libperlx-assert-perl_0.905-1_all.deb


Advertisement

Description

libperlx-assert-perl - yet another assertion keyword

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperlx-assert-perl
Package version 0.905
Package release 1
Package architecture all
Package type deb
Installed size 36 B
Download size 8.76 KB
Official Mirror archive.ubuntu.com
PerlX::Assert is a framework for embedding assertions in Perl code.
Under normal circumstances, assertions are not checked; they are
optimized away at compile time.
However if, at compile time, any of the following environment variables
is true, assertions are checked, and if they fail, throw an exception.
- PERL_STRICT
- AUTHOR_TESTING
- EXTENDED_TESTING
- RELEASE_TESTING
That is, assertions will only typically be checked when the test suite
is being run on the authors' machine, or otherwise opted into.

Alternatives

Package Version Architecture Repository
libperlx-assert-perl_0.905-1_all.deb 0.905 all Ubuntu Universe
libperlx-assert-perl - - -

Requires

Name Value
libdevel-declare-perl -
libdevel-strictmode-perl -
libexporter-tiny-perl -
libkeyword-simple-perl -
perl -

Download

Type URL
Binary Package libperlx-assert-perl_0.905-1_all.deb
Source Package libperlx-assert-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperlx-assert-perl deb package:
    # sudo apt-get install libperlx-assert-perl

Files

Path
/usr/share/doc/libperlx-assert-perl/CREDITS
/usr/share/doc/libperlx-assert-perl/README
/usr/share/doc/libperlx-assert-perl/changelog.Debian.gz
/usr/share/doc/libperlx-assert-perl/copyright
/usr/share/man/man3/PerlX::Assert.3pm.gz
/usr/share/perl5/PerlX/Assert.pm
/usr/share/perl5/PerlX/Assert/DD.pm
/usr/share/perl5/PerlX/Assert/Keyword.pm

Changelog

2017-07-11 - gregor herrmann <gregoa@debian.org>
libperlx-assert-perl (0.905-1) unstable; urgency=medium
* Team upload.
* Add libkeyword-simple-perl, libdevel-declare-perl to Depends.
(Closes: #868075)
* Bump debhelper compatibility level to 9.
* Use canonical URL for Vcs-Git.
* Declare compliance with Debian Policy 4.0.0.
* New upstream version 0.905.
Fixes "FTBFS with perl 5.26: Unescaped left brace in regex"
(Closes: #826489)
* Update years of upstream copyright.
* Drop mention of removed CONTRIBUTING file from debian/copyright.
* debian/gbp.conf: replace git-import-orig with import-orig.
2015-02-24 - Jonas Smedegaard <dr@jones.dk>
libperlx-assert-perl (0.904-1) unstable; urgency=low
* Initial packaging release.
Closes: bug#779132.

See Also

Package Description
libperlx-maybe-perl_1.001-1_all.deb return a pair only if they are both defined
libperlx-maybe-xs-perl_1.001-2build4_i386.deb XS backend for PerlX::Maybe
libpetal-perl_2.23-2_all.deb Perl Template Attribute Language - TAL for perl
libpetal-utils-perl_0.06-3_all.deb Useful template modifiers for Petal
libpetsc-complex-3.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc-complex-3.7.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc-complex-3.7.7_3.7.7+dfsg1-2build5_i386.deb Shared libraries for version 3.7 of PETSc with Complex Numbers
libpetsc3.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc3.7.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc3.7.7_3.7.7+dfsg1-2build5_i386.deb Shared libraries for version 3.7 of PETSc
libpff-dev_20120802-5.1_i386.deb library to access various ms outlook files formats (development)
libpff1_20120802-5.1_i386.deb library to access various ms outlook files formats
libpfqueue-dev_0.5.6-9build2_i386.deb interactive console-based tool to control MTA queues (development)
libpfqueue0_0.5.6-9build2_i386.deb interactive console-based tool to control MTA queues (library)
libpfs-dev_2.1.0-3_i386.deb C++ library to read and write pfs files (development files)
Advertisement
Advertisement