libperl6-export-perl_0.009-1_all.deb


Advertisement

Description

libperl6-export-perl - implementation of the Perl 6 'is export(...)' trait

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperl6-export-perl
Package version 0.009
Package release 1
Package architecture all
Package type deb
Installed size 29 B
Download size 9.15 KB
Official Mirror archive.ubuntu.com
Perl6::Export prototypes the Perl 6 'exported' and 'exportable' traits
in Perl 5.
Instead of messing around with @EXPORT arrays, you just declare which
subs are to be exported (or are exportable on request) as part of
those subs.

Alternatives

Package Version Architecture Repository
libperl6-export-perl_0.009-1_all.deb 0.009 all Ubuntu Universe
libperl6-export-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libperl6-export-perl_0.009-1_all.deb
Source Package libperl6-export-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperl6-export-perl deb package:
    # sudo apt-get install libperl6-export-perl

Files

Path
/usr/share/doc/libperl6-export-perl/changelog.Debian.gz
/usr/share/doc/libperl6-export-perl/copyright
/usr/share/doc/libperl6-export-perl/examples/Demo_Export.pm
/usr/share/doc/libperl6-export-perl/examples/Demo_IMPORT.pm
/usr/share/doc/libperl6-export-perl/examples/demo_IMPORT.pl
/usr/share/doc/libperl6-export-perl/examples/demo_export.pl
/usr/share/man/man3/Perl6::Export.3pm.gz
/usr/share/perl5/Perl6/Export.pm

Changelog

2015-11-24 - Florian Schlichting <fsfs@debian.org>
libperl6-export-perl (0.009-1) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: Added: ${misc:Depends} to Depends: field.
* Change my email address.
* Strip trailing slash from metacpan URLs.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Florian Schlichting ]
* Switch to source format 3.0 (quilt)
* Import upstream version 0.009
* Ship demo as example
* Use short form debian/rules
* Convert d/copryright to copyright-format 1.0
* Bump dh compat to level 9
* Brush up short and long description
* Declare compliance with Debian Policy 3.9.6
* Mark package autopkgtest-able
* Don't ship executable examples without interpreter
2008-03-11 - gregor herrmann <gregor+debian@comodo.priv.at>
libperl6-export-perl (0.07-10) unstable; urgency=low
[ Joachim Breitner ]
* Removed myself from uploaders.
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Removed: XS-
Vcs-Svn fields.
* Remove ./COPYRIGHT (not in upstream tarball), revert change to MANIFEST.
* debian/rules:
- delete /usr/lib/perl5 only if it exists (closes: #467849)
- update based on dh-make-perl's templates
- don't install the "upstream" COPYRIGHT any more
* debian/watch: use dist-based URL.
* Set Standards-Version to 3.7.3 (no changes).
2006-10-01 - gregor herrmann <gregor+debian@comodo.priv.at>
libperl6-export-perl (0.07-9) unstable; urgency=low
* Use $(CURDIR) [make] instead of $(PWD) [sh] to fix issues with sudo.
2006-06-16 - gregor herrmann <gregor+debian@comodo.priv.at>
libperl6-export-perl (0.07-8) unstable; urgency=low
* Moved debhelper to Build-Depends.
* Set Standards-Version to 3.7.2 (no changes).
* Set Debhelper Compatibility Level to 5.
* Removed empty /usr/lib/perl5 from package.
2005-09-01 - Gunnar Wolf <gwolf@debian.org>
libperl6-export-perl (0.07-7) unstable; urgency=low
* Modified debian/watch so it does not get confused with modules
sharing the namespace (i.e. Perl6::Export::Attrs)
2004-11-28 - Gunnar Wolf <gwolf@debian.org>
libperl6-export-perl (0.07-6) unstable; urgency=low
* Fix dependencies: let dh_perl decide
(Thanks Brendan O'Dea <bod@debian.org>)
* Corrected: No longer a native package, upstream tarball uploaded
2004-08-30 - Gunnar Wolf <gwolf@debian.org>
libperl6-export-perl (0.07-5) unstable; urgency=low
* Small typo in package description (Closes: #262287)
2004-05-04 - Gunnar Wolf <gwolf@debian.org>
libperl6-export-perl (0.07-4) unstable; urgency=low
* Last version moved the man page from ".3pm" to ".3" - I stand
corrected, moved it back to ".3pm". Sorry.
2004-05-03 - Gunnar Wolf <gwolf@debian.org>
libperl6-export-perl (0.07-3) unstable; urgency=low
* Minor (aesthetic) fixes in debian/copyright, debian/control
* First version uploaded to Debian (Closes: #247244)
* Man file no longer has a "3pm" extension, now uses standard "3"
2004-04-26 - Allard Hoeve <allard@byte.nl>
libperl6-export-perl (0.07-2) unstable; urgency=low
* Add Uploaders: line to add Joachum, Gunnar and me
* Update Standards-Version: to 3.6.1

See Also

Package Description
libperl6-form-perl_0.06-1_all.deb Perl 5 implementation of the Perl 6 'form' built-in
libperl6-junction-perl_1.60000-1_all.deb module providing Perl6-style Junction operators in Perl5
libperl6-say-perl_0.16-1_all.deb module to print without newline needed
libperl6-slurp-perl_0.051005-1_all.deb module implementing the Perl 6 'slurp' built-in
libperlanet-perl_0.56-3_all.deb program for creating programs that aggregate web feeds
libperlbal-perl_1.80-3_all.deb Perlbal libraries; embed perlbal into another app
libperlbal-xs-httpheaders-perl_0.20-2build5_i386.deb Perlbal extension for processing HTTP headers faster
libperldoc-search-perl_0.01-3_all.deb Index and Search local Perl Documentation
libperlio-eol-perl_0.17-1_i386.deb PerlIO layer for normalizing line endings
libperlio-layers-perl_0.011-1build2_i386.deb Perl module to query a filehandle's capabilities
libperlio-utf8-strict-perl_0.007-2_i386.deb fast and correct UTF-8 Perl IO module
libperlio-via-dynamic-perl_0.14-1_all.deb module to create dynamic PerlIO layers
libperlio-via-symlink-perl_0.05-3_all.deb PerlIO layer for creating symlinks
libperlio-via-timeout-perl_0.32-1_all.deb PerlIO layer that adds read & write timeout to a handle
libperlmenu-perl_4.0-5_all.deb Menu and Template (curses-based) UI for Perl
Advertisement
Advertisement