libperl-metrics-simple-perl_0.18-1_all.deb


Advertisement

Description

libperl-metrics-simple-perl - module to provide metrics of Perl code

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperl-metrics-simple-perl
Package version 0.18
Package release 1
Package architecture all
Package type deb
Installed size 131 B
Download size 30.84 KB
Official Mirror archive.ubuntu.com
Perl::Metrics::Simple is a Perl module that provides several useful methods
for static analysis of one or many Perl files. It currently offers these
metrics: packages, subroutines, lines of code, and an approximation of
cyclomatic (mccabe) complexity for the subroutines and the "main" portion
of the code.
This module is designed to be simpler than the similar Perl::Metric module.

Alternatives

Package Version Architecture Repository
libperl-metrics-simple-perl_0.18-1_all.deb 0.18 all Ubuntu Universe
libperl-metrics-simple-perl - - -

Requires

Name Value
libppi-perl -
libreadonly-perl -
libstatistics-basic-perl -
perl -

Download

Type URL
Binary Package libperl-metrics-simple-perl_0.18-1_all.deb
Source Package libperl-metrics-simple-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperl-metrics-simple-perl deb package:
    # sudo apt-get install libperl-metrics-simple-perl

Files

Path
/usr/bin/countperl
/usr/share/doc/libperl-metrics-simple-perl/Todo
/usr/share/doc/libperl-metrics-simple-perl/changelog.Debian.gz
/usr/share/doc/libperl-metrics-simple-perl/copyright
/usr/share/man/man1/countperl.1p.gz
/usr/share/man/man3/Perl::Metrics::Simple.3pm.gz
/usr/share/man/man3/Perl::Metrics::Simple::Analysis.3pm.gz
/usr/share/man/man3/Perl::Metrics::Simple::Analysis::File.3pm.gz
/usr/share/perl5/Perl/Metrics/Simple.pm
/usr/share/perl5/Perl/Metrics/Simple/Analysis.pm
/usr/share/perl5/Perl/Metrics/Simple/Analysis/File.pm

Changelog

2015-05-30 - gregor herrmann <gregoa@debian.org>
libperl-metrics-simple-perl (0.18-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* debian/control: update Module::Build dependency.
* Add debian/upstream/metadata
* Import upstream version 0.18
* Update years of upstream copyright.
* Declare compliance with Debian Policy 3.9.6.
* Mark package as autopkgtest-able.
2013-10-03 - Florian Schlichting <fsfs@debian.org>
libperl-metrics-simple-perl (0.17-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Florian Schlichting ]
* Import Upstream version 0.17
* Add build-dependency on Module::Build 0.40
* Update stand-alone license paragraphs to commonly used form (not
referencing GNU/Linux, directly linking GPL-1)
* Wrap and sort dependencies
* Bump dh compatibility to level 8 (no changes necessary)
* Declare compliance with Debian Policy 3.9.4
* Add myself to uploaders and copyright
2010-05-13 - Jonathan Yu <jawnsy@cpan.org>
libperl-metrics-simple-perl (0.15-1) unstable; urgency=low
* New upstream release
* Use new 3.0 (quilt) source format
2010-02-08 - Jonathan Yu <jawnsy@cpan.org>
libperl-metrics-simple-perl (0.14-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Use short debhelper rules format
* Update copyright to DEP5 format
* Rewrite control description
* Standards-Version 3.8.4 (no changes)
* Drop version dependencies satisfied in oldstable
* Drop Module::Build, Makefile.PL is traditional
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ryan Niebur ]
* Update ryan52's email address
[ gregor herrmann ]
* debian/control: Changed: (build-)depend on perl instead of perl-
modules.
2009-05-07 - Ryan Niebur <ryanryan52@gmail.com>
libperl-metrics-simple-perl (0.13-1) unstable; urgency=low
* New upstream release
* update copyright
2009-05-02 - Ryan Niebur <ryanryan52@gmail.com>
libperl-metrics-simple-perl (0.12-1) unstable; urgency=low
* Initial Release. (Closes: #526245)

See Also

Package Description
libperl-minimumversion-perl_1.38-1_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-1_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5build2_all.deb Use Perl code in OCaml programs, documentation
libperl4caml-ocaml_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, runtime library
libperl5i-perl_2.13.2-1_i386.deb pragma to fix as much of Perl 5 as possible
libperl6-caller-perl_0.100-3_all.deb Perl6-like OO caller() interface for Perl 5
libperl6-export-attrs-perl_0.000005-1_all.deb Perl 6 'is export(...)' trait as a Perl 5 attribute
libperl6-export-perl_0.009-1_all.deb implementation of the Perl 6 'is export(...)' trait
libperl6-form-perl_0.06-1_all.deb Perl 5 implementation of the Perl 6 'form' built-in
libperl6-junction-perl_1.60000-1_all.deb module providing Perl6-style Junction operators in Perl5
libperl6-say-perl_0.16-1_all.deb module to print without newline needed
Advertisement
Advertisement