libperl-apireference-perl_0.22-7_all.deb


Advertisement

Description

libperl-apireference-perl - Perl module to programmatically query the perlapi

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperl-apireference-perl
Package version 0.22
Package release 7
Package architecture all
Package type deb
Installed size 1.81 KB
Download size 1.39 MB
Official Mirror archive.ubuntu.com
Perl::APIReference is a Perl module that allows Perl programs to access the
perlapi documentation for multiple releases of perl as an index (a hash). It
supports a multitude of perl versions, starting from 5.6.

Alternatives

Package Version Architecture Repository
libperl-apireference-perl_0.22-7_all.deb 0.22 all Ubuntu Universe
libperl-apireference-perl - - -

Requires

Name Value
libclass-xsaccessor-perl -
libpod-eventual-perl -
libsereal-decoder-perl >= 3.005
libsereal-encoder-perl >= 3.005
perl -

Download

Type URL
Binary Package libperl-apireference-perl_0.22-7_all.deb
Source Package libperl-apireference-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperl-apireference-perl deb package:
    # sudo apt-get install libperl-apireference-perl

Files

Path
/usr/share/doc/libperl-apireference-perl/changelog.Debian.gz
/usr/share/doc/libperl-apireference-perl/copyright
/usr/share/man/man3/Perl::APIReference.3pm.gz
/usr/share/man/man3/Perl::APIReference::Generator.3pm.gz
/usr/share/perl5/Perl/APIReference.pm
/usr/share/perl5/Perl/APIReference/Generator.pm
/usr/share/perl5/Perl/APIReference/V5_006_000.pm
/usr/share/perl5/Perl/APIReference/V5_006_001.pm
/usr/share/perl5/Perl/APIReference/V5_006_002.pm
/usr/share/perl5/Perl/APIReference/V5_008_000.pm
/usr/share/perl5/Perl/APIReference/V5_008_001.pm
/usr/share/perl5/Perl/APIReference/V5_008_002.pm
/usr/share/perl5/Perl/APIReference/V5_008_003.pm
/usr/share/perl5/Perl/APIReference/V5_008_004.pm
/usr/share/perl5/Perl/APIReference/V5_008_005.pm
/usr/share/perl5/Perl/APIReference/V5_008_006.pm
/usr/share/perl5/Perl/APIReference/V5_008_007.pm
/usr/share/perl5/Perl/APIReference/V5_008_008.pm
/usr/share/perl5/Perl/APIReference/V5_008_009.pm
/usr/share/perl5/Perl/APIReference/V5_010_000.pm
/usr/share/perl5/Perl/APIReference/V5_010_001.pm
/usr/share/perl5/Perl/APIReference/V5_012_000.pm
/usr/share/perl5/Perl/APIReference/V5_012_001.pm
/usr/share/perl5/Perl/APIReference/V5_012_002.pm
/usr/share/perl5/Perl/APIReference/V5_012_003.pm
/usr/share/perl5/Perl/APIReference/V5_012_004.pm
/usr/share/perl5/Perl/APIReference/V5_012_005.pm
/usr/share/perl5/Perl/APIReference/V5_014_000.pm
/usr/share/perl5/Perl/APIReference/V5_014_001.pm
/usr/share/perl5/Perl/APIReference/V5_014_002.pm
/usr/share/perl5/Perl/APIReference/V5_014_003.pm
/usr/share/perl5/Perl/APIReference/V5_014_004.pm
/usr/share/perl5/Perl/APIReference/V5_014_005.pm
/usr/share/perl5/Perl/APIReference/V5_016_000.pm
/usr/share/perl5/Perl/APIReference/V5_016_001.pm
/usr/share/perl5/Perl/APIReference/V5_016_002.pm
/usr/share/perl5/Perl/APIReference/V5_016_003.pm
/usr/share/perl5/Perl/APIReference/V5_018_000.pm
/usr/share/perl5/Perl/APIReference/V5_018_001.pm
/usr/share/perl5/Perl/APIReference/V5_018_002.pm
/usr/share/perl5/Perl/APIReference/V5_020_000.pm
/usr/share/perl5/Perl/APIReference/V5_020_001.pm
/usr/share/perl5/Perl/APIReference/V5_020_002.pm
/usr/share/perl5/Perl/APIReference/V5_022_000.pm
/usr/share/perl5/Perl/APIReference/V5_022_001.pm
/usr/share/perl5/Perl/APIReference/V5_022_002.pm
/usr/share/perl5/Perl/APIReference/V5_024_000.pm
/usr/share/perl5/Perl/APIReference/V5_024_001.pm
/usr/share/perl5/Perl/APIReference/V5_026_000.pm
/usr/share/perl5/Perl/APIReference/V5_026_001.pm

Changelog

2017-11-05 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.22-7) unstable; urgency=medium
* Handle 5.26.1. as a full release instead of an alias.
While the latter is correct it makes the build fail as we are looking for
a file corresponding to the current perl version.
Thanks to Adrian Bunk for the bug report. Closes: #880843
* Update long description.
Don't mention the most recent perl version number, which changes on each
release.
* Declare compliance with Debian Policy 4.1.1.
2017-10-21 - Damyan Ivanov <dmn@debian.org>
libperl-apireference-perl (0.22-6) unstable; urgency=medium
* Add support for 5.26.1 (no changes since 5.26.0)
2017-06-20 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.22-5) unstable; urgency=medium
* Add support for 5.26.0.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.0.0.
2016-09-26 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.22-4) unstable; urgency=medium
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
* Add support for 5.24.1. (Closes: #838934)
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.8.
2016-05-28 - Dominic Hargreaves <dom@earth.li>
libperl-apireference-perl (0.22-3) unstable; urgency=medium
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Dominic Hargreaves ]
* Add support for 5.24.0 (Closes: #825613)
2016-04-30 - Dominic Hargreaves <dom@earth.li>
libperl-apireference-perl (0.22-2) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Dominic Hargreaves ]
* Add support for 5.22.2 (Closes: #823057)
2015-12-30 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.22-1) unstable; urgency=medium
* New upstream release.
* Revert "Add support for 5.22.1."
The data for 5.22.1 are now contained in the new 0.22 release.
* Drop 0001-Make-the-stored-data-reproducible-between-builds.patch
(merged upstream).
* Add debian/upstream/metadata.
2015-12-23 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.21-3) unstable; urgency=medium
* Add support for 5.22.1. (Closes: #808825)
2015-12-05 - Niko Tyni <ntyni@debian.org>
libperl-apireference-perl (0.21-2) unstable; urgency=medium
* Team upload.
* Make the stored data reproducible between builds. (Closes: #807111)
2015-11-09 - gregor herrmann <gregoa@debian.org>
libperl-apireference-perl (0.21-1) unstable; urgency=medium
* Imported Upstream version 0.21.
* Revert "Add perlapi.pod for 5.22 and patch for Perl::APIReference".
The data for 5.22 are included upstream in 0.20.
* Add (build) dependecy on libsereal-{de,en}coder-perl.
* Bump debhelper compatibility level to 9.

See Also

Package Description
libperl-critic-perl_1.130-1_all.deb Perl module to critique code for best practices
libperl-destruct-level-perl_0.02-2build4_i386.deb Perl module to change Perl's destruction level
libperl-metrics-simple-perl_0.18-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-1_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-1_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5build2_all.deb Use Perl code in OCaml programs, documentation
libperl4caml-ocaml_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, runtime library
libperl5i-perl_2.13.2-1_i386.deb pragma to fix as much of Perl 5 as possible
libperl6-caller-perl_0.100-3_all.deb Perl6-like OO caller() interface for Perl 5
libperl6-export-attrs-perl_0.000005-1_all.deb Perl 6 'is export(...)' trait as a Perl 5 attribute
libperl6-export-perl_0.009-1_all.deb implementation of the Perl 6 'is export(...)' trait
Advertisement
Advertisement