libperinci-sub-normalize-perl_0.19-1_all.deb


Advertisement

Description

libperinci-sub-normalize-perl - Perl module to normalize Rinci function metadata

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperinci-sub-normalize-perl
Package version 0.19
Package release 1
Package architecture all
Package type deb
Installed size 24 B
Download size 6.61 KB
Official Mirror archive.ubuntu.com
Perinci::Sub::Normalize normalizes and checks Rinci function metadata $meta
and returns a normalized metadata, which is a shallow copy of $meta. This is
done by normalize_function_metadata subroutine.

Alternatives

Package Version Architecture Repository
libperinci-sub-normalize-perl_0.19-1_all.deb 0.19 all Ubuntu Universe
libperinci-sub-normalize-perl - - -

Requires

Name Value
libdata-sah-normalize-perl -
librinci-perl >= 1.1.80
libsah-schemas-rinci-perl >= 1.1.82
perl -

Download

Type URL
Binary Package libperinci-sub-normalize-perl_0.19-1_all.deb
Source Package libperinci-sub-normalize-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperinci-sub-normalize-perl deb package:
    # sudo apt-get install libperinci-sub-normalize-perl

Files

Path
/usr/share/doc/libperinci-sub-normalize-perl/changelog.Debian.gz
/usr/share/doc/libperinci-sub-normalize-perl/copyright
/usr/share/man/man3/Perinci::Sub::Normalize.3pm.gz
/usr/share/perl5/Perinci/Sub/Normalize.pm

Changelog

2016-12-26 - gregor herrmann <gregoa@debian.org>
libperinci-sub-normalize-perl (0.19-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.19.
* Update (build) dependencies.
2016-10-26 - gregor herrmann <gregoa@debian.org>
libperinci-sub-normalize-perl (0.18-2) unstable; urgency=medium
* Team upload.
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
* Add (build) dependency on libsah-schemas-rinci-perl. (Closes: #840980)
2016-05-12 - gregor herrmann <gregoa@debian.org>
libperinci-sub-normalize-perl (0.18-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.18
* Bump (build) dependency on librinci-perl to 1.1.80-1.
(Closes: #824143)
2016-04-13 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libperinci-sub-normalize-perl (0.16-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Lucas Kanashiro ]
* Imported Upstream version 0.16
* d/u/metadata: update Repository{-Browse,}
* Declare compliance with Debian policy 3.9.8
2016-01-10 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libperinci-sub-normalize-perl (0.15-1) unstable; urgency=low
* Initial Release. (Closes: #810625)

See Also

Package Description
libperinci-sub-util-perl_0.46-1_all.deb Perl module that is a helper to write functions
libperinci-sub-util-propertymodule-perl_0.46-1_all.deb module to detect which property modules are used with Perinci
libperl-apireference-perl_0.22-7_all.deb Perl module to programmatically query the perlapi
libperl-critic-perl_1.130-1_all.deb Perl module to critique code for best practices
libperl-destruct-level-perl_0.02-2build4_i386.deb Perl module to change Perl's destruction level
libperl-metrics-simple-perl_0.18-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-1_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-1_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5build2_all.deb Use Perl code in OCaml programs, documentation
libperl4caml-ocaml_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, runtime library
libperl5i-perl_2.13.2-1_i386.deb pragma to fix as much of Perl 5 as possible
Advertisement
Advertisement