libperinci-object-perl_0.30-1_all.deb


Advertisement

Description

libperinci-object-perl - module that provides a object-oriented interface for Rinci

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libperinci-object-perl
Package version 0.30
Package release 1
Package architecture all
Package type deb
Installed size 70 B
Download size 27.36 KB
Official Mirror archive.ubuntu.com
Rinci works using pure data structures, but sometimes it's convenient to have
an object-oriented interface (wrapper) for those data. Perinci::Object module
provides just that.

Alternatives

Package Version Architecture Repository
libperinci-object-perl_0.30-1_all.deb 0.30 all Ubuntu Universe
libperinci-object-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libperinci-object-perl_0.30-1_all.deb
Source Package libperinci-object-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperinci-object-perl deb package:
    # sudo apt-get install libperinci-object-perl

Files

Path
/usr/share/doc/libperinci-object-perl/changelog.Debian.gz
/usr/share/doc/libperinci-object-perl/copyright
/usr/share/man/man3/Perinci::Object.3pm.gz
/usr/share/man/man3/Perinci::Object::EnvResult.3pm.gz
/usr/share/man/man3/Perinci::Object::EnvResultMulti.3pm.gz
/usr/share/man/man3/Perinci::Object::EnvResultTable.3pm.gz
/usr/share/man/man3/Perinci::Object::Function.3pm.gz
/usr/share/man/man3/Perinci::Object::Metadata.3pm.gz
/usr/share/man/man3/Perinci::Object::Package.3pm.gz
/usr/share/man/man3/Perinci::Object::ResMeta.3pm.gz
/usr/share/man/man3/Perinci::Object::Variable.3pm.gz
/usr/share/perl5/Perinci/Object.pm
/usr/share/perl5/Perinci/Object/EnvResult.pm
/usr/share/perl5/Perinci/Object/EnvResultMulti.pm
/usr/share/perl5/Perinci/Object/EnvResultTable.pm
/usr/share/perl5/Perinci/Object/Function.pm
/usr/share/perl5/Perinci/Object/Metadata.pm
/usr/share/perl5/Perinci/Object/Package.pm
/usr/share/perl5/Perinci/Object/ResMeta.pm
/usr/share/perl5/Perinci/Object/Variable.pm

Changelog

2018-01-01 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.30-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.30.
* Update years of upstream copyright.
* Declare compliance with Debian Policy 4.1.3.
* Bump debhelper compatibility level to 10.
2016-12-28 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.29-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.29.
* Update debian/upstream/metadata.
2016-12-27 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.28-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.28.
2016-12-26 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.27-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.27.
* Update Git URLs in debian/upstream/metadata.
* Drop (build) dependency on libstring-trim-more-perl as per
upstream changes.
2016-12-22 - Lucas Kanashiro <kanashiro@debian.org>
libperinci-object-perl (0.26-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.26
* d/u/metadata: update repository links
2016-11-29 - Lucas Kanashiro <kanashiro@debian.org>
libperinci-object-perl (0.25-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ Lucas Kanashiro ]
* Import upstream version 0.25
* d/u/metadata: update repository info
* Update years of upstream copyright
* Update Debian packaging copyright
* Declare compliance with Debian policy 3.9.8
* debian/control: remove build dep on versioned libtest-simple-perl
2015-12-06 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libperinci-object-perl (0.24-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Lucas Kanashiro ]
* Add debian/upstream/metadata
* Import upstream version 0.24
* Update upstream copyright and contact in debian/copyright
* Bump debhelper compatibility level to 9
* Declare compliance with Debian policy 3.9.6
* Update runtime and build dependencies
* Update long description to have more than 2 lines.
Silence lintian extended-description-is-probably-too-short
2014-01-11 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.13-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update year of upstream copyright.
2013-12-22 - gregor herrmann <gregoa@debian.org>
libperinci-object-perl (0.12-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update years of upstream copyright.
* Declare compliance with Debian Policy 3.9.5.
2013-08-25 - Joenio Costa <joenio@colivre.coop.br>
libperinci-object-perl (0.11-1) unstable; urgency=low
* Initial Release. (Closes: #721276)

See Also

Package Description
libperinci-sub-normalize-perl_0.19-1_all.deb Perl module to normalize Rinci function metadata
libperinci-sub-util-perl_0.46-1_all.deb Perl module that is a helper to write functions
libperinci-sub-util-propertymodule-perl_0.46-1_all.deb module to detect which property modules are used with Perinci
libperl-apireference-perl_0.22-7_all.deb Perl module to programmatically query the perlapi
libperl-critic-perl_1.130-1_all.deb Perl module to critique code for best practices
libperl-destruct-level-perl_0.02-2build4_i386.deb Perl module to change Perl's destruction level
libperl-metrics-simple-perl_0.18-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-1_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-1_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5build2_all.deb Use Perl code in OCaml programs, documentation
libperl4caml-ocaml_0.9.5-5build2_i386.deb Use Perl code in OCaml programs, runtime library
Advertisement
Advertisement