libpeas-1.0-python2loader_1.22.0-2_i386.deb


Advertisement

Description

libpeas-1.0-python2loader - Application plugin library (Python 2 support)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpeas-1.0-python2loader
Package version 1.22.0
Package release 2
Package architecture i386
Package type deb
Installed size 45 B
Download size 11.21 KB
Official Mirror archive.ubuntu.com
libpeas is a library that allows applications to support plugins.
This package contains the Python 2 loader shared library.
If your plugin is written in Python 2, please consider porting it to
Python 3 and drop the dependency on this package.
This package exists only for backwards-compatibility with plugins
that have not yet been ported. It should be considered deprecated.

Alternatives

Package Version Architecture Repository
libpeas-1.0-python2loader_1.22.0-2_amd64.deb 1.22.0 amd64 Ubuntu Universe
libpeas-1.0-python2loader - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.38.0
libpeas-1.0-0 = 1.22.0-2
libpeas-common -
libpython2.7 >= 2.7

Provides

Name Value
libpeas-1.0-0-python2loader -

Conflicts

Name Value
libpeas-1.0-0-python2loader -

Replaces

Name Value
libpeas-1.0-0 << 1.8.0-2
libpeas-1.0-0-python2loader -

Download

Type URL
Binary Package libpeas-1.0-python2loader_1.22.0-2_i386.deb
Source Package libpeas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpeas-1.0-python2loader deb package:
    # sudo apt-get install libpeas-1.0-python2loader

Files

Path
/usr/lib/i386-linux-gnu/libpeas-1.0/loaders/libpythonloader.so
/usr/share/doc/libpeas-1.0-python2loader/changelog.Debian.gz
/usr/share/doc/libpeas-1.0-python2loader/copyright

Changelog

2017-12-19 - Jeremy Bicha <jbicha@debian.org>
libpeas (1.22.0-2) unstable; urgency=medium
[ Simon McVittie ]
* gir1.2-peas-1.0 Provides gir1.2-peasgtk-1.0, reflecting the fact
that it contains both Peas-1.0.typelib and PeasGtk-1.0.typelib
* Bump priorities from extra to optional. Priority: extra is now
deprecated.
[ Jeremy Bicha ]
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Bump Standards-Version to 4.1.2
* Bump debhelper compat to 11
* Build with all hardening flags
2017-09-10 - Jeremy Bicha <jbicha@debian.org>
libpeas (1.22.0-1) unstable; urgency=medium
* New upstream translations release
2017-08-29 - Jeremy Bicha <jbicha@ubuntu.com>
libpeas (1.21.0-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.1.0
2016-09-19 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.20.0-1) unstable; urgency=medium
* Convert from cdbs to dh.
* Bump to dh compat 10 (automatic dh-autoreconf)
* Add explicit gnome-common build-dependency (Closes: #837844)
* New upstream release.
2016-07-05 - Iain Lane <laney@debian.org>
libpeas (1.18.0-3) unstable; urgency=medium
* Convert to multiarch. (Closes: #815727)
* Add some Conflicts/Replaces/Provides for the benefit of users
transitioning from Ubuntu's different loader split.
2016-04-15 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.18.0-2) unstable; urgency=medium
* Add Build-Depends-Package meta-tags to symbols file.
* Split out python2 loader in a separate package (Closes: #806824)
* Use --fail-missing when installing package files.
* Bump Standards-Version to 3.9.8
2016-04-02 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.18.0-1) experimental; urgency=medium
[ Hideki Yamane ]
* debian/watch
- adjust to new upstream URL
[ Andreas Henriksson ]
* New upstream release.
* Drop debian/patches/0001-Fix-Python-plugin-loader-module-paths.patch
- merged upstream.
* Bump Standards-Version to 3.9.7
* Append '-V -- -c4' to dh makeshlib args.
- prevents package being built with auto-generated symbols file.
* Update debian/libpeas-1.0-0.symbols with three additions.
2015-09-22 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.16.0-1) unstable; urgency=medium
* New upstream release.
* Update debian/patches/0001-Fix-Python-plugin-loader-module-paths.patch
- replace patch from gnome bugzilla with commit from upstream git.
2015-09-04 - Michael Biebl <biebl@debian.org>
libpeas (1.14.0-1) unstable; urgency=medium
[ Iain Lane ]
* Depend on adwaita-icon-theme for the test. This is GNOME's new default
icon theme.
[ Jackson Doak ]
* New upstream release
[ Andreas Henriksson ]
* Fix Homepage url (breakage spotted by DUCK by skanz@d.o)
[ Michael Biebl ]
* Bump Build-Depends as per configure.ac.
* Drop obsolete --disable-seed configure flag.
* Update symbols file. Mark private symbols as optional.
* Bump debhelper compatibility level to 9.
* Drop obsolete Conflicts and Replaces from pre-wheezy.
* Fix Python plugin loader module paths. Patch taken from bgo#753401.
2014-11-06 - Emilio Pozuelo Monfort <pochu@debian.org>
libpeas (1.12.1-2) unstable; urgency=medium
* Disable seed support everywhere.

See Also

Package Description
libpegdown-java_1.6.0-1_all.deb Lightweight Markdown processing library
libpegex-perl_0.64-1_all.deb Acmeist PEG Parser Framework
libpentaho-reporting-flow-engine-java-doc_0.9.4-5_all.deb report library for java documentation
libpentaho-reporting-flow-engine-java_0.9.4-5_all.deb report library for java
libpeony-extension-dev_1.1.1-0ubuntu2_i386.deb libraries for Peony components (development files)
libpeony-extension-doc_1.1.1-0ubuntu2_all.deb libraries for Peony components (API documentation files)
libpeony-extension1_1.1.1-0ubuntu2_i386.deb libraries for Peony components
libperformance-dev_0.5.0-1build1_i386.deb GNUstep performance library (development files)
libperformance0.5_0.5.0-1build1_i386.deb GNUstep performance library (runtime library)
libperinci-cmdline-perl_1.77-1_all.deb Rinci/Riap-based command-line application framework
libperinci-object-perl_0.30-1_all.deb module that provides a object-oriented interface for Rinci
libperinci-sub-normalize-perl_0.19-1_all.deb Perl module to normalize Rinci function metadata
libperinci-sub-util-perl_0.46-1_all.deb Perl module that is a helper to write functions
libperinci-sub-util-propertymodule-perl_0.46-1_all.deb module to detect which property modules are used with Perinci
libperl-apireference-perl_0.22-7_all.deb Perl module to programmatically query the perlapi
Advertisement
Advertisement