rpm_4.14.1+dfsg1-2_amd64.deb


Advertisement

Description

rpm - package manager for RPM

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name rpm
Package version 4.14.1+dfsg1
Package release 2
Package architecture amd64
Package type deb
Installed size 414 B
Download size 116.26 KB
Official Mirror archive.ubuntu.com
The RPM Package Manager (RPM) is a command-line driven package
management system capable of installing, uninstalling, verifying,
querying, and updating computer software packages.
On Debian and derived systems it is recommended to use "alien" to
convert RPM packages into .deb format instead of bypassing the Debian
package management system by installing them directly with rpm.

Alternatives

Package Version Architecture Repository
rpm_4.14.1+dfsg1-2_i386.deb 4.14.1+dfsg1 i386 Ubuntu Universe
rpm - - -

Requires

Name Value
debugedit = 4.14.1+dfsg1-2
libc6 >= 2.17
libelf1 >= 0.131
libpopt0 >= 1.14
librpm8 >= 4.14.0+dfsg1
librpmbuild8 >= 4.14.0+dfsg1
librpmio8 >= 4.14.0+dfsg1
librpmsign8 >= 4.14.0+dfsg1
perl:any -
rpm-common = 4.14.1+dfsg1-2
rpm2cpio -

Download

Type URL
Binary Package rpm_4.14.1+dfsg1-2_amd64.deb
Source Package rpm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rpm deb package:
    # sudo apt-get install rpm

Files

Path
/usr/bin/gendiff
/usr/bin/rpm
/usr/bin/rpmbuild
/usr/bin/rpmdb
/usr/bin/rpmgraph
/usr/bin/rpmkeys
/usr/bin/rpmquery
/usr/bin/rpmsign
/usr/bin/rpmspec
/usr/bin/rpmverify
/usr/lib/rpm/brp-compress
/usr/lib/rpm/brp-java-gcjcompile
/usr/lib/rpm/brp-python-bytecompile
/usr/lib/rpm/brp-python-hardlink
/usr/lib/rpm/brp-strip
/usr/lib/rpm/brp-strip-comment-note
/usr/lib/rpm/brp-strip-shared
/usr/lib/rpm/brp-strip-static-archive
/usr/lib/rpm/check-buildroot
/usr/lib/rpm/check-files
/usr/lib/rpm/check-prereqs
/usr/lib/rpm/check-rpaths
/usr/lib/rpm/check-rpaths-worker
/usr/lib/rpm/debuginfo.prov
/usr/lib/rpm/desktop-file.prov
/usr/lib/rpm/elfdeps
/usr/lib/rpm/find-debuginfo.sh
/usr/lib/rpm/find-lang.sh
/usr/lib/rpm/find-provides
/usr/lib/rpm/find-requires
/usr/lib/rpm/fontconfig.prov
/usr/lib/rpm/libtooldeps.sh
/usr/lib/rpm/metainfo.prov
/usr/lib/rpm/mkinstalldirs
/usr/lib/rpm/mono-find-provides
/usr/lib/rpm/mono-find-requires
/usr/lib/rpm/ocaml-find-provides.sh
/usr/lib/rpm/ocaml-find-requires.sh
/usr/lib/rpm/perl.prov
/usr/lib/rpm/perl.req
/usr/lib/rpm/pkgconfigdeps.sh
/usr/lib/rpm/python-macro-helper
/usr/lib/rpm/pythondeps.sh
/usr/lib/rpm/pythondistdeps.py
/usr/lib/rpm/rpm.daily
/usr/lib/rpm/rpm.supp
/usr/lib/rpm/rpm2cpio.sh
/usr/lib/rpm/rpmdb_loadcvt
/usr/lib/rpm/rpmdeps
/usr/lib/rpm/rpmpopt-4.14.1
/usr/lib/rpm/script.req
/usr/lib/rpm/sepdebugcrcfix
/usr/lib/rpm/tgpg
/usr/lib/rpm/fileattrs/debuginfo.attr
/usr/lib/rpm/fileattrs/desktop.attr
/usr/lib/rpm/fileattrs/elf.attr
/usr/lib/rpm/fileattrs/font.attr
/usr/lib/rpm/fileattrs/libtool.attr
/usr/lib/rpm/fileattrs/metainfo.attr
/usr/lib/rpm/fileattrs/mono.attr
/usr/lib/rpm/fileattrs/ocaml.attr
/usr/lib/rpm/fileattrs/perl.attr
/usr/lib/rpm/fileattrs/perllib.attr
/usr/lib/rpm/fileattrs/pkgconfig.attr
/usr/lib/rpm/fileattrs/python.attr
/usr/lib/rpm/fileattrs/script.attr
/usr/share/doc/rpm/CREDITS
/usr/share/doc/rpm/NEWS.Debian.gz
/usr/share/doc/rpm/README
/usr/share/doc/rpm/README.Debian
/usr/share/doc/rpm/builddependencies.gz
/usr/share/doc/rpm/buildroot
/usr/share/doc/rpm/changelog.Debian.gz
/usr/share/doc/rpm/conditionalbuilds
/usr/share/doc/rpm/copyright
/usr/share/doc/rpm/dependencies.gz
/usr/share/doc/rpm/format.gz
/usr/share/doc/rpm/hregions
/usr/share/doc/rpm/macros.gz
/usr/share/doc/rpm/multiplebuilds
/usr/share/doc/rpm/queryformat.gz
/usr/share/doc/rpm/relocatable
/usr/share/doc/rpm/signatures
/usr/share/doc/rpm/spec.gz
/usr/share/doc/rpm/triggers.gz
/usr/share/doc/rpm/tsort.gz
/usr/share/lintian/overrides/rpm
/usr/share/man/man1/gendiff.1.gz
/usr/share/man/man8/rpm-misc.8.gz
/usr/share/man/man8/rpm-plugin-systemd-inhibit.8.gz
/usr/share/man/man8/rpm.8.gz
/usr/share/man/man8/rpmbuild.8.gz
/usr/share/man/man8/rpmdb.8.gz
/usr/share/man/man8/rpmdeps.8.gz
/usr/share/man/man8/rpmgraph.8.gz
/usr/share/man/man8/rpmkeys.8.gz
/usr/share/man/man8/rpmquery.8.gz
/usr/share/man/man8/rpmsign.8.gz
/usr/share/man/man8/rpmspec.8.gz
/usr/share/man/man8/rpmverify.8.gz

Changelog

2018-03-14 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-2) unstable; urgency=medium
* Build with libzstd-dev (Closes: #892759).
2018-01-23 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Remove old package replaces/conflicts from debian/control.
* Bump standards to 4.1.3.
2017-11-11 - Michal Čihař <nijel@debian.org>
rpm (4.14.0+dfsg1-2) unstable; urgency=medium
* Upload to unstable.
* Fixed compilation on architectures without MAP_POPULATE.
2017-11-08 - Michal Čihař <nijel@debian.org>
rpm (4.14.0+dfsg1-1) experimental; urgency=medium
* New upstream release.
- Fixes crashes on corrupted packages (Closes: #801456, #780309).
* Fix debian/watch to (again) changed upstream website.
* Use optional priority instead of extra.
* Avoid using deprecated autotools_dev debhelper.
* Bump standards to 4.1.1.
* Make rpm suggest python for one of helper scripts.
* Add binutils-dev to build depends.
2017-03-29 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.2+dfsg1-2) unstable; urgency=medium
* Adjust debian/watch to new upstream website.
* Add patch to improve rpmsign behavior with gpgp2 (Closes: #858998).
2016-11-10 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.2+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Use HTTPS in the Vcs-* fields, and use the cgit frontend instead of
gitweb
* Build-depend on debhelper >= 9.20150628 to use --ddeb-migration
2016-08-01 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.1+dfsg1-6) unstable; urgency=medium
* Fix preun scriptlet failure not aborting rpm erase (Closes: #830194).
2016-07-27 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.1+dfsg1-5) unstable; urgency=medium
* Migrate to dbgsym packages instead of librpm-dbg.
* Update Maintainer, Uploaders and VCS for pkg-rpm team.
2016-07-07 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.1+dfsg1-4) unstable; urgency=medium
* Change p7zip build dependency to p7zip-full (Closes: #797920).
* Bump standards to 3.9.8.
2015-06-30 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.1+dfsg1-3) unstable; urgency=medium
* Simplify debian/copyright.
* Adjust short description of python3-rpm.
* Add missing rpm-common dependency to python modules (Closes: #790490).

See Also

Package Description
rpmlint_1.9-6_all.deb RPM package checker
rr_5.1.0-1_amd64.deb application execution recorder, player and debugger
rrdcached_1.7.0-1build1_amd64.deb data caching daemon for RRDtool
rrdcollect_0.2.10-2build1_amd64.deb Round-Robin-Database Collecting Daemon
rrdtool-tcl_1.7.0-1build1_amd64.deb time-series data storage and display system (Tcl interface)
rrdweather_0.42-0ubuntu1_all.deb weather monitoring tool based on RRDtool and weather.com
rrep_1.3.6-1ubuntu1_amd64.deb recursive pattern replacement utility
rrootage-data_0.23a-12build1_all.deb space shooting game - data files
rrootage_0.23a-12build1_amd64.deb arcade-style space shooting game
rs_20140609-5_amd64.deb reshape a data array
rsakeyfind_1.0-4_amd64.deb locates BER-encoded RSA private keys in memory images
rsbac-admin_1.4.0-repack-0ubuntu6_amd64.deb Rule Set Based Access Control administrative utilities
rsbac-doc_1.4.0-repack-0ubuntu6_all.deb RSBAC documentation
rsbac-klogd_1.4.0-repack-0ubuntu6_amd64.deb RSBAC messages logger
rsbackup-graph_4.0-1ubuntu1_amd64.deb Graphics for rsync-based backup utility
Advertisement
Advertisement