mbuffer_20171011-1ubuntu1_amd64.deb


Advertisement

Description

mbuffer - tool for buffering data streams

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package filename mbuffer_20171011-1ubuntu1_amd64.deb
Package name mbuffer
Package version 20171011
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category universe/utils
Homepage http://www.maier-komor.de/mbuffer.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 42.72 KB
Installed size 125.00 KB
The mbuffer tool is used to buffer data streams and show the I/O rate and
summary to the user.  It is especially useful for writing backups to
fast tape drives or streaming them over the network.  If used correctly,
it can prevent buffer underruns and speed up the whole backup or
transfer process.

Alternatives

Package Version Architecture Repository
mbuffer_20171011-1ubuntu1_i386.deb 20171011 i386 Ubuntu Universe
mbuffer - - -

Requires

Name Value
libc6 >= 2.17
libmhash2 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mbuffer_20171011-1ubuntu1_amd64.deb
Source Package mbuffer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mbuffer deb package:
    # sudo apt-get install mbuffer

Files

Path
/etc/mbuffer.rc
/usr/bin/mbuffer
/usr/lib/x86_64-linux-gnu/mbuffer/idev.so
/usr/lib/x86_64-linux-gnu/mbuffer/tapetest.so
/usr/share/doc/mbuffer/README
/usr/share/doc/mbuffer/changelog.Debian.gz
/usr/share/doc/mbuffer/copyright
/usr/share/man/man1/mbuffer.1.gz

Changelog

2018-03-18 - Steve Langasek <steve.langasek@ubuntu.com>
mbuffer (20171011-1ubuntu1) bionic; urgency=medium
* debian/patches/fix-upstream-test.patch: fix a test case whose file
glob fails on some archs.
2017-10-29 - Peter Pentchev <roam@ringlet.net>
mbuffer (20171011-1) unstable; urgency=medium
* New upstream release:
- update the patches
- drop the 06-ip6-localhost patch, upstream removed the use of
the "ip6-localhost" hostname
- simplify the test-library patch a bit and add idev, too
* Remove a trailing space from the rules file.
* Add "Rules-Requires-Root: no" to the source control stanza.
* Bump the debhelper compatibility level to 11 and override
the Lintian warning about the build dependency.
* Switch to git-dpm for patch management and rename the patches.
2017-10-04 - Peter Pentchev <roam@ringlet.net>
mbuffer (20170921-1) unstable; urgency=medium
* Declare compliance with Debian Policy 4.1.1 with no changes.
* New upstream release:
- update the patches
- add the 08-config-mbuffer patch to fix the build when config.h has
been overwritten by autoreconf
- update the upstream copyright years: more files have the 2000-2017
copyright notice now, so bundle everything up in it
2017-09-25 - Peter Pentchev <roam@ringlet.net>
mbuffer (20170806-2) unstable; urgency=medium
* Missed another reference to PIPE_BUF added to log.c; updated
the 02-pipe-buf patch to fix the FTBFS on the Hurd.
2017-09-24 - Peter Pentchev <roam@ringlet.net>
mbuffer (20170806-1) unstable; urgency=medium
* Drop the implied "Testsuite: autopkgtest" source control field.
* Declare compliance with Debian Policy 4.1.0 with no changes.
* New upstream version:
- refresh the 02-test-cleanup, 09-pipe-buf, 11-typos patches
- add the 17-etcdir and 18-close-errno patches
- add a "raises/rises" fix to the 12-path-max patch
- update the upstream copyright years
- add the 20-test-library patch to bundle the tapetest.so library
needed for the autopkgtest suite
- renumber the patches
2016-11-23 - Peter Pentchev <roam@ringlet.net>
mbuffer (20161115-1) unstable; urgency=medium
* Build-depend on debhelper 10 now that it's even in jessie-backports.
* New upstream release, refresh the patches.
2016-07-15 - Peter Pentchev <roam@ringlet.net>
mbuffer (20160613-1) unstable; urgency=medium
* Use HTTPS for the copyright format specification URL.
* New upstream release:
- refresh the patches
- update the upstream copyright years
2016-04-21 - Peter Pentchev <roam@ringlet.net>
mbuffer (20160228-1) unstable; urgency=medium
* Declare compliance with Debian Policy 3.9.8 with no changes.
* Add three more typo fixes to the 11-typos patch.
* Update the watch file to vesion 4 and explicitly add pgpmode=none.
* Add an autopkgtest suite.
* Bump the year on my debian/* copyright notice.
* New upstream release:
- refresh the patches
- update the upstream copyright years
* Bump the debhelper compat level to 10:
- let it handle the config.guess/config.sub update
- let it run autoreconf and the parallel build by itself
- add a Lintian override for the debhelper warning as it itself suggests
2015-09-06 - Peter Pentchev <roam@ringlet.net>
mbuffer (20150412-3) unstable; urgency=medium
* Resurrect the 12-path-max patch, since PATH_MAX is mentioned
a couple of lines further down again.
2015-09-05 - Peter Pentchev <roam@ringlet.net>
mbuffer (20150412-2) unstable; urgency=medium
* In the 09-pipe-buf patch, use logwrite() in printmsg(), too.
Fixes a FTBFS on the Hurd.
* Bump the year in my debian/* copyright notice.

See Also

Package Description
mbw_1.2.2-1build1_amd64.deb memory bandwidth benchmark program
mc-data_4.8.19-1_all.deb Midnight Commander - a powerful file manager -- data files
mc_4.8.19-1_amd64.deb Midnight Commander - a powerful file manager
mcabber_1.1.0-1_amd64.deb small Jabber (XMPP) console client
mccs_1.1-6build1_amd64.deb multi-critera CUDF solver
mce-dev_1.15.0+15.10.20150929-0ubuntu1_all.deb development files for mce
mce-doc_1.15.0+15.10.20150929-0ubuntu1_all.deb Documentation files for mce D-Bus API
mcl-doc_14-137+ds-1_all.deb documentation for mcl
mcl_14-137+ds-1_amd64.deb Markov Cluster algorithm
mcollective-client_2.6.0+dfsg-2.1_all.deb Marionette Collective clustering framework - clients
mcollective-common_2.6.0+dfsg-2.1_all.deb Marionette Collective clustering framework - common files
mcollective-doc_2.6.0+dfsg-2.1_all.deb Marionette Collective clustering framework - documentation
mcollective-plugins-centralrpclog_0.0.0~git20120507.df2fa81-0ubuntu2_all.deb mcollective plugin for central rpc log management
mcollective-plugins-facts-facter_0.0.0~git20120507.df2fa81-0ubuntu2_all.deb mcollective plugin for collecting facts via facter
mcollective-plugins-filemgr_0.0.0~git20120507.df2fa81-0ubuntu2_all.deb mcollective plugin for file management
Advertisement
Advertisement