mate-applet-appmenu_0.6.94+repack1-1_amd64.deb


Advertisement

Description

mate-applet-appmenu - Application Menu plugin for mate-panel

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package filename mate-applet-appmenu_0.6.94+repack1-1_amd64.deb
Package name mate-applet-appmenu
Package version 0.6.94+repack1
Package release 1
Package architecture amd64
Package type deb
Category universe/x11
Homepage https://github.com/rilian-la-te/vala-panel-appmenu
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 53.61 KB
Installed size 200.00 KB
This is an Application Menu (Global Menu) plugin. It is built using
the Unity protocol and libraries and provides all features found in
the Unity implementation.
This package provides the plugin for MATE.

Alternatives

Package Version Architecture Repository
mate-applet-appmenu_0.6.94+repack1-1_i386.deb 0.6.94+repack1 i386 Ubuntu Universe
mate-applet-appmenu - - -

Requires

Name Value
bamfdaemon -
dconf-gsettings-backend -
gsettings-backend -
libbamf3-2 >= 0.2.110
libc6 >= 2.7
libglib2.0-0 >= 2.47.1
libgtk-3-0 >= 3.21.6
libmate-panel-applet-4-1 >= 1.6.1
vala-panel-appmenu-common = 0.6.94+repack1-1
vala-panel-appmenu-registrar = 0.6.94+repack1-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mate-applet-appmenu_0.6.94+repack1-1_amd64.deb
Source Package vala-panel-appmenu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mate-applet-appmenu deb package:
    # sudo apt-get install mate-applet-appmenu

Files

Path
/usr/lib/mate-panel/appmenu-mate
/usr/share/dbus-1/services/org.mate.panel.applet.AppmenuAppletFactory.service
/usr/share/doc/mate-applet-appmenu/changelog.Debian.gz
/usr/share/doc/mate-applet-appmenu/copyright
/usr/share/glib-2.0/schemas/10_mate_applet_appmenu.gschema.override
/usr/share/mate-panel/applets/org.vala-panel.appmenu.mate-panel-applet

Changelog

2018-03-29 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.94+repack1-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release (0.6.93).
* debian/patches:
+ Drop 0001_fix_menu_bar_height.patch. Applied upstream.
+ Drop 0002_make_separator_transparent.patch. Applied upstream.
+ Drop 0010_send_opened_before_actual_load.patch. Applied upstream.
+ Drop 0011_check_and_ignore_firefox_stubs.patch. Applied upstream.
+ Drop 0012_use_opened_before_abouttoshow.patch. Applied upstream.
+ Drop 0020_handle_non_standard_border.patch. Applied upstream.
+ Rebased 2001_subprojects-not-shipped-with-the-source-tree.patch.
+ Add 0001_nullify_GVariants.patch. nullify GVariants to prevent Qt5
applications from crashing the XFCE panel.
* debian/rules:
+ Add -DENABLE_REGISTRAR=ON to ensure appmenu-registrar is built.
[ Mike Gabriel ]
* New upstream release (0.6.94).
* debian/patches:
+ Drop 0001_nullify_GVariants.patch. Applied upstream in 0.6.94.
* debian/copyright:
+ Update copyright attributions.
+ Update auto-generated copyright.in file.
+ Add Comment: field that explains why the orig tarball has been repacked.
2018-03-07 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.92+repack1-3) unstable; urgency=medium
[ Martin Wimpress ]
* debian/10_budgie_appmenu_applet.gschema.override:
+ Update namespace to reflect upstream changes.
* debian/10_mate_applet_appmenu.gschema.override:
+ Update namespace to reflect upstream changes. Make application names bold
via gschema override.
* debian/patches:
+ Drop 2002_bold_application_name.patch. Bold application names are now set
via a gschema override.
+ Add 0002_make_separator_transparent.patch: Make the separator between the
application name and menus transparent for wider theme compatibility.
+ Add 0010_send_opened_before_actual_load.patch. Send opened before actual
load to support Firefox and Thunderbird.
+ Add 0011_check_and_ignore_firefox_stubs.patch. Check and ignore Firefox
stubs.
+ Add 0012_use_opened_before_abouttoshow.patch. Use Opened before
AboutToShow to properly support Firefox and Thunderbird.
+ Add 0020_handle_non_standard_border.patch. Handle non-standard borders
to prevent VLC crashing the applet.
[ Mike Gabriel ]
* debian/control:
+ Drop alternative Recommends: of unity-gtk<X>-module. Debian and Ubuntu
both (and other derivatives) should now use appmenu-gtk-module.
2018-03-03 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.92+repack1-2) unstable; urgency=medium
[ Mike Gabriel ]
* debian/control:
+ Fix Vcs-*: fields. Don't point to upstream but to Alioth.
[ Martin Wimpress ]
* debian/vala-panel-appmenu.sh:
+ Fix GTK_MODULES to load appmenu-gtk-module.
2018-03-01 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.92+repack1-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
* debian/rules:
+ Drop obsolete -DMAKE_BOLD_APPNAME=ON. Bold application names is now an in
applet preference.
* debian/copyright:
+ Update copyright attributions.
* debian/patches:
+ Add README.
+ Add 0001_fix_menu_bar_height.patch. Use EXPAND_MINOR to correct the height
of global menus.
+ Add 2002_bold_application_name.patch. Make application names bold by
default.

See Also

Package Description
mate-applet-brisk-menu_0.5.0-7ubuntu1_amd64.deb Solus Project's Brisk Menu MATE Panel Applet
mate-applets-common_1.20.1-3_all.deb Various applets for the MATE panel (common files)
mate-applets_1.20.1-3_amd64.deb Various applets for the MATE panel
mate-backgrounds_1.20.0-0ubuntu1_all.deb Set of backgrounds packaged with the MATE Desktop Environment
mate-calc-common_1.20.1-1_all.deb MATE desktop calculator (common files)
mate-calc_1.20.1-1_amd64.deb MATE desktop calculator
mate-common_1.20.0-1_all.deb common scripts and macros to develop with MATE
mate-control-center-common_1.20.2-2ubuntu1_all.deb utilities to configure the MATE desktop (common files)
mate-control-center_1.20.2-2ubuntu1_amd64.deb utilities to configure the MATE desktop
mate-core_1.20.0+4_all.deb MATE Desktop Environment (essential components, dummy package)
mate-desktop-common_1.20.1-2ubuntu1_all.deb Library with common API for various MATE modules (common files)
mate-desktop-environment-core_1.20.0+4_all.deb MATE Desktop Environment (essential components, metapackage)
mate-desktop-environment-extra_1.20.0+4_all.deb MATE Desktop Environment (extra components, dummy package)
mate-desktop-environment-extras_1.20.0+4_all.deb MATE Desktop Environment (extra components, metapackage)
mate-desktop-environment_1.20.0+4_all.deb MATE Desktop Environment (metapackage)
Advertisement
Advertisement