magics++_3.0.0-1_amd64.deb


Advertisement

Description

magics++ - Executables for the magics++ library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package filename magics++_3.0.0-1_amd64.deb
Package name magics++
Package version 3.0.0
Package release 1
Package architecture amd64
Package type deb
Category universe/utils
Homepage https://software.ecmwf.int/wiki/display/MAGP/Magics
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.21 KB
Installed size 124.00 KB
Magics++ is the latest generation of the ECMWF's Meteorological plotting
software MAGICS. Although completely redesigned in C++, it is intended to be
as backwards-compatible as possible with the Fortran interface.
Besides its programming interfaces (Fortran and C), Magics++ offers MagML,
a plot description language based on XML aimed at automatic web production.
This package contains the MagcML binary that may be used with magics++.

Alternatives

Package Version Architecture Repository
magics++_3.0.0-1_i386.deb 3.0.0 i386 Ubuntu Universe
magics++ - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libmagplus3v5 = 3.0.0-1
libstdc++6 >= 5.2
python:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package magics++_3.0.0-1_amd64.deb
Source Package magics++

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install magics++ deb package:
    # sudo apt-get install magics++

Files

Path
/usr/bin/magjson
/usr/bin/magjsonx
/usr/bin/magml
/usr/bin/magmlx
/usr/bin/mapgen_clip
/usr/bin/metgram
/usr/bin/metgramx
/usr/share/doc/magics++/changelog.Debian.gz
/usr/share/doc/magics++/copyright

Changelog

2018-01-01 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.0.0-1) unstable; urgency=medium
* New upstream release 
- Update unique_ptr.patch
- python3 changes now upstream
- python*-jinja2 dependendencies now needed
* S-V: 4.1.2; no changes required
2017-11-20 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-6) unstable; urgency=medium
* Fix typo in control file. Closes: #881577
2017-11-13 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-5) unstable; urgency=medium
* libmagics++-dev now depends on libodb-api-dev. Closes: #881577
2017-11-12 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-4) unstable; urgency=medium
* Require odb-api >= 0.17..4 for renamed odb executable.
Closes: #881180
2017-11-07 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-3) unstable; urgency=medium
* Build using odb-api.
* Change references in cmake files from libgfortran.so.3 to so.4
2017-10-20 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-2) unstable; urgency=medium
* Drop B-D on transitional libhdf5-serial-dev. Closes: #879142 
2017-10-03 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.3-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.1.1
2017-08-07 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.1-2) unstable; urgency=medium
* Dont use use g++-6; g++-7 now works and is default. Closes: #871361
* Rebuild against g++-7, add tight mkshlibs deps. Closes: #871304
2017-07-17 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.1-1) unstable; urgency=medium
* New upstream release
* Add debian/gbp.conf
2017-07-02 - Alastair McKinstry <mckinstry@debian.org>
magics++ (2.34.0-1) unstable; urgency=medium
* New upstream release
* Add watch file

See Also

Package Description
magictouch_0.1+svn6821+dfsg-0ubuntu2_all.deb Retro game goes multitouch: use two knobs to paint a picture
magit_2.11.0-1_all.deb transitional dummy package for elpa-magit
magnum-api_6.1.0-0ubuntu1_all.deb OpenStack containers as a service
magnum-common_6.1.0-0ubuntu1_all.deb OpenStack containers as a service - API server
magnum-conductor_6.1.0-0ubuntu1_all.deb OpenStack containers as a service - conductor
mago_0.3+bzr20-0ubuntu3_all.deb Library and harness for desktop testing
mah-jong_1.11-2build1_amd64.deb Original Mah-Jong game
mahimahi-traces_0.98-1build1_all.deb network traces for the mahimahi toolkit
mahimahi_0.98-1build1_amd64.deb tools for network emulation and analysis
mail-expire_0.8_all.deb Utility to extract outdated messages from mbox files
mail-notification-evolution_5.4.dfsg.1-14ubuntu2_amd64.deb evolution support for mail notification
mail-notification_5.4.dfsg.1-14ubuntu2_amd64.deb mail notification in system tray
mailagent_3.1-81-4build1_amd64.deb automatic mail-processing tool and filter
mailavenger_0.8.4-4.1_amd64.deb Highly configurable, MTA-independent SMTP filter server
mailcheck_1.91.2-2build1_amd64.deb Check multiple mailboxes/maildirs for mail
Advertisement
Advertisement