madison-lite_0.22_all.deb


Advertisement

Description

madison-lite - display versions of Debian packages in an archive

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package filename madison-lite_0.22_all.deb
Package name madison-lite
Package version 0.22
Package release -
Package architecture all
Package type deb
Category universe/admin
Homepage -
License -
Maintainer Colin Watson <cjwatson@debian.org>
Download size 13.34 KB
Installed size 51.00 KB
This program inspects a local Debian package archive and displays the
versions of the given packages found in each suite (for example, stable,
testing, or unstable) in a brief but easily human-readable form. It aims to
be a drop-in replacement for the madison utility from the da-katie archive
management suite that runs on the central Debian archive systems, but one
which can run without access to the archive's SQL database.
For simple queries, you can use http://packages.debian.org/ instead, which
does not require you to have access to a system with a local mirror.

Alternatives

Package Version Architecture Repository
madison-lite_0.22_all.deb 0.22 all Ubuntu Universe
madison-lite - - -

Requires

Name Value
perl >= 5.10

Download

Type URL
Mirror archive.ubuntu.com
Binary Package madison-lite_0.22_all.deb
Source Package madison-lite

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install madison-lite deb package:
    # sudo apt-get install madison-lite

Files

Path
/usr/bin/madison-lite
/usr/share/doc/madison-lite/changelog.gz
/usr/share/doc/madison-lite/copyright
/usr/share/doc/madison-lite/examples/debian.org.config
/usr/share/doc/madison-lite/examples/local-mirror.config
/usr/share/doc/madison-lite/examples/make-local-mirror
/usr/share/doc/madison-lite/examples/ubuntu.com.config
/usr/share/man/man1/madison-lite.1.gz

Changelog

2016-08-26 - Colin Watson <cjwatson@debian.org>
madison-lite (0.22) unstable; urgency=medium
* Add xz support (thanks, Ivan Udovichenko; closes: #835527).
2016-01-27 - Colin Watson <cjwatson@debian.org>
madison-lite (0.21) unstable; urgency=medium
* Update Vcs-Browser URL for alioth cgit.
* Policy version 3.9.6: no changes required.
* Remove duplicated licence paragraph from debian/copyright.
* Upgrade to debhelper v9.
* Use the defined-or operator where appropriate.
* Use HTTPS for Vcs-* URLs.
2014-06-24 - Colin Watson <cjwatson@debian.org>
madison-lite (0.20) unstable; urgency=medium
* Use scalar variables for filehandles throughout rather than typeglobs.
* Ensure that cache files have the same timestamp as their source file,
and check for this rather than checking whether the cache file is at
least as new.  This fixes a race where stale caches could be left
unnoticed if the mirror was updated while the cache was being built.
2014-01-07 - Colin Watson <cjwatson@debian.org>
madison-lite (0.19) unstable; urgency=low
* Switch to git; adjust Vcs-* fields.
* Convert debian/copyright to copyright-format 1.0.
* Policy version 3.9.5.
2013-11-26 - Colin Watson <cjwatson@debian.org>
madison-lite (0.18) unstable; urgency=low
* Calculate optimal column sizes in the same way as Debian's madison.cgi,
and otherwise tweak output formatting to match (LP: #315833).
2013-09-24 - Colin Watson <cjwatson@debian.org>
madison-lite (0.17) unstable; urgency=low
* make-local-mirror: Use 'set -e' rather than '#! /bin/sh -e', to avoid
accidents when debugging with 'sh -x'.
* Ensure that the cache directory exists before creating the lock.
* Print lock file name in the error message emitted if we fail to open it.
2012-11-28 - Colin Watson <cjwatson@debian.org>
madison-lite (0.16) unstable; urgency=low
[ Colin Watson ]
* Update Vcs-Bzr field for Alioth changes.
* Add Vcs-Browser field.
[ Stefano Rivera ]
* Avoid multiple madison-lites updating the same cache file at the same
time, by having a cache-wide lock file.
2010-11-05 - Colin Watson <cjwatson@debian.org>
madison-lite (0.15) unstable; urgency=low
* Convert to source format 3.0 (native).
* Use the 'say' feature from Perl 5.10.
* Use the 'state' feature to simplify caching_disabled.
* Convert from 'perl -w' to 'use warnings'.
* Make regex searches actually produce some output (closes: #576941).
* Policy version 3.9.1: no changes required.
2009-07-26 - Colin Watson <cjwatson@debian.org>
madison-lite (0.14) unstable; urgency=low
* Moved to bzr.debian.org; add Vcs-Bzr control field.
* Convert to debhelper 7.
2008-07-04 - Colin Watson <cjwatson@debian.org>
madison-lite (0.13) unstable; urgency=low
* Update version comparison code from Dpkg::Version in dpkg-dev 1.14.20;
adds ~ (low-sorting character) support.
* Policy version 3.8.0: no changes required.
* Relicense to GPLv2+. I'm using a decent chunk of Dpkg::Version, which is
also GPLv2+, and dealing with a mixed-licence file is just too annoying.
I don't know of anyone this will adversely affect; if it does, e-mail me
and I'll be willing to discuss the matter. (The examples are still
2-clause BSD.)
* Convert to machine-readable copyright format, wiki revision 179.

See Also

Package Description
madlib-doc_1.3.0-2.1ubuntu1_all.deb mesh adaptation library
madplay_0.15.2b-8.2_amd64.deb MPEG audio player in fixed point
madwimax_0.1.1-1ubuntu3_amd64.deb user-space driver for mWiMAX equipment based on Samsung CMC-730
mafft_7.310-1_amd64.deb Multiple alignment program for amino acid or nucleotide sequences
magic-wormhole_0.10.3-1_all.deb Securely and simply transfer data between computers
magic_8.0.210-2build1_amd64.deb VLSI layout tool
magicfilter_1.2-65_amd64.deb automatic printer filter
magicmaze_1.4.3.6+dfsg-2_all.deb rescue the maiden while avoiding the monsters
magicor-data_1.1-4build1_all.deb data files for the magicor puzzle game
magicor_1.1-4build1_all.deb puzzle game in the spirit of solomon's key
magicrescue_1.1.9-6_amd64.deb recover files by looking for magic bytes
magics++_3.0.0-1_amd64.deb Executables for the magics++ library
magictouch_0.1+svn6821+dfsg-0ubuntu2_all.deb Retro game goes multitouch: use two knobs to paint a picture
magit_2.11.0-1_all.deb transitional dummy package for elpa-magit
magnum-api_6.1.0-0ubuntu1_all.deb OpenStack containers as a service
Advertisement
Advertisement