libqtscript4-webkit_0.2.0-1build1_amd64.deb


Advertisement

Description

libqtscript4-webkit - QtScript bindings for the Qt 4 WebKit library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name libqtscript4-webkit
Package version 0.2.0
Package release 1build1
Package architecture amd64
Package type deb
Installed size 635 B
Download size 136.28 KB
Official Mirror archive.ubuntu.com
QtScript is a scripting language based on the ECMAScript standard, with
bindings that give access to substantial portions of the Qt 4 API.
This package contains bindings for the Qt 4 WebKit library.

Alternatives

Package Version Architecture Repository
libqtscript4-webkit_0.2.0-1build1_i386.deb 0.2.0 i386 Ubuntu Universe
libqtscript4-webkit - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt4-network >= 4:4.8.0
libqt4-script >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libqtscript4-core = 0.2.0-1build1
libqtwebkit4 -
libstdc++6 >= 5

Download

Type URL
Binary Package libqtscript4-webkit_0.2.0-1build1_amd64.deb
Source Package qtscriptgenerator

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqtscript4-webkit deb package:
    # sudo apt-get install libqtscript4-webkit

Files

Path
/usr/lib/x86_64-linux-gnu/qt4/plugins/script/libqtscript_webkit.so
/usr/lib/x86_64-linux-gnu/qt4/plugins/script/libqtscript_webkit.so.1
/usr/lib/x86_64-linux-gnu/qt4/plugins/script/libqtscript_webkit.so.1.0
/usr/lib/x86_64-linux-gnu/qt4/plugins/script/libqtscript_webkit.so.1.0.0
/usr/share/doc/libqtscript4-webkit/changelog.Debian.gz
/usr/share/doc/libqtscript4-webkit/copyright

Changelog

2018-04-03 - Balint Reczey <rbalint@ubuntu.com>
qtscriptgenerator (0.2.0-1build1) bionic; urgency=high
* No change rebuild to pick up -fPIE compiler default
2012-05-01 - Modestas Vainius <modax@debian.org>
qtscriptgenerator (0.2.0-1) unstable; urgency=low
* New upstream release.
* Update upstream_support_later_phonon.diff patch to support Phonon 4.6.
Thanks to Felix Geyer. (Closes: #662771)
* Bump debhelper compat level to 9 in order to gain build flag support.
* Remove custom build flag management code from debian/rules.
* Bump Standards-Version to 3.9.3: no changes needed.
* Add multi-arch support:
- build depend on multi-arch aware Qt 4.8.0;
- switch libqtscript4-qtbindings to Architecture:any and mark it
Multi-Arch:same;
- mark all bindings package Multi-Arch: same and add to ${misc:Pre-Depends}
to their Pre-Depends.
- install plugins into multiarch path (/usr/lib/<arch>/qt4/).
* Fix package descriptions. Thanks to Martin Eberhard Schauer for the patch.
(Closes: #634171)
* Fix FTBFS with gcc 4.7 (patch upstream_gcc4.7_fix.diff).
2011-04-24 - Modestas Vainius <modax@debian.org>
qtscriptgenerator (0.1.0+git20101026+8b191fbc-2) unstable; urgency=low
* debian_simple_top_makefile.diff: make generated_cpp depend on typesystem
xml files.
* Add upstream_arm_fix_ftbfs.diff patch to fix FTBFS on arm* architectures.
2011-04-23 - Modestas Vainius <modax@debian.org>
qtscriptgenerator (0.1.0+git20101026+8b191fbc-1) unstable; urgency=low
* New upstream development snapshot to support Qt 4.7.
* Remove DMUA field from debian/control. I'm a DD now.
* Switch my e-mail address to @debian.org one.
* Git repository moved to my new DD account on alioth. Change Vcs fields in
debian/control accordingly.
* Build depend on libqtwebkit-dev | libqt4-dev (<< 4:4.7.0). Also steal
debian_webkit_phonon_include.diff from kubuntu to enable building with Qt
4.7. Fixes FTBFS. (Closes: #618172)
* Drop topgit support.
* Move patches out of subdirectories.
* Switch source package to 3.0 (quilt).
* Bump Standards-Version to 3.9.2: no changes needed.
* Drop upstream_gcc4.4_ftbfs_fix.diff, merged upstream.
* Adapt debian_drop_extra_linkage_fix.diff to upstream changes.
* Add patch upstream_support_later_phonon.diff which fixes building against
system Phonon 4.5.0.
* Reimplement top Makefile in the parallel-safe manner (patch
debian_simple_top_makefile.diff) and pass --parallel to dh.
* Add doc-base control file for libqtscript4-doc.
2009-05-09 - Modestas Vainius <modestas@vainius.eu>
qtscriptgenerator (0.1.0-3) unstable; urgency=low
* Fix noopt check.
* Export QMAKE_TARGET.
* Use dh_makeshlibs --remaining-packages instead of the previous hack,
hence depend on debhelper 7.2.7.
* Bump Standards-Version to 3.8.1. No changes needed.
* New patches:
- general/memory_alignment_fix.diff - some unaligned memory fixes. It 
should fix FTBFS on armel/sparc (Closes: #525980).
- general/gcc4.4_ftbfs_fix.diff - fixes FTBFS with gcc 4.4
(Closes: #526167).
- debian/drop_extra_linkage_fix - do not link with unnecessary libraries.
* Use new quilt dh sequence module, build depend on quilt (>= 0.46-7~).
* Backports friendly debhelper build dependency versioning.
* Update debian/README.source: build branch merged into master.
* Improve simple_top_makefile patch:
- build process depends on existance of plugins;
- update timestamps whenever possible to avoid unnecessary rebuilds.
2009-04-25 - Modestas Vainius <modestas@vainius.eu>
qtscriptgenerator (0.1.0-2) unstable; urgency=low
* Reenable libqtscript4-phonon, build depend on Qt 4.5.
* Add notice about Qt 4.5 copyright to debian/copyright.
2009-03-07 - Modestas Vainius <modestas@vainius.eu>
qtscriptgenerator (0.1.0-1) unstable; urgency=low
* Initial release (Closes: #518601).
* libqtscript4-phonon is empty on purpose until the package is built
against Qt 4.5 which is going to be soon.

See Also

Package Description
libqtscript4-xml_0.2.0-1build1_amd64.deb QtScript bindings for the Qt 4 XML library
libqtscript4-xmlpatterns_0.2.0-1build1_amd64.deb QtScript bindings for the Qt 4 XML patterns library
libqttest4-perl_4.14.1-0ubuntu11_amd64.deb perl bindings for the Qt Test library
libqtwebkit-dev_2.3.2-0ubuntu13_amd64.deb Web content engine library for Qt - development files
libqtwebkit-qmlwebkitplugin_2.3.2-0ubuntu13_amd64.deb Qt WebKit QML plugin
libqtwebkit4_2.3.2-0ubuntu13_amd64.deb Web content engine library for Qt
libqtxml4-perl_4.14.1-0ubuntu11_amd64.deb perl bindings for the Qt Xml library
libquadmath0-amd64-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-dbg-amd64-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library (debug symbols)
libquadmath0-dbg-i386-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library (debug symbols)
libquadmath0-dbg-ppc64el-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library (debug symbols)
libquadmath0-dbg-x32-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library (debug symbols)
libquadmath0-i386-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-ppc64el-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-x32-cross_8-20180414-1ubuntu2cross1_all.deb GCC Quad-Precision Math Library
Advertisement
Advertisement