epsilon-bin_0.9.2+dfsg-2_amd64.deb


Advertisement

Description

epsilon-bin - Library for wavelet image compression - tools

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name epsilon-bin
Package version 0.9.2+dfsg
Package release 2
Package architecture amd64
Package type deb
Installed size 90 B
Download size 31.72 KB
Official Mirror archive.ubuntu.com
Epsilon is C library for Wavelet based lossy image compression.
Wavelet-driven compressors are know to be much more effective than
traditional DCT-based ones (like JPEG).
At the moment, the program supports about 30 different wavelet filters,
runs in parallel in multi-threaded and MPI environments, can process
huge images and much more.
This package contains some useful tools to compress/uncompress images.

Alternatives

Package Version Architecture Repository
epsilon-bin_0.9.2+dfsg-2_i386.deb 0.9.2+dfsg i386 Ubuntu Universe
epsilon-bin - - -

Requires

Name Value
dsh -
libc6 >= 2.14
libepsilon1 >= 0.8.1
libpopt0 >= 1.14
perl -

Download

Type URL
Binary Package epsilon-bin_0.9.2+dfsg-2_amd64.deb
Source Package libepsilon

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install epsilon-bin deb package:
    # sudo apt-get install epsilon-bin

Files

Path
/usr/bin/epsilon
/usr/bin/start_epsilon_nodes
/usr/bin/stop_epsilon_nodes
/usr/share/doc/epsilon-bin/changelog.Debian.gz
/usr/share/doc/epsilon-bin/copyright
/usr/share/man/man1/epsilon.1.gz
/usr/share/man/man1/start_epsilon_nodes.1.gz
/usr/share/man/man1/stop_epsilon_nodes.1.gz

Changelog

2016-04-17 - Bas Couwenberg <sebastic@debian.org>
libepsilon (0.9.2+dfsg-2) unstable; urgency=medium
* Bump Standards-Version to 3.9.8, no changes.
* Add declare-xmalloc.patch by Colin Watson to
include mem_alloc.h in files that use xmalloc.
* Add ${perl:Depends} to epsilon-bin Depends.
* Enable all hardening buildflags.
2016-03-11 - Bas Couwenberg <sebastic@debian.org>
libepsilon (0.9.2+dfsg-1) unstable; urgency=medium
* Update Vcs-* URLs to use HTTPS.
* Update watch file to handle common issues.
* Update SourceForge URLs to use HTTPS.
* Update copyright years for Alexander Simakov.
* Update dh_install override to use --list-missing.
* Enable parallel builds.
* Repack upstream tarball to exclude non-free lena test image.
* Add gbp.conf to use pristine-tar by default.
* Add patch to disable tests using non-free lena image.
* Bump Standards-Version to 3.9.7, no changes.
* Explicitly remove .la files, not installed.
2015-04-27 - Bas Couwenberg <sebastic@debian.org>
libepsilon (0.9.2-3) unstable; urgency=medium
* Move from experimental to unstable.
2015-04-23 - Bas Couwenberg <sebastic@debian.org>
libepsilon (0.9.2-3~exp2) experimental; urgency=medium
* Update my email to use @debian.org address.
* Override dh_clean to remove generated man pages.
* Set the date embedded in man pages to the build date for
reproducible builds.
2015-01-09 - Bas Couwenberg <sebastic@xs4all.nl>
libepsilon (0.9.2-3~exp1) experimental; urgency=medium
* Update copyright file, change GPL3 license shortname to GPL-3.
* Update Vcs-Browser URL to use cgit instead of gitweb.
* Bump Standards-Version to 3.9.6, no changes.
2014-01-29 - Bas Couwenberg <sebastic@xs4all.nl>
libepsilon (0.9.2-2) unstable; urgency=low
* Add lib/msvc/* to copyright file.
(closes: #737004) 
2014-01-26 - Bas Couwenberg <sebastic@xs4all.nl>
libepsilon (0.9.2-1) unstable; urgency=low
* New upstream release (no code changes, only build system).
* Add myself to Uploaders.
* Use canonical URLs for Vcs-* fields.
* Change priority to optional.
* Update copyright file format from dep5 to copyright-format 1.0.
* Bump Debhelper compatibility to 9.
* Support Multi-Arch.
* Use dh-autoreconf for retooling.
(closes: #735228)
* Use dh_auto_configure with additional options instead of configure.
* Don't start description synopsis with an article.
* Rename libepsilon0 to libepsilon1 to match SONAME.
* Add man pages for start_epsilon_nodes and stop_epsilon_nodes.
* Add dependency on dsh for epsilon-tools, required for *_epsilon_nodes.
* Add symbols file for libepsilon1.
* Bump Standards-Version to 3.9.5, changes: Vcs-* URLs, copyright format,
shared library.
2011-05-09 - Francesco Paolo Lovergine <frankie@debian.org>
libepsilon (0.9.1-1) unstable; urgency=low
* New upstream release.
* Fixed Vcs-* fields in debian/control.
(closes: #618659)
* Moved debian/copyright to DEP5 format.
* Upstream relicensed 0.8.1+ under GPL3/LGPL3, debian/copyright changed as
required.
* Policy bumped to 3.9.2, no changes required.
* Debhelper level set to 8.
* Now enables both pthreads and cluster mode.
2010-11-20 - Francesco Paolo Lovergine <frankie@debian.org>
libepsilon (0.8.1-1) unstable; urgency=low
* Initial release.
(closes: #604141)

See Also

Package Description
epstool_3.08+repack-7_amd64.deb edit preview images and fix bounding boxes in EPS files
epub-utils_0.2.2-4ubuntu1_amd64.deb tools to work with the EPUB file format
epubcheck_4.0.2-2_all.deb Validation Tool for EPUB
epydoc-doc_3.0.1+dfsg-17_all.deb tool for documenting Python modules (documentation)
epylog_1.0.8-2_all.deb New logs analyzer and parser
eq10q_2.2~repack0-2_amd64.deb LV2 plugins bundle
eql_1.2.ds1-4build1_amd64.deb load balancing tool for serial network connections
eqonomize-doc_0.6-8_all.deb documentation for the Eqonomize! accounting software
eqonomize_0.6-8_amd64.deb personal accounting software for the small household economy
equalx_0.7.1-4build1_amd64.deb graphical editor for LaTeX equations
equivs_2.1.0_all.deb Circumvent Debian package dependencies
ergo_3.5-1_amd64.deb Quantum chemistry program for large-scale calculations
eric-api-files_17.11.1-1_all.deb API description files for use with eric
eric_17.11.1-1_all.deb full featured Python IDE
erlang-asciideck_0.0+git20170714.48cbfe8b-2_amd64.deb Erlang library for asciidoc
Advertisement
Advertisement