epoptes_0.5.10-2_all.deb


Advertisement

Description

epoptes - Computer lab management tool

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name epoptes
Package version 0.5.10
Package release 2
Package architecture all
Package type deb
Installed size 1.82 KB
Download size 177.41 KB
Official Mirror archive.ubuntu.com
Epoptes is an open source computer lab management and monitoring tool. It
allows for screen broadcasting and monitoring, remote command execution,
message sending, imposing restrictions like screen locking or sound muting
the clients and much more!
Contains the server daemon and a GUI for controlling client PCs.
It supports LTSP installations, but it also works without LTSP.

Alternatives

Package Version Architecture Repository
epoptes_0.5.10-2_all.deb 0.5.10 all Ubuntu Universe
epoptes - - -

Requires

Name Value
adduser -
faketime -
iperf -
iproute -
iproute2 -
librsvg2-common -
lsb-base -
notification-daemon -
openssl -
python << 2.8
python >= 2.7
python-dbus -
python-gtk2 -
python-netifaces -
python-notify -
python-openssl -
python-pycha -
python-twisted-core -
python:any >= 2.6.6-7~
socat -
ssvnc -
tigervnc-viewer -
vnc-viewer -
x11vnc -
xfce4-notifyd -
xterm -
xvnc4viewer -

Download

Type URL
Binary Package epoptes_0.5.10-2_all.deb
Source Package epoptes

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install epoptes deb package:
    # sudo apt-get install epoptes

Files

Path
/etc/default/epoptes
/etc/init.d/epoptes
/usr/bin/epoptes
/usr/lib/python2.7/dist-packages/epoptes-0.5.10_2.egg-info
/usr/lib/python2.7/dist-packages/epoptes/__init__.py
/usr/lib/python2.7/dist-packages/epoptes/common/__init__.py
/usr/lib/python2.7/dist-packages/epoptes/common/config.py
/usr/lib/python2.7/dist-packages/epoptes/common/constants.py
/usr/lib/python2.7/dist-packages/epoptes/common/ltsconf.py
/usr/lib/python2.7/dist-packages/epoptes/common/xdg_dirs.py
/usr/lib/python2.7/dist-packages/epoptes/core/__init__.py
/usr/lib/python2.7/dist-packages/epoptes/core/lib_users.py
/usr/lib/python2.7/dist-packages/epoptes/core/structs.py
/usr/lib/python2.7/dist-packages/epoptes/core/wol.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/__init__.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/bashplex.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/commands.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/exchange.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/guiplex.py
/usr/lib/python2.7/dist-packages/epoptes/daemon/uiconnection.py
/usr/lib/python2.7/dist-packages/epoptes/ui/__init__.py
/usr/lib/python2.7/dist-packages/epoptes/ui/about_dialog.py
/usr/lib/python2.7/dist-packages/epoptes/ui/benchmark.py
/usr/lib/python2.7/dist-packages/epoptes/ui/client_information.py
/usr/lib/python2.7/dist-packages/epoptes/ui/execcommand.py
/usr/lib/python2.7/dist-packages/epoptes/ui/graph.py
/usr/lib/python2.7/dist-packages/epoptes/ui/gui.py
/usr/lib/python2.7/dist-packages/epoptes/ui/notifications.py
/usr/lib/python2.7/dist-packages/epoptes/ui/remote_assistance.py
/usr/lib/python2.7/dist-packages/epoptes/ui/sendmessage.py
/usr/lib/python2.7/dist-packages/twisted/plugins/epoptesd.py
/usr/share/applications/epoptes.desktop
/usr/share/doc/epoptes/README
/usr/share/doc/epoptes/changelog.Debian.gz
/usr/share/doc/epoptes/copyright
/usr/share/epoptes/about_dialog.ui
/usr/share/epoptes/client-functions
/usr/share/epoptes/client_information.ui
/usr/share/epoptes/epoptes.ui
/usr/share/epoptes/executeCommand.ui
/usr/share/epoptes/netbenchmark.ui
/usr/share/epoptes/remote_assistance.ui
/usr/share/epoptes/sendMessage.ui
/usr/share/epoptes/images/assist.svg
/usr/share/epoptes/images/broadcast-stop.svg
/usr/share/epoptes/images/broadcast-windowed.svg
/usr/share/epoptes/images/broadcast.svg
/usr/share/epoptes/images/execute.svg
/usr/share/epoptes/images/fat.svg
/usr/share/epoptes/images/graph.png
/usr/share/epoptes/images/info.svg
/usr/share/epoptes/images/lock-screen.svg
/usr/share/epoptes/images/login.png
/usr/share/epoptes/images/logout.svg
/usr/share/epoptes/images/message.svg
/usr/share/epoptes/images/mute.svg
/usr/share/epoptes/images/observe.svg
/usr/share/epoptes/images/off.png
/usr/share/epoptes/images/offline.svg
/usr/share/epoptes/images/on.png
/usr/share/epoptes/images/poweron.svg
/usr/share/epoptes/images/restart.svg
/usr/share/epoptes/images/root-terminal.svg
/usr/share/epoptes/images/shutdown.svg
/usr/share/epoptes/images/standalone.svg
/usr/share/epoptes/images/systemgrp.png
/usr/share/epoptes/images/terminal.svg
/usr/share/epoptes/images/thin.svg
/usr/share/epoptes/images/unlock-screen.svg
/usr/share/epoptes/images/unmute.svg
/usr/share/epoptes/images/usersgrp.png
/usr/share/epoptes/images/16/assist.png
/usr/share/epoptes/images/16/broadcast-stop.png
/usr/share/epoptes/images/16/broadcast-windowed.png
/usr/share/epoptes/images/16/broadcast.png
/usr/share/epoptes/images/16/execute.png
/usr/share/epoptes/images/16/graph.png
/usr/share/epoptes/images/16/info.png
/usr/share/epoptes/images/16/lock-screen.png
/usr/share/epoptes/images/16/logout.png
/usr/share/epoptes/images/16/message.png
/usr/share/epoptes/images/16/mute.png
/usr/share/epoptes/images/16/observe.png
/usr/share/epoptes/images/16/poweron.png
/usr/share/epoptes/images/16/restart.png
/usr/share/epoptes/images/16/root-terminal.png
/usr/share/epoptes/images/16/shutdown.png
/usr/share/epoptes/images/16/terminal.png
/usr/share/epoptes/images/16/unlock-screen.png
/usr/share/epoptes/images/16/unmute.png
/usr/share/icons/hicolor/scalable/apps/epoptes.svg
/usr/share/locale/af/LC_MESSAGES/epoptes.mo
/usr/share/locale/ar/LC_MESSAGES/epoptes.mo
/usr/share/locale/bg/LC_MESSAGES/epoptes.mo
/usr/share/locale/ca/LC_MESSAGES/epoptes.mo
/usr/share/locale/ca@valencia/LC_MESSAGES/epoptes.mo
/usr/share/locale/cs/LC_MESSAGES/epoptes.mo
/usr/share/locale/da/LC_MESSAGES/epoptes.mo
/usr/share/locale/de/LC_MESSAGES/epoptes.mo
/usr/share/locale/el/LC_MESSAGES/epoptes.mo
/usr/share/locale/en_AU/LC_MESSAGES/epoptes.mo
/usr/share/locale/en_GB/LC_MESSAGES/epoptes.mo
/usr/share/locale/es/LC_MESSAGES/epoptes.mo
/usr/share/locale/eu/LC_MESSAGES/epoptes.mo
/usr/share/locale/fi/LC_MESSAGES/epoptes.mo
/usr/share/locale/fr/LC_MESSAGES/epoptes.mo
/usr/share/locale/gl/LC_MESSAGES/epoptes.mo
/usr/share/locale/he/LC_MESSAGES/epoptes.mo
/usr/share/locale/hu/LC_MESSAGES/epoptes.mo
/usr/share/locale/id/LC_MESSAGES/epoptes.mo
/usr/share/locale/it/LC_MESSAGES/epoptes.mo
/usr/share/locale/lt/LC_MESSAGES/epoptes.mo
/usr/share/locale/ml/LC_MESSAGES/epoptes.mo
/usr/share/locale/ms/LC_MESSAGES/epoptes.mo
/usr/share/locale/nb/LC_MESSAGES/epoptes.mo
/usr/share/locale/nl/LC_MESSAGES/epoptes.mo
/usr/share/locale/oc/LC_MESSAGES/epoptes.mo
/usr/share/locale/pl/LC_MESSAGES/epoptes.mo
/usr/share/locale/pt/LC_MESSAGES/epoptes.mo
/usr/share/locale/pt_BR/LC_MESSAGES/epoptes.mo
/usr/share/locale/ru/LC_MESSAGES/epoptes.mo
/usr/share/locale/se/LC_MESSAGES/epoptes.mo
/usr/share/locale/sk/LC_MESSAGES/epoptes.mo
/usr/share/locale/sl/LC_MESSAGES/epoptes.mo
/usr/share/locale/so/LC_MESSAGES/epoptes.mo
/usr/share/locale/sr/LC_MESSAGES/epoptes.mo
/usr/share/locale/sr@latin/LC_MESSAGES/epoptes.mo
/usr/share/locale/sv/LC_MESSAGES/epoptes.mo
/usr/share/locale/tr/LC_MESSAGES/epoptes.mo
/usr/share/locale/uk/LC_MESSAGES/epoptes.mo
/usr/share/locale/vi/LC_MESSAGES/epoptes.mo
/usr/share/locale/zh_CN/LC_MESSAGES/epoptes.mo
/usr/share/locale/zh_TW/LC_MESSAGES/epoptes.mo
/usr/share/ltsp/plugins/ltsp-build-client/common/040-epoptes-certificate
/usr/share/man/man1/epoptes.1.gz

Changelog

2017-01-23 - Vagrant Cascadian <vagrant@debian.org>
epoptes (0.5.10-2) unstable; urgency=medium
* Add debian/watch file.
* Add patches from upstream to support tigervnc.
* debian/control:
- Update Vcs-* fields.
- Bump Standards-Version to 3.9.8, no changes.
- Add dependency on lsb-base, used by init scripts.
- Prefer tigervnc-viewer over other vnc-viewers.
* Updated copyright years.
2016-03-25 - Vagrant Cascadian <vagrant@debian.org>
epoptes (0.5.10-1) unstable; urgency=medium
* New upstream version:
- Add a fallback to detect network interfaces that may not have a
MAC address (e.g. TUN devices).
- Fix multiple issues in info() function (LP: #1549467).
- Prevent screensaver while broadcasting (LP: #1548695).
- Avoid 90 sec shutdown delay on Debian/systemd.
* epoptes-client.init:
- Source LSB init-functions to make lintian happy.
* epoptes.postinst:
- Generate certificates with openssl without leaving ~/.rnd directory
in root's homedir.
* epoptes.init:
- Determine if running as an LTSP client by checking for init-ltsp in
boot commandline. Thanks to Alkis for the fix!
* debian/control:
- Use https URL for Vcs-Browser.
- Update to Standards-Version 3.9.7, no changes.
* debian/copyright:
- Updated copyrights years.
2015-10-06 - Fotis Tsamis <ftsamis@gmail.com>
epoptes (0.5.8-1) unstable; urgency=low
* New upstream version:
- TERM was missing in text-based remote assistance (LP: #1117158).
- Add support for shutdown/reboot/logout on systemd (LP: #1447321).
- Fix a crash which occurred when changing the group selection.
- Emulate x-canonical-append for notifications when necessary.
- Support newer socat versions >= 1.7.3.
- Generate a certificate valid since the Epoch.
- Use python-netifaces to discover the broadcast addresses (LP: #1341278).
- Handle the --version argument.
- Read epoptes socket without checking for group membership (LP: #1338051).
- Add a network throughput measurement feature.
- Make the Groups header translatable.
* epoptes:
- Remove python-vte from dependencies (Closes: #790167).
- Depend on iperf and python-pycha.
* epoptes-client:
- Depend on iproute2 instead of only iproute (Closes: #753715).
- Add iperf on dependencies.
* debian/control:
- Update Standards-Version to 3.9.6, no changes necessary. 
2013-11-24 - Vagrant Cascadian <vagrant@debian.org>
epoptes (0.5.7-1) unstable; urgency=low
* New upstream version:
- Add a config option for grabbing the keyboard and the mouse pointer
when assisting a user (LP: #977637).
- Preserve the clients selection when a client connects, disconnects, or
is removed from the selected group (LP: #1045065).
- Send WOL to all interfaces (LP: #1157241).
- Fix epoptes crashing when running as root (LP: #977049).
- Fix logout in Mate.
- Improve the thumbnails zooming functionality.
- Prefer pactl for muting when available (LP: #1026331).
- Grab local input when assisting a client (LP: #977637).
- Support xtightvncviewer as an alternative to xvnc4viewer.
- Prefer ssvncviewer over xvnc4viewer (LP: #1030853).
* epoptes:
- Add python-openssl as an epoptes dependency (Closes: #703512).
- Start the epoptes service later for LDAP/Samba (LP: #1054665).
* epoptes-client:
- Enable Wake On Lan when ethtool is installed. Add Suggests on ethtool.
* debian/control:
- Update Standards-Version to 3.9.5, no changes necessary. 
2012-06-27 - Alkis Georgopoulos <alkisg@gmail.com>
epoptes (0.5.6-1) unstable; urgency=low
* New upstream version:
- Support ssvnc as an alternative to xvnc4viewer.
- Disable alias editing for clients in the 'Detected' group.
- Correctly parse info for clients with multiple VGAs (LP: #1017140).
- Prefix "-" to fullscreen parameter (LP: #1015239).

See Also

Package Description
epsilon-bin_0.9.2+dfsg-2_amd64.deb Library for wavelet image compression - tools
epstool_3.08+repack-7_amd64.deb edit preview images and fix bounding boxes in EPS files
epub-utils_0.2.2-4ubuntu1_amd64.deb tools to work with the EPUB file format
epubcheck_4.0.2-2_all.deb Validation Tool for EPUB
epydoc-doc_3.0.1+dfsg-17_all.deb tool for documenting Python modules (documentation)
epylog_1.0.8-2_all.deb New logs analyzer and parser
eq10q_2.2~repack0-2_amd64.deb LV2 plugins bundle
eql_1.2.ds1-4build1_amd64.deb load balancing tool for serial network connections
eqonomize-doc_0.6-8_all.deb documentation for the Eqonomize! accounting software
eqonomize_0.6-8_amd64.deb personal accounting software for the small household economy
equalx_0.7.1-4build1_amd64.deb graphical editor for LaTeX equations
equivs_2.1.0_all.deb Circumvent Debian package dependencies
ergo_3.5-1_amd64.deb Quantum chemistry program for large-scale calculations
eric-api-files_17.11.1-1_all.deb API description files for use with eric
eric_17.11.1-1_all.deb full featured Python IDE
Advertisement
Advertisement