entropybroker_2.9-1_amd64.deb


Advertisement

Description

entropybroker - infrastructure for distributing random numbers (entropy data)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name entropybroker
Package version 2.9
Package release 1
Package architecture amd64
Package type deb
Installed size 6.99 KB
Download size 613.82 KB
Official Mirror archive.ubuntu.com
Entropy Broker is an infrastructure for distributing cryptographically secure
random numbers (entropy data) from one or more servers to one or more clients.
It allows you to distribute entropy data (random values) to /dev/random
devices from other systems (real servers or virtualised systems).
It helps preventing that the /dev/random device gets depleted; an empty
/dev/random-device can cause programs to hang (waiting for entropy data to
become available).
This is useful for systems that need to generate encryption keys, run VPN
software or run a casino website. Also virtual systems that have no good
sources of entropy like virtual servers (e.g. VMware, XEN and KVM (although
KVM has the virtio_rnd driver)).
Entropy Broker is an infrastructure consisting of client-daemons that fill
/dev/random and server-daemons that feed the central entropy broker-server.
The server-daemons can gather random values by measuring timer frequency
noise, analysing noise from a unused audio-device, noise from a video source
(webcam, tv-card) and random values from a real hardware RNG (random number
generator).

Alternatives

Package Version Architecture Repository
entropybroker_2.9-1_i386.deb 2.9 i386 Ubuntu Universe
entropybroker - - -

Requires

Name Value
init-system-helpers >= 1.18~
libasound2 >= 1.0.16
libc6 >= 2.15
libcrypto++6 -
libftdi1 -
libgcc1 >= 1:3.0
libgd3 >= 2.1.0~alpha~
libpcsclite1 >= 1.3.0
libstdc++6 >= 5.2
libusb-1.0-0 >= 2:1.0.8
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package entropybroker_2.9-1_amd64.deb
Source Package entropybroker

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install entropybroker deb package:
    # sudo apt-get install entropybroker

Files

Path
/etc/entropybroker/eb_client_egd.config
/etc/entropybroker/eb_client_file.config
/etc/entropybroker/eb_client_kernel_generic.config
/etc/entropybroker/eb_client_linux_kernel.config
/etc/entropybroker/eb_proxy_knuth_b.config
/etc/entropybroker/eb_proxy_knuth_m.config
/etc/entropybroker/eb_server_Araneus_Alea.config
/etc/entropybroker/eb_server_ComScire_R2000KU.config
/etc/entropybroker/eb_server_audio.config
/etc/entropybroker/eb_server_egd.config
/etc/entropybroker/eb_server_ext_proc.config
/etc/entropybroker/eb_server_linux_kernel.config
/etc/entropybroker/eb_server_push_file.config
/etc/entropybroker/eb_server_smartcard.config
/etc/entropybroker/eb_server_stream.config
/etc/entropybroker/eb_server_timers.config
/etc/entropybroker/eb_server_usb.config
/etc/entropybroker/eb_server_v4l.config
/etc/entropybroker/entropy_broker.conf
/etc/entropybroker/entropy_broker.conf.dist
/etc/entropybroker/entropy_broker.config
/etc/entropybroker/t
/etc/entropybroker/users.txt
/lib/systemd/system/eb_client_egd.service
/lib/systemd/system/eb_client_file.service
/lib/systemd/system/eb_client_kernel_generic.service
/lib/systemd/system/eb_client_linux_kernel.service
/lib/systemd/system/eb_proxy_knuth_b.service
/lib/systemd/system/eb_proxy_knuth_m.service
/lib/systemd/system/eb_server_Araneus_Alea.service
/lib/systemd/system/eb_server_ComScire_R2000KU.service
/lib/systemd/system/eb_server_audio.service
/lib/systemd/system/eb_server_egd.service
/lib/systemd/system/eb_server_ext_proc.service
/lib/systemd/system/eb_server_linux_kernel.service
/lib/systemd/system/eb_server_push_file.service
/lib/systemd/system/eb_server_smartcard.service
/lib/systemd/system/eb_server_stream.service
/lib/systemd/system/eb_server_timers.service
/lib/systemd/system/eb_server_usb.service
/lib/systemd/system/eb_server_v4l.service
/lib/systemd/system/entropybroker.service
/usr/bin/eb_client_egd
/usr/bin/eb_client_file
/usr/bin/eb_client_kernel_generic
/usr/bin/eb_client_linux_kernel
/usr/bin/eb_proxy_knuth_b
/usr/bin/eb_proxy_knuth_m
/usr/bin/eb_server_Araneus_Alea
/usr/bin/eb_server_ComScire_R2000KU
/usr/bin/eb_server_audio
/usr/bin/eb_server_egd
/usr/bin/eb_server_ext_proc
/usr/bin/eb_server_linux_kernel
/usr/bin/eb_server_push_file
/usr/bin/eb_server_smartcard
/usr/bin/eb_server_stream
/usr/bin/eb_server_timers
/usr/bin/eb_server_usb
/usr/bin/eb_server_v4l
/usr/bin/entropy_broker
/usr/share/doc/entropybroker/README.Debian
/usr/share/doc/entropybroker/changelog.Debian.gz
/usr/share/doc/entropybroker/copyright
/usr/share/doc/entropybroker/entropy_broker/auth.txt
/usr/share/doc/entropybroker/entropy_broker/design.txt
/usr/share/doc/entropybroker/entropy_broker/err.txt.gz
/usr/share/doc/entropybroker/entropy_broker/interfacing.txt
/usr/share/doc/entropybroker/entropy_broker/license.txt
/usr/share/doc/entropybroker/entropy_broker/network_protocol.txt
/usr/share/doc/entropybroker/entropy_broker/readme.txt.gz
/usr/share/doc/entropybroker/entropy_broker/users.txt
/usr/share/entropybroker/web/404.html
/usr/share/entropybroker/web/favicon.ico
/usr/share/entropybroker/web/logfiles.png
/usr/share/entropybroker/web/logo-bw.png
/usr/share/entropybroker/web/logo.png
/usr/share/entropybroker/web/statistics.png
/usr/share/entropybroker/web/stylesheet.css
/usr/share/entropybroker/web/users.png
/usr/share/man/man1/eb_client_egd.1.gz
/usr/share/man/man1/eb_client_file.1.gz
/usr/share/man/man1/eb_client_kernel_generic.1.gz
/usr/share/man/man1/eb_client_linux_kernel.1.gz
/usr/share/man/man1/eb_proxy_knuth_b.1.gz
/usr/share/man/man1/eb_proxy_knuth_m.1.gz
/usr/share/man/man1/eb_server_Araneus_Alea.1.gz
/usr/share/man/man1/eb_server_ComScire_R2000KU.1.gz
/usr/share/man/man1/eb_server_audio.1.gz
/usr/share/man/man1/eb_server_egd.1.gz
/usr/share/man/man1/eb_server_ext_proc.1.gz
/usr/share/man/man1/eb_server_linux_kernel.1.gz
/usr/share/man/man1/eb_server_push_file.1.gz
/usr/share/man/man1/eb_server_smartcard.1.gz
/usr/share/man/man1/eb_server_stream.1.gz
/usr/share/man/man1/eb_server_timers.1.gz
/usr/share/man/man1/eb_server_usb.1.gz
/usr/share/man/man1/eb_server_v4l.1.gz
/usr/share/man/man1/entropy_broker.1.gz
/usr/share/man/man1/test_egd_speed.1.gz

Changelog

2017-07-05 - Thorsten Alteholz <debian@alteholz.de>
entropybroker (2.9-1) sid; urgency=medium
* new upstream version
* debian/control: bump standard to 4.0.0
* rework patches, some are applied upstream
* rework systemd service files to handle more parameters
2017-03-01 - Thorsten Alteholz <debian@alteholz.de>
entropybroker (2.8-3) unstable; urgency=medium
* fix for correct handling of ppoll (Closes: #856187)
2016-10-08 - Thorsten Alteholz <debian@alteholz.de>
entropybroker (2.8-2) unstable; urgency=medium
* don't build server_cycle_count (Closes: #840018)
It uses a CPU register as source for entropy that is not available 
on all architectures)
* replace constant 8lu by (size_t)8 (Closes: #840019)
sizeof operator returns a constant with type std::size_t, which
is not unsigned long on all architectures
* take care of unavailable constants (Closes: #840020)
sparc64 does not know some baudrates
* thanks a lot to Aaron M. Ucko for his suggestions to solve
these bugs
2016-10-04 - Thorsten Alteholz <debian@alteholz.de>
entropybroker (2.8-1) unstable; urgency=medium
* initial upload (Closes: #545148)

See Also

Package Description
enum_1.1-1_amd64.deb seq- and jot-like enumerator
env2_1.1.0-4_all.deb convert environment variables between scripting languages
environment-modules_4.1.1-1_amd64.deb Modular system for handling environment variables
envstore_2.1-4_amd64.deb store for environment variables across shell processes
eoconv_1.5-1_amd64.deb convert text files between various Esperanto encodings
eog-plugin-disable-dark-theme_3.26.2-1_amd64.deb Disable Dark Theme plugin for GNOME Image Viewer
eog-plugin-exif-display_3.26.2-1_amd64.deb Exif Display plugin for GNOME Image Viewer
eog-plugin-export-to-folder_3.26.2-1_amd64.deb Export to Folderplugin for GNOME Image Viewer
eog-plugin-fit-to-width_3.26.2-1_amd64.deb Fit to Width plugin for GNOME Image Viewer
eog-plugin-fullscreen-background_3.26.2-1_amd64.deb Fullscreen Background plugin for GNOME Image Viewer
eog-plugin-hide-titlebar_3.26.2-1_amd64.deb Hide Titlebarplugin for GNOME Image Viewer
eog-plugin-map_3.26.2-1_amd64.deb Map plugin for GNOME Image Viewer
eog-plugin-maximize-windows_3.26.2-1_amd64.deb Maximize Windows plugin for GNOME Image Viewer
eog-plugin-picasa_3.26.2-1_amd64.deb Picasa plugin for GNOME Image Viewer
eog-plugin-python-console_3.26.2-1_amd64.deb Python Console plugin for GNOME Image Viewer
Advertisement
Advertisement