ent_1.2debian-1build1_amd64.deb


Advertisement

Description

ent - pseudorandom number sequence test program

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name ent
Package version 1.2debian
Package release 1build1
Package architecture amd64
Package type deb
Installed size 36 B
Download size 12.79 KB
Official Mirror archive.ubuntu.com
This program applies various tests to sequences of bytes stored in
files and reports the results of those tests. The program is useful
for those evaluating pseudorandom number generators for encryption and
statistical sampling applications, compression algorithms, and other
applications where the information density of a file is of interest.
Original Homepage: http://www.fourmilab.ch/random/
(Now maintained primarily in Debian.)

Alternatives

Package Version Architecture Repository
ent_1.2debian-1build1_i386.deb 1.2debian i386 Ubuntu Universe
ent - - -

Requires

Name Value
libc6 >= 2.4

Download

Type URL
Binary Package ent_1.2debian-1build1_amd64.deb
Source Package ent

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ent deb package:
    # sudo apt-get install ent

Files

Path
/usr/bin/ent
/usr/share/doc/ent/changelog.Debian.gz
/usr/share/doc/ent/copyright
/usr/share/man/man1/ent.1.gz

Changelog

2018-04-03 - Balint Reczey <rbalint@ubuntu.com>
ent (1.2debian-1build1) bionic; urgency=high
* No change rebuild to pick up -fPIE compiler default
2015-06-13 - Thorsten Alteholz <debian@alteholz.de>
ent (1.2debian-1) unstable; urgency=medium
* New upstream release (Closes: #774021)
* debian/control: bump standard to 3.9.6 (no changes)
2014-05-10 - Thorsten Alteholz <debian@alteholz.de>
ent (1.1debian-4) unstable; urgency=low
* debian/control: bump standard to 3.9.5 (no changes)
* fix typo in manpage (Closes: #747541)
Patch from "D. Joe Anderson" <deejoe@etrumeus.com>
2012-11-07 - Thorsten Alteholz <debian@alteholz.de>
ent (1.1debian-3) unstable; urgency=low
* debian/patches/totalcount.patch: prevent overflow (Closes: #692214)
2012-06-05 - Thorsten Alteholz <debian@alteholz.de>
ent (1.1debian-2) unstable; urgency=low
* new maintainer (Closes: #568140)
* debian/control: use dehelper 9
* debian/control: bump standard to 3.9.3 (no changes)
* debian/control: added old Homepage:
* debian/rules: move to dh
* debian/ent.install use this file for installation
* debian/source/format: added
* debian/watch: add empty watch file (no more upstream development)
* debian/patches: changes moved to patches
2010-07-17 - Jakub Wilk <jwilk@debian.org>
ent (1.1debian-1.1) unstable; urgency=low
* Non-maintainer upload.
* Remove private definition of log2() function; use the function provided by
the C library library instead (closes: #552835).
* Add ‘Depends: ${misc:Depends}’.
2007-08-25 - Wesley J. Landaker <wjl@icecavern.net>
ent (1.1debian-1) unstable; urgency=low
* New upstream release
* All Debian patches rolled in upstream
* Now generates documentation with asciidoc, docbook2x
* Updated to Debian Policy 3.7.2 (no changes necessary)
* Bumped debhelper compatibility up to 5
* Removed test stuff from examples; it's now verified during build
2006-05-03 - Wesley J. Landaker <wjl@icecavern.net>
ent (1.0-6) unstable; urgency=low
* Compile with -Wall and -Werror
* Add missing braces in multi-dimensional array initializer
* Update to Policy 3.7.1.0 (no changes necessary)
* Clarify packaging license in debian/copyright
* More slight manpage fixes, not using txt2man anymore
* Fixed up Makefile's clean target a bit
* Disabled test target during build; it's unnecessary (closes: #355726)
* Allow -h for command line help so we aren't confusing
2005-06-14 - Wesley J. Landaker <wjl@icecavern.net>
ent (1.0-5) unstable; urgency=low
* Fixed package description slightly
* Cleaned up debian/rules
* Fixed manpage title (ENT -> ent)
2005-03-18 - Wesley J. Landaker <wjl@icecavern.net>
ent (1.0-4) unstable; urgency=low
* Acknowledge QA maintainer.
* Fixed hyphens in man page

See Also

Package Description
entagged_0.35-6_all.deb graphical audio file tagger with freedb support
entangle_0.7.2-1ubuntu1_amd64.deb Tethered Camera Control & Capture
entr_3.9-1_amd64.deb Run arbitrary commands when files change
entropybroker_2.9-1_amd64.deb infrastructure for distributing random numbers (entropy data)
enum_1.1-1_amd64.deb seq- and jot-like enumerator
env2_1.1.0-4_all.deb convert environment variables between scripting languages
environment-modules_4.1.1-1_amd64.deb Modular system for handling environment variables
envstore_2.1-4_amd64.deb store for environment variables across shell processes
eoconv_1.5-1_amd64.deb convert text files between various Esperanto encodings
eog-plugin-disable-dark-theme_3.26.2-1_amd64.deb Disable Dark Theme plugin for GNOME Image Viewer
eog-plugin-exif-display_3.26.2-1_amd64.deb Exif Display plugin for GNOME Image Viewer
eog-plugin-export-to-folder_3.26.2-1_amd64.deb Export to Folderplugin for GNOME Image Viewer
eog-plugin-fit-to-width_3.26.2-1_amd64.deb Fit to Width plugin for GNOME Image Viewer
eog-plugin-fullscreen-background_3.26.2-1_amd64.deb Fullscreen Background plugin for GNOME Image Viewer
eog-plugin-hide-titlebar_3.26.2-1_amd64.deb Hide Titlebarplugin for GNOME Image Viewer
Advertisement
Advertisement