elpa-projectile_0.14.0-2_all.deb


Advertisement

Description

elpa-projectile - project interaction library for Emacs

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name elpa-projectile
Package version 0.14.0
Package release 2
Package architecture all
Package type deb
Installed size 178 B
Download size 31.53 KB
Official Mirror archive.ubuntu.com
This library enhances Emacs with easy project management and
navigation. The concept of a project is simple: just a folder
containing a special file.  Currently git, mercurial, darcs and
bazaar repos are considered projects by default.  So are lein, maven,
sbt, scons, rebar and bundler projects.  If you want to mark a folder
manually as a project just create an empty .projectile file in it.
Some of Projectile's features:
* jump to a file in project
* jump to files at point in project
* jump to a directory in project
* jump to a file in a directory
* jump to a project buffer
* jump to a test in project
* toggle between files with same names but different extensions
(e.g. `.h` <-> `.c/.cpp`, `Gemfile` <-> `Gemfile.lock`)
* toggle between code and its test (e.g. `main.service.js` <->
`main.service.spec.js`)
* jump to recently visited files in the project
* switch between projects you have worked on
* kill all project buffers
* replace in project
* multi-occur in project buffers
* grep in project
* regenerate project etags or gtags
* visit project in dired
* run make in a project with a single key chord

Alternatives

Package Version Architecture Repository
elpa-projectile_0.14.0-2_all.deb 0.14.0 all Ubuntu Universe
elpa-projectile - - -

Requires

Name Value
elpa-dash >= 2.11.0
elpa-pkg-info >= 0.4
emacs -
emacsen-common -

Download

Type URL
Binary Package elpa-projectile_0.14.0-2_all.deb
Source Package projectile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install elpa-projectile deb package:
    # sudo apt-get install elpa-projectile

Files

Path
/usr/lib/emacsen-common/packages/compat/elpa-projectile
/usr/lib/emacsen-common/packages/install/elpa-projectile
/usr/lib/emacsen-common/packages/remove/elpa-projectile
/usr/share/doc/elpa-projectile/README.md
/usr/share/doc/elpa-projectile/changelog.Debian.gz
/usr/share/doc/elpa-projectile/copyright
/usr/share/emacs/site-lisp/elpa-src/projectile-0.14.0/projectile-autoloads.el
/usr/share/emacs/site-lisp/elpa-src/projectile-0.14.0/projectile-pkg.el
/usr/share/emacs/site-lisp/elpa-src/projectile-0.14.0/projectile.el

Changelog

2017-12-22 - Sean Whitton <spwhitton@spwhitton.name>
projectile (0.14.0-2) unstable; urgency=medium
* Update dependency dash-el => elpa-dash (Closes: #865915).
Thanks to Mykola Nikishov for reporting the problem.
- Bump dh-elpa build dependency to (>= 1.7).
Ensures that elpa-dash is included in ${elpa:Depends}.
* Add build-dependency on mkdocs-bootstrap (Closes: #884772).
Thanks Antonio Terceiro for reporting the bug and indicating the fix.
* Correct debhelper build-dep bound to match compat.
* Switch from d/rules DH_ELPA_TEST_ERT_HELPER to entry in d/elpa-test
config file (see dh_elpa_test(1)).
* Drop d/source/local-options for dgit.
* Declare compliance with Debian Policy 4.1.2.
* Drop unused Lintian overrides:
- package-needs-versioned-debhelper-build-depends
- package-uses-experimental-debhelper-compat-version
- privacy-breach-generic *html5shiv.js*
- privacy-breach-generic *respond.min.js*
2016-07-24 - Sean Whitton <spwhitton@spwhitton.name>
projectile (0.14.0-1) unstable; urgency=medium
* New upstream release.
- elpa-persp-projectile & elpa-helm-projectile binary packages dropped.
They now have their own source packages.
* New projectile-doc binary package installing HTML manual.
- elpa-projectile Suggests: projectile-doc
- Add dh sequencer argument: --with linktree
- New build dependency on dh-linktree
- Add doc-base registration
- Add d/clean
- Add projectile-doc.lintian-overrides
* Run test suite with dh_elpa_test.
- Bump debhelper compat to 10.
- Add source Lintian overrides:
- package-needs-versioned-debhelper-build-depends
- package-uses-experimental-debhelper-compat-version
* Quilt patches:
- Append to 0001-patch-README.patch to remove screenshot.
Screenshots now installed by projectile-doc.
- Drop 0003-fix-cleanup-known-projects-test.patch
Merged upstream.
- Rename 0004-debianise-exuberant-ctags-dep.patch
to 0003-debianise-exuberant-ctags-dep.patch
- Add 0004-drop-external-gratipay-image.patch
- Add 0005-configure-mkdocs-for-Debian.patch
- Refresh patches
* d/copyright updates:
- bump copyright years and add upstream author's e-mail address
- remove paragraph for persp-projectile.el
* Run wrap-and-sort -abst
* Bump standards version to 3.9.8 (no changes required).
2016-02-21 - Sean Whitton <spwhitton@spwhitton.name>
projectile (0.13.0-1) unstable; urgency=medium
* Initial release. (Closes: #807839)

See Also

Package Description
elpa-ps-ccrypt_1.10-6_all.deb Emacs addon for working with files encrypted with ccrypt
elpa-py-autopep8_2016.1-1_all.deb use autopep8 to beautify a Python buffer
elpa-py-isort_2016.1-2_all.deb use isort to sort the imports in a Python buffer
elpa-python-environment_0.0.2-2_all.deb virtualenv API for Emacs Lisp
elpa-pyvenv_1.12-1_all.deb Python virtual environment interface
elpa-qml-mode_0.4-1_all.deb Emacs major mode for editing QT Declarative (QML) code
elpa-queue_0.2-1_all.deb queue data structure for Emacs Lisp
elpa-racket-mode_20170617+0+g9c5bcb7-2_all.deb emacs support for editing and running racket code
elpa-rainbow-delimiters_2.1.3-1_all.deb Emacs mode to colour-code delimiters according to their depth
elpa-rainbow-identifiers_0.2.2-2_all.deb highlight identifiers according to their names
elpa-rainbow-mode_0.13-1_all.deb colorize color names in buffers
elpa-recursive-narrow_20140811.1546-1_all.deb narrow-to-region that operates recursively
elpa-redtick_00.01.02+git20170220.e6d2e9b+dfsg-1_all.deb tiny pomodoro timer for Emacs
elpa-restart-emacs_0.1.1-1_all.deb restart emacs from within emacs
elpa-rich-minority_1.0.2-1_all.deb clean-up and beautify the list of minor-modes in Emacs' mode-line
Advertisement
Advertisement