editmoin_1.17-2_all.deb


Advertisement

Description

editmoin - edit MoinMoin wiki pages with your favourite editor

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name editmoin
Package version 1.17
Package release 2
Package architecture all
Package type deb
Installed size 51 B
Download size 12.66 KB
Official Mirror archive.ubuntu.com
editmoin allows you to edit pages in MoinMoin wikis with your
preferred editor instead of the (usually quite limited) web
browser text areas.
It also supports configuration files to define shortcuts for URLs
that you edit often.
This package also includes a Vim syntax file. Install
vim-addon-manager and use "vim-addons install editmoin" to activate.
However, you can use any other editor by setting the standard $EDITOR
environment variable.

Alternatives

Package Version Architecture Repository
editmoin_1.17-2_all.deb 1.17 all Ubuntu Universe
editmoin - - -

Requires

Name Value
python:any -

Download

Type URL
Binary Package editmoin_1.17-2_all.deb
Source Package editmoin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install editmoin deb package:
    # sudo apt-get install editmoin

Files

Path
/usr/bin/editmoin
/usr/share/doc/editmoin/changelog.Debian.gz
/usr/share/doc/editmoin/copyright
/usr/share/man/man1/editmoin.1.gz
/usr/share/vim/addons/plugin/moin.vim
/usr/share/vim/addons/syntax/moin1_5.vim
/usr/share/vim/addons/syntax/moin1_6.vim
/usr/share/vim/registry/vim-editmoin.yaml

Changelog

2016-11-23 - Martin Pitt <mpitt@debian.org>
editmoin (1.17-2) unstable; urgency=medium
* Move packaging to collab-maint git, update Vcs-* accordingly
* Bump debhelper compat to 9
* Annotate python dependency with ":any" M-A qualifier
* debian/copyright: Move to machine parseable copyright format 1.0
* Bump Standards-Version to 3.9.8
* Manage/reformat patches with gbp pq
2011-07-06 - Martin Pitt <mpitt@debian.org>
editmoin (1.17-1) unstable; urgency=low
* New upstream release:
- Use sensible-editor instead of vi to pick up the system level editor
preference.
- Add support for URLs that include query parameters.
* Switch to 3.0 source package format.
* Move inline change to editmoin.1 to 01_man_ids_from_firefox.patch. Also
update it to catch cookies like "MOIN_SESSION_443_ROOT".
* Move moin-plugin.vim into debian/, to work better for 3.0 source.
* debian/control: Bump Standards-Version to 3.9.2.
* Add 02_alternative_cookie_names.patch: Current moin versions use
MOIN_SESSION_80_ROOT or MOIN_SESSION_443_ROOT cookie names. Try these
before the standard MOIN_SESSION cookie. Thanks Andy Whitcroft for the
patch! (LP: #801284)
* debian/editmoin.install, debian/rules: Simplify installation of vim
plugin.
* Add bzr-builddeb configuration (merge mode).
2011-02-11 - Martin Pitt <mpitt@debian.org>
editmoin (1.16-1) unstable; urgency=low
* New upstream release:
- Split editing logic in its own function
- avoid showing the note message multiple times
- allow arguments in $EDITOR variable
* editmoin.1: Add example command how to parse moin wiki IDs from
mozilla/firefox cookie database.
* debian/control: Fix typo in "vim-addons" in long description.
(Closes: #612706)
* Drop Pythonic build system; this is only a single-script program, no
modules at all, and setup.py installs too much noise around it. Just
install the executable and manpage manually.
* Move to debhelper level 7 and from cdbs to dh.
* Bump Standards-Version to 3.9.1.
2010-06-23 - Martin Pitt <mpitt@debian.org>
editmoin (1.15-1) unstable; urgency=low
* New upstream release:
- Moin used to work with numerical IDs for identification, and editmoin
was still based on this model. This release adds support for direct
authentication as available in current Moin releases.
- The new file ~/.moin_users is now parsed to obtain usernames, supporting
the feature above. Shortcuts are also supported in this file. 
- Added support for textcha question handling.
* debian/control: Replace python-dev build dependency (which isn't really
required) with just python.
* Bump Standards-Version to 3.8.4 (no changes necessary).
* Add debian/source/format. Keep 1.0 for now, 3.0 does not work well for VCS
maintained packages.
2009-05-03 - Martin Pitt <mpitt@debian.org>
editmoin (1.10.1-3) unstable; urgency=low
* editmoin: Fix md5 deprecation warning with Python 2.6, thanks to Max
Bowsher. (LP: #357221)
* debian/control: Add missing misc:Depends, thanks lintian.
* debian/control: Bump Standards-Version (no changes necessary).
2008-07-13 - Martin Pitt <mpitt@debian.org>
editmoin (1.10.1-2) unstable; urgency=low
* Rebuild against latest python-central. (Closes: #490460)

See Also

Package Description
editorconfig-doc_0.12.1-1.1_all.deb coding style indenter across editors - documentation
editorconfig_0.12.1-1.1_amd64.deb coding style indenter for all editors - commandline tools
editra_0.7.20+dfsg.1-3_all.deb simple multi-platform text editor
edtsurf_0.2009-5_amd64.deb triangulated mesh surfaces for protein structures
edubuntu-artwork_15.12.1_all.deb edubuntu themes and artwork
edubuntu-desktop_15.12.9_amd64.deb educational desktop for Ubuntu
edubuntu-docs_11.03.3_all.deb The Ubuntu Documentation Project - Edubuntu Documentation
edubuntu-fonts_15.12.9_amd64.deb Additional fonts included on a default Edubuntu system
edubuntu-live_14.04.2build1_all.deb Edubuntu live media support
edubuntu-menueditor_1.3.5-0ubuntu2_all.deb Simple ui to manage different menu profiles on a system
edubuntu-wallpapers_15.12.1_all.deb wallpapers included in edubuntu
eegdev-plugins-free_0.2-3.1_amd64.deb Biosignal acquisition device library (free plugins)
eekboek-db-postgresql_2.02.05+dfsg-2_all.deb PostgreSQL database driver for EekBoek
eekboek-gui_2.02.05+dfsg-2_all.deb Graphical User Interface for EekBoek
eekboek_2.02.05+dfsg-2_all.deb Bookkeeping software for small and medium-size businesses
Advertisement
Advertisement