drumgizmo_0.9.14-3_amd64.deb


Advertisement

Description

drumgizmo - Audio sampler plugin and stand-alone app that simulates a real drum kit

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name drumgizmo
Package version 0.9.14
Package release 3
Package architecture amd64
Package type deb
Installed size 1.14 KB
Download size 338.44 KB
Official Mirror archive.ubuntu.com
DrumGizmo's main aim is to simulate a real drum kit. Features:
- Stand-alone application, Lv2 plugin version available
- Drum multilayer velocities, allowing for several different hit
velocities for each drum
- Multichannel output, making it possible to mix it just the way you
would a real drumkit
- Optional built-in humanizer, analyzing the MIDI notes, adjusting
velocities on-the-fly
- Mic bleed simulation
- Open drumkit file format, allowing to create your own drumkits
- Stand-alone MIDI renderer, generating .wav files, 1 for each channel
- Stand-alone MIDI input, making it possible to use DrumGizmo as a
software sampler for an electronic drumkit
Please note that for using DrumGizmo you will need to download some
compatible drum kit audio data made by the community (such as those
available at www.drumgizmo.org) or create one yourself with DGEdit
(provided in the dgedit package).

Alternatives

Package Version Architecture Repository
drumgizmo_0.9.14-3_i386.deb 0.9.14 i386 Ubuntu Universe
drumgizmo - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.15
libexpat1 >= 2.0.1
libgcc1 >= 1:3.0
libjack-0.125 -
libjack-jackd2-0 >= 1.9.10+20150825
libsmf0 >= 1.3
libsndfile1 >= 1.0.20
libstdc++6 >= 5.2
libx11-6 -
libxext6 -
libzita-resampler1 -

Provides

Name Value
lv2-plugin -

Download

Type URL
Binary Package drumgizmo_0.9.14-3_amd64.deb
Source Package drumgizmo

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install drumgizmo deb package:
    # sudo apt-get install drumgizmo

Files

Path
/usr/bin/drumgizmo
/usr/lib/lv2/drumgizmo.lv2/drumgizmo.so
/usr/lib/lv2/drumgizmo.lv2/drumgizmo.ttl
/usr/lib/lv2/drumgizmo.lv2/manifest.ttl
/usr/share/doc/drumgizmo/README.Debian
/usr/share/doc/drumgizmo/changelog.Debian.gz
/usr/share/doc/drumgizmo/copyright
/usr/share/man/man1/drumgizmo.1.gz
/usr/share/man/man1/drumgizmo.fr.1.gz

Changelog

2017-10-13 - James Cowgill <jcowgill@debian.org>
drumgizmo (0.9.14-3) unstable; urgency=medium
* Team upload.
* debian/control:
- Bump standards version to 4.1.1.
* debian/patches/0003-testsuite.patch:
- Fix testsuite failures on various architectures. (Closes: #872586)
* debian/watch:
- Update to use uscan v4 and use https download URL.
2017-08-12 - Sebastian Ramacher <sramacher@debian.org>
drumgizmo (0.9.14-2) unstable; urgency=medium
* Team upload.
* Upload to unstable.
[ Víctor Cuadrado Juan ]
* Bump Std-Ver to 4.0.0
* Upload back to Unstable after freeze
[ Sebastian Ramacher ]
* debian/control:
- Remove superfluous B-D on libcppunit-1.13-0v5 (Closes: #870400)
- Bump Standards-Version.
2017-07-01 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.14-1) experimental; urgency=medium
* New upstream version 0.9.12
- switches from cppunit.m4 to pkg-config (closes: #862134)
* New upstream version 0.9.13
* New upstream version 0.9.14
* Update d/patches and d/copyright to new upstream version
- Drop 0002-mips-atomic.patch as it upstreamed
- Update 0001-alsa-kFreeBSD.patch to new version
- Add 0002-disable-lv2-test.patch
* Don't short-cirtuit dh_auto_test now that lv2 test is disabled
* Add items to TODO.Debian
2016-11-08 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.11-3) unstable; urgency=medium
* Change mips-atomic.patch to always link libatomic
* Refactor patch names from gbp pq usage
2016-11-07 - James Cowgill <jcowgill@debian.org>
drumgizmo (0.9.11-2) unstable; urgency=medium
* Team upload.
* Use sse2 on amd64 instead of sse3. (Closes: #843149)
[ Radovan Birdic ]
* Ensure libatomic test checks for large integers. Fixes FTBFS on
mips/mipsel. (Closes: #843136)
2016-11-01 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.11-1) unstable; urgency=medium
* New upstream version 0.9.11
- Add back support for test inputengine
* Update Std-Ver to 3.9.8
* Add Build-Dep for tests and test engine
* Enable tests and test engine compilation (Closes: #841791)
* Enable make check for review purposes but don't trust it yet
* Don't pack new /usr/bin/dgreftest as not useful for non-devs
* Update d/TODO.Debian
* Fix typo in d/changelog
* Reformat and update d/copyright for last upstream version
* Update dh compat level to 10
- Declare Build-dep on debhelper (>= 10)
- Remove --parallel and --with autoreconf as they are default in dh 10
- Remove Build-Dep on dh-autoreconf as it is obsolete now
* Run wrap-and-sort
2016-04-05 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.10-1) unstable; urgency=medium
* New upstream release: version 0.9.10
- Upstream disabled SSE on the code because of bugs
* Update d/copyright: license change to LGPL-3+, add 2016
* Drop patch 01-FTBFS-KfreeBSD.patch as it's upstreamed
* Refresh patch alsa-kFreeBSD.patch
* Don't delete drumgizmo.a as not there anymore
* Enable largefile support by configure flag
* Add upstream's GPG key and start checking signatures
* Remove README.source as not needed
2016-02-09 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.8.1-3) unstable; urgency=medium
* Add patch to fix FTBFS for KfreeBSD: reduce alsa to >=1.0.5
2016-02-09 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.8.1-2) unstable; urgency=medium
* Update standards version to 3.9.7
* Use a secure transport (https) for Vcs-Git field
* Fix --enable-gui-x11 on BSD (Closes: #814125)
2015-10-19 - Víctor Cuadrado Juan <me@viccuad.me>
drumgizmo (0.9.8.1-1) unstable; urgency=low
* Initial release (Closes: #802269).

See Also

Package Description
drumkv1-common_0.8.6-1_amd64.deb old-school drum-kit sampler - common files
drumkv1-lv2_0.8.6-1_amd64.deb old-school drum-kit sampler - lv2-plugin
drumkv1_0.8.6-1_amd64.deb old-school drum-kit sampler - standalone
drumstick-tools_0.5.0-4_amd64.deb Qt4/C++ wrapper for ALSA Sequencer - utilities
dsdp-doc_5.8-9.4_all.deb Software for Semidefinite Programming
dsdp_5.8-9.4_amd64.deb Software for Semidefinite Programming
dsh_0.25.10-1.3_amd64.deb dancer's shell, or distributed shell
dsniff_2.4b1+debian-28.1~build1_amd64.deb Various tools to sniff network traffic for cleartext insecurities
dspdfviewer_1.15.1-1build1_amd64.deb Dual-Screen PDF Viewer for LaTeX-beamer
dssi-dev_1.1.1~dfsg0-1build2_all.deb Header file for compiling DSSI plugins and hosts
dssi-example-plugins_1.1.1~dfsg0-1build2_amd64.deb Examples of DSSI plugin
dssi-host-jack_1.1.1~dfsg0-1build2_amd64.deb Example of DSSI host
dssi-utils_1.1.1~dfsg0-1build2_amd64.deb Command-line utilities for sending commands to DSSI plugins
dssp_3.0.0-2_amd64.deb protein secondary structure assignment based on 3D structure
dstat_0.7.3-1_all.deb versatile resource statistics tool
Advertisement
Advertisement