dpdk-rte-kni-dkms_17.11.1-6_amd64.deb


Advertisement

Description

dpdk-rte-kni-dkms - Data Plane Development Kit (rte kni dkms)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name dpdk-rte-kni-dkms
Package version 17.11.1
Package release 6
Package architecture amd64
Package type deb
Installed size 1.96 KB
Download size 295.08 KB
Official Mirror archive.ubuntu.com
DPDK is a set of libraries for fast packet processing. Applications run
in user-space and communicate directly with dedicated network interfaces.
This package contains the source code for the rte_kni kernel module.

Alternatives

Package Version Architecture Repository
dpdk-rte-kni-dkms_17.11.3-3~ubuntu0.18.04_amd64.deb 17.11.3 amd64 Ubuntu Updates Universe
dpdk-rte-kni-dkms_17.11.3-3~ubuntu0.18.04_i386.deb 17.11.3 i386 Ubuntu Updates Universe
dpdk-rte-kni-dkms_17.11.1-6_i386.deb 17.11.1 i386 Ubuntu Universe
dpdk-rte-kni-dkms - - -

Requires

Name Value
dkms >= 2.1.0.0
dpdk-dev = 17.11.1-6
libdpdk-dev = 17.11.1-6
make -

Download

Type URL
Binary Package dpdk-rte-kni-dkms_17.11.1-6_amd64.deb
Source Package dpdk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install dpdk-rte-kni-dkms deb package:
    # sudo apt-get install dpdk-rte-kni-dkms

Files

Path
/usr/share/doc/dpdk-rte-kni-dkms/changelog.Debian.gz
/usr/share/doc/dpdk-rte-kni-dkms/copyright
/usr/src/dpdk-rte-kni-17.11.1/Makefile
/usr/src/dpdk-rte-kni-17.11.1/compat.h
/usr/src/dpdk-rte-kni-17.11.1/dkms.conf
/usr/src/dpdk-rte-kni-17.11.1/kni_dev.h
/usr/src/dpdk-rte-kni-17.11.1/kni_ethtool.c
/usr/src/dpdk-rte-kni-17.11.1/kni_fifo.h
/usr/src/dpdk-rte-kni-17.11.1/kni_misc.c
/usr/src/dpdk-rte-kni-17.11.1/kni_net.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/README
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_82575.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_82575.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_api.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_api.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_defines.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_hw.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_i210.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_i210.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_mac.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_mac.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_manage.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_manage.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_mbx.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_mbx.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_nvm.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_nvm.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_osdep.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_phy.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_phy.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/e1000_regs.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_ethtool.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_main.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_param.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_regtest.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_vmdq.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/igb_vmdq.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/igb/kcompat.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_82598.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_82598.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_82599.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_82599.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_api.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_api.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_common.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_common.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_dcb.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_ethtool.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_fcoe.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_main.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_mbx.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_osdep.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_phy.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_phy.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_type.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_x540.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/ixgbe_x540.h
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/kcompat.c
/usr/src/dpdk-rte-kni-17.11.1/ethtool/ixgbe/kcompat.h

Changelog

2018-03-14 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-6) unstable; urgency=medium
* test-linkage: drop brittle test for secondary library dependencies
2018-03-13 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-5) unstable; urgency=medium
[ Christian Ehrhardt ]
* d/t/control: depend on dpdk-dev to be able to use dpdk-sdk-env.sh
* d/t/testlinkage: improvements and fixes for current debci issues
- Use RTE_SDK to build the binary
- verbose execution for better debugging
- check for librt instead of libpthread as second level lib
- use a valid prototype for main
[ Luca Boccassi ]
2018-03-12 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-4) unstable; urgency=medium
[ Christian Ehrhardt ]
* d/control: let libdpdk-dev depend on zlib1g-dev as it is used on build and
creeps into pkg-config. Even thou at the moment no dpdk .so uses it is
required to build correctly with the libs provided by pkg-config.
[ Luca Boccassi ]
2018-03-09 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-3) unstable; urgency=medium
* autopkgtest: add pkg-config dependency to really fix linkage test.
2018-03-08 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-2) unstable; urgency=medium
* autopkgtest: use libdpdk pkg-config to set all the required compiler
flags.
2018-03-07 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-1) unstable; urgency=medium
* New upstream release 17.11.1; for a full list of changes see:
http://dpdk.org/doc/guides/rel_notes/release_17_11.html
2018-02-08 - Luca Boccassi <bluca@debian.org>
dpdk (17.11-5) unstable; urgency=medium
* Bump Standards-Version to 4.1.1, no changes.
* Add dependency on Python to dpdk-doc for diagram-generator.py and
pipeline-to-core-mapping.py. Fixes Lintian Error:
python-script-but-no-python-dep
* Fix librte-gro17.11 short description to mention -gro instead of
-eal. (Closes: #885832)
* dpdk: depend on python3-pyelftools since the scripts can work with either
version.
* dpdk-doc: depend only on python3 since the pipeline tools can work
with python3. (Closes: #883153)
* dpdk/dpdk-doc: change all scripts shebangs from python to python3.
* dpdk-doc: mark Python dependency with :any.
* Bump Standards-Version to 4.1.3 - no changes.
* d/control, d/changelog: use HTTPS for dpdk.org links.
2018-01-04 - Luca Boccassi <bluca@debian.org>
dpdk (17.11-4) unstable; urgency=low
[ Luca Boccassi ]
* Fix librte-gro17.11 short description to mention -gro instead of
-eal. (Closes: #885832)
[ Christian Ehrhardt ]
* d/rules: make auto-loaded drivers dir versioned (LP: #1741244).
3rd party drivers should drop into the versioned directories now to show
their support for that version and to be autoloaded by librte_eal due
to that.
2017-12-18 - Luca Boccassi <bluca@debian.org>
dpdk (17.11-3) unstable; urgency=medium
* Upload to unstable.
2017-11-30 - Luca Boccassi <bluca@debian.org>
dpdk (17.11-2) experimental; urgency=medium
* Bump Standards-Version to 4.1.1, no changes.
* Add dependency on Python to dpdk-doc for diagram-generator.py and
pipeline-to-core-mapping.py. Fixes Lintian Error:
python-script-but-no-python-dep

See Also

Package Description
dphys-config_20130301~current-5_all.deb Tool to distribute config files by fetching them
dphys-swapfile_20100506-3_all.deb Autogenerate and use a swap file
dpic_2014.01.01+dfsg1-0ubuntu2_amd64.deb Produce diagrams for LaTeX documents or web files
dpkg-awk_1.2+nmu2_all.deb Gawk script to parse /var/lib/dpkg/{status,available} and Packages
dpkg-dev-el_36.3ubuntu1_all.deb Emacs helpers specific to Debian development
dpkg-sig_0.13.1+nmu4_all.deb create and verify signatures on .deb-files
dpkg-www_2.57_all.deb Web based Debian package browser
dpm-copy-server-mysql_1.10.0-2_amd64.deb DPM copy server with MySQL database backend
dpm-copy-server-postgres_1.10.0-2_amd64.deb DPM copy server with postgres database backend
dpm-name-server-mysql_1.10.0-2_amd64.deb DPM nameserver server with MySQL database backend
dpm-name-server-postgres_1.10.0-2_amd64.deb DPM nameserver server with postgres database backend
dpm-rfio-server_1.10.0-2_amd64.deb DPM RFIO (Remote File IO) server
dpm-server-mysql_1.10.0-2_amd64.deb Disk Pool Manager (DPM) server with MySQL database backend
dpm-server-postgres_1.10.0-2_amd64.deb Disk Pool Manager (DPM) server with postgres database backend
dpm-srm-server-mysql_1.10.0-2_amd64.deb DPM SRM server with MySQL database backend
Advertisement
Advertisement