dose-distcheck_5.0.1-9build3_amd64.deb


Advertisement

Description

dose-distcheck - Checks whether dependencies of packages can be satisfied

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name dose-distcheck
Package version 5.0.1
Package release 9build3
Package architecture amd64
Package type deb
Installed size 4.14 KB
Download size 891.80 KB
Official Mirror archive.ubuntu.com
This software checks for every package of a distribution whether it
is possible to satisfy its dependencies and conflicts within this
distribution. It comes in several versions:
- dose-debcheck for Debian packages
- dose-rpmcheck for rpm packages
- dose-eclipsecheck for OSGi plugins

Alternatives

Package Version Architecture Repository
dose-distcheck_5.0.1-9build3_i386.deb 5.0.1 i386 Ubuntu Universe
dose-distcheck - - -

Requires

Name Value
libbz2-1.0 -
libc6 >= 2.17
librpm8 >= 4.14.0+dfsg1
librpmio8 >= 4.14.0+dfsg1
xz-utils -
zlib1g >= 1:1.1.4

Replaces

Name Value
dose3-distcheck << 2.9.13

Download

Type URL
Binary Package dose-distcheck_5.0.1-9build3_amd64.deb
Source Package dose3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install dose-distcheck deb package:
    # sudo apt-get install dose-distcheck

Files

Path
/usr/bin/dose-debcheck
/usr/bin/dose-distcheck
/usr/bin/dose-eclipsecheck
/usr/bin/dose-rpmcheck
/usr/share/doc/dose-distcheck/NEWS.Debian.gz
/usr/share/doc/dose-distcheck/changelog.Debian.gz
/usr/share/doc/dose-distcheck/copyright
/usr/share/man/man1/dose-debcheck.1.gz
/usr/share/man/man1/dose-distcheck.1.gz
/usr/share/man/man1/dose-eclipsecheck.1.gz
/usr/share/man/man1/dose-rpmcheck.1.gz

Changelog

2017-11-12 - Matthias Klose <doko@debian.org>
dose3 (5.0.1-9build3) bionic; urgency=medium
* No-change rebuild for librpm soname bump.
2017-10-28 - Gianfranco Costamagna <locutusofborg@debian.org>
dose3 (5.0.1-9build2) bionic; urgency=medium
* Rebuild against new OCAML ABIs.
2017-08-31 - Dimitri John Ledkov <xnox@ubuntu.com>
dose3 (5.0.1-9build1) artful; urgency=high
* No change rebuild against new ocaml abis.
2017-07-19 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-9) unstable; urgency=medium
* patch virtual_provides: packages that provide the same virtual package
in different versions, or that provide the same versioned virtual package
as a real package, are co-installable (closes: #867104, #864906).
* add a test-case for bug  #867104
* dose-doc: set Multi-Arch=foreign
* add build-dependency on ocamlbuild
* standards-version 4.0.0 (no change)
2017-01-17 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-8) unstable; urgency=medium
* Patches taken from upstream (thanks, Josch!)
- architecture-tuples: replace architecture triples by tuples.
(closes: #843409)
- architectures-dpkg-1.18.15: Update embedded cputable and tupletable
to dpkg 1.18.15
- deb-drop-d-b-arch: add support for --deb-drop-b-d-arch (closes: #850943)
2016-11-03 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-7) unstable; urgency=medium
* use pic options only on native architectures.
2016-10-27 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-6) unstable; urgency=medium
* New patch ocaml-4.02.3+gcc-6.2.0 as provided by Josch: fix FTBFS. This
patch should probably be removed when we transition to ocaml 4.03.
2016-10-26 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-4) unstable; urgency=medium
* Revert the change introduced by 5.0.1-3, since it makes the
autobuilders fail.
2016-10-25 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-3) unstable; urgency=medium
* Added build-dependency "ocamlbuild|ocaml-nox(<<4.03)", in view of the
transition to ocaml 4.03 which does no longer include ocamlbuild.
2016-10-16 - Ralf Treinen <treinen@debian.org>
dose3 (5.0.1-2) unstable; urgency=medium
[ Johannes Schauer ]
* Backport more commits from upstream to fix remaining bugs considering
- the handling of Essential:yes packages:
0003-applications-distcheck.ml-Consider-essential-package.patch
0007-applications-deb-buildcheck.ml-fix-regression-that-l.patch
0008-Catch-expection-in-diagnostic.ml.patch
- library bugs that affect packages using libdose3-dev:
0004-doseparse-stdUtils.ml-It-s-d.byte-and-not-p.byte-for.patch
0005-algo-depsolver.ml-reset-progress-bar-after-univcheck.patch
0006-algo-depsolver.ml-set-correct-value-for-Util.Progres.patch
[ Ralf Treinen ]
* Patch input-xz-files: accept input from xz-compressed files.
Add dependency on xz-utils.

See Also

Package Description
dose-doc_5.0.1-9build3_all.deb Documentation for dose tools and libraries
dose-extra_5.0.1-9build3_amd64.deb Extra QA tools from the Dose3-library
dossizola-data_1.0-9_all.deb Data files for Do'SSi Zo'la game
dossizola_1.0-9_amd64.deb Isola board game with nice graphics
dot-forward_0.71-2.2_amd64.deb reads sendmail's .forward files under qmail
dot2tex_2.9.0-2.1_all.deb Graphviz to LaTeX converter
dotdee_2.0-0ubuntu1_all.deb convert a flat file to a file concatenated from a .d-style directory
dotlrn_2.5.0+dfsg2-1_all.deb e-learning portal system based on OpenACS
dotmcp_0.2.2-14build1_amd64.deb mcp for s3d
dotter_4.44.1+dfsg-2build1_amd64.deb detailed comparison of two genomic sequences
doublecmd-common_0.8.2-1_all.deb twin-panel (commander-style) file manager
doublecmd-gtk_0.8.2-1_amd64.deb twin-panel (commander-style) file manager (GTK2)
doublecmd-help-en_0.8.0-1_all.deb Documentation for Double Commander (English)
doublecmd-help-ru_0.8.0-1_all.deb Documentation for Double Commander (Russian)
doublecmd-help-uk_0.8.0-1_all.deb Documentation for Double Commander (Ukrainian)
Advertisement
Advertisement