docker-compose_1.17.1-2_all.deb


Advertisement

Description

docker-compose - Punctual, lightweight development environments using Docker

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name docker-compose
Package version 1.17.1
Package release 2
Package architecture all
Package type deb
Installed size 505 B
Download size 74.51 KB
Official Mirror archive.ubuntu.com
docker-compose is a service management software built on top of docker. Define
your services and their relationships in a simple YAML file, and let compose
handle the rest.

Alternatives

Package Version Architecture Repository
docker-compose_1.17.1-2_all.deb 1.17.1 all Ubuntu Universe
docker-compose - - -

Requires

Name Value
python-backports.ssl-match-hostname -
python-cached-property >= 1.2.0
python-docker >= 2.4.0
python-dockerpty >= 0.4.1
python-docopt >= 0.6.1
python-enum34 >= 1.0.4
python-enum34 << 2
python-ipaddress -
python-jsonschema >= 2.5.1
python-requests >= 2.6.1
python-six << 2
python-six >= 1.3.0
python-texttable >= 0.9
python-websocket >= 0.32.0
python-yaml >= 3.10
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package docker-compose_1.17.1-2_all.deb
Source Package docker-compose

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install docker-compose deb package:
    # sudo apt-get install docker-compose

Files

Path
/usr/bin/docker-compose
/usr/lib/python2.7/dist-packages/compose/__init__.py
/usr/lib/python2.7/dist-packages/compose/__main__.py
/usr/lib/python2.7/dist-packages/compose/bundle.py
/usr/lib/python2.7/dist-packages/compose/const.py
/usr/lib/python2.7/dist-packages/compose/container.py
/usr/lib/python2.7/dist-packages/compose/errors.py
/usr/lib/python2.7/dist-packages/compose/network.py
/usr/lib/python2.7/dist-packages/compose/parallel.py
/usr/lib/python2.7/dist-packages/compose/progress_stream.py
/usr/lib/python2.7/dist-packages/compose/project.py
/usr/lib/python2.7/dist-packages/compose/service.py
/usr/lib/python2.7/dist-packages/compose/state.py
/usr/lib/python2.7/dist-packages/compose/timeparse.py
/usr/lib/python2.7/dist-packages/compose/utils.py
/usr/lib/python2.7/dist-packages/compose/version.py
/usr/lib/python2.7/dist-packages/compose/volume.py
/usr/lib/python2.7/dist-packages/compose/cli/__init__.py
/usr/lib/python2.7/dist-packages/compose/cli/colors.py
/usr/lib/python2.7/dist-packages/compose/cli/command.py
/usr/lib/python2.7/dist-packages/compose/cli/docker_client.py
/usr/lib/python2.7/dist-packages/compose/cli/docopt_command.py
/usr/lib/python2.7/dist-packages/compose/cli/errors.py
/usr/lib/python2.7/dist-packages/compose/cli/formatter.py
/usr/lib/python2.7/dist-packages/compose/cli/log_printer.py
/usr/lib/python2.7/dist-packages/compose/cli/main.py
/usr/lib/python2.7/dist-packages/compose/cli/signals.py
/usr/lib/python2.7/dist-packages/compose/cli/utils.py
/usr/lib/python2.7/dist-packages/compose/cli/verbose_proxy.py
/usr/lib/python2.7/dist-packages/compose/config/__init__.py
/usr/lib/python2.7/dist-packages/compose/config/config.py
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v1.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v2.0.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v2.1.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v2.2.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v2.3.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.0.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.1.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.2.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.3.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.4.json
/usr/lib/python2.7/dist-packages/compose/config/config_schema_v3.5.json
/usr/lib/python2.7/dist-packages/compose/config/environment.py
/usr/lib/python2.7/dist-packages/compose/config/errors.py
/usr/lib/python2.7/dist-packages/compose/config/interpolation.py
/usr/lib/python2.7/dist-packages/compose/config/serialize.py
/usr/lib/python2.7/dist-packages/compose/config/sort_services.py
/usr/lib/python2.7/dist-packages/compose/config/types.py
/usr/lib/python2.7/dist-packages/compose/config/validation.py
/usr/lib/python2.7/dist-packages/docker_compose-1.17.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/docker_compose-1.17.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/docker_compose-1.17.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/docker_compose-1.17.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/docker_compose-1.17.1.egg-info/top_level.txt
/usr/share/bash-completion/completions/docker-compose
/usr/share/doc/docker-compose/NEWS.Debian.gz
/usr/share/doc/docker-compose/README.md
/usr/share/doc/docker-compose/SWARM.md
/usr/share/doc/docker-compose/changelog.Debian.gz
/usr/share/doc/docker-compose/copyright
/usr/share/man/man1/docker-compose.1.gz
/usr/share/zsh/vendor-completions/_docker-compose

Changelog

2018-02-21 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.17.1-2) unstable; urgency=medium
* Change Vcs-* Urls to salsa
* Tighten dependencies to ensure correct versions. Closes: #891003
2017-11-19 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.17.1-1) unstable; urgency=medium
* New upstream release
* Bump debhelper compat level to 10
2017-11-04 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.17.0-1) unstable; urgency=medium
* New upstream version. (Closes: #860454)
* Bump build-dependencies
* Refresh patches
* Run tests directly through pytest
* Bump standards version
2016-10-19 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.8.0-2) unstable; urgency=medium
* Also Bump runtime dependencies of python-docker and python-dockerpty
Closes: #841307
2016-10-17 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.8.0-1) unstable; urgency=medium
* New upstream release
- Bump python-docker dependency
- Bump docker.io recommends version
- Refresh patches
* Update Vcs urls to https
2015-12-10 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.5.2-1) unstable; urgency=medium
* New upstream version
* Refresh patches
2015-11-14 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.5.1-1) unstable; urgency=medium
* New upstream release
* Refresh patches.
* Add SWARM docs
* Note upstream breaking changes in NEWS.Debian
2015-07-19 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.3.3-1) unstable; urgency=medium
* New upstream release
- Refresh patches
- Bump python-docker dependency
* Add manpage for docker-compose. Thanks Dariusz Dwornikowski.
Closes: #792518
2015-07-04 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.3.1-1) unstable; urgency=medium
* New upstream version
- Add news file documenting breaking changes in 1.3.0
* Backport zsh completion fixes from upstream
* Install bash and zsh completions
* Update dependencies
* Recommend the daemon
* Tighten runtime dependencies on python-requests, dockerpty and docker-py
(Closes: #790734)
2015-05-20 - Felipe Sateler <fsateler@debian.org>
docker-compose (1.2.0-1) unstable; urgency=medium
[ Felipe Sateler ]
* New upstream version
- Refresh patches. Relax python-docker depenency
- Update dependency versions
- Drop bootstrap bundle
* debian/watch: Fix version mangle, allow upstream -rc without -
* Update copyright file

See Also

Package Description
docker-containerd_0.2.3+git+docker1.13.1~ds1-1_amd64.deb daemon to control runC (Docker's version)
docker-doc_17.12.1-0ubuntu1_all.deb Linux container runtime -- documentation
docker-registry_2.6.2~ds1-1_amd64.deb Docker toolset to pack, ship, store, and deliver content
docker-runc_1.0.0~rc2+git+docker1.13.1~ds1-3_amd64.deb Open Container Project - runtime (Docker's version)
docker.io_17.12.1-0ubuntu1_amd64.deb Linux container runtime
docker2aci_0.14.0+dfsg-2_amd64.deb CLI tool to convert Docker images to ACIs
docker_1.5-1build1_amd64.deb System tray for KDE3/GNOME2 docklet applications
docky_2.2.1.1-1_all.deb Elegant, powerful, clean dock
doclava-aosp_6.0.1+r55-1_all.deb Custom Javadoc doclet by Google
doclifter_2.11-1_all.deb Convert troff to DocBook
doconce_0.7.3-1_all.deb document once, include anywhere
doctest-dev_1.2.7+repack0-2_all.deb Light and feature-rich C++ testing framework
doctest_0.11.4-1build1_amd64.deb test interactive Haskell examples; executable
doctorj_5.0.0-5_all.deb A tool to analyze Java code
doctrine-sphinx-theme_0~20130227-1_all.deb Sphinx theme used by Doctrine
Advertisement
Advertisement