dictionary-el_1.10-3_all.deb


Advertisement

Description

dictionary-el - dictionary client for Emacs

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe amd64
Package name dictionary-el
Package version 1.10
Package release 3
Package architecture all
Package type deb
Installed size 101 B
Download size 26.54 KB
Official Mirror archive.ubuntu.com
dictionary-el is a DICT (RFC 2229) client for (X)Emacs, with support
for brace-delimited cross references and UTF-8-encoded entries.
Note that XEmacs bundles a slightly older version of this package.

Alternatives

Package Version Architecture Repository
dictionary-el_1.10-3_all.deb 1.10 all Ubuntu Universe
dictionary-el - - -

Requires

Name Value
emacs -
emacsen -
emacsen-common >= 2.0.8

Provides

Name Value
dict-client -

Download

Type URL
Binary Package dictionary-el_1.10-3_all.deb
Source Package dictionary-el

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install dictionary-el deb package:
    # sudo apt-get install dictionary-el

Files

Path
/etc/emacs/site-start.d/50dictionary-el.el
/usr/lib/emacsen-common/packages/compat/dictionary-el
/usr/lib/emacsen-common/packages/install/dictionary-el
/usr/lib/emacsen-common/packages/remove/dictionary-el
/usr/share/doc/dictionary-el/README.gz
/usr/share/doc/dictionary-el/changelog.Debian.gz
/usr/share/doc/dictionary-el/copyright
/usr/share/emacs/site-lisp/dictionary-el/connection.el
/usr/share/emacs/site-lisp/dictionary-el/dictionary-init.el
/usr/share/emacs/site-lisp/dictionary-el/dictionary.el
/usr/share/emacs/site-lisp/dictionary-el/install-package.el
/usr/share/emacs/site-lisp/dictionary-el/link.el

Changelog

2017-01-05 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.10-3) unstable; urgency=medium
* debian/control: Canonicalize per cme.  In particular, declare
Standards-Version: 3.9.8 (already compliant, in fact).
* dictionary.el:
- Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>,
adjust buffer-read-only rather than calling toggle-read-only, which
is deprecated and can have unwanted side effects.  (Closes: #850279.)
- Per the ever-patient Kevin Ryde <user42@zip.com.au>, adjust
dictionary-tooltip-dictionary's defcustom type to acknowledge that nil
(the default value) is in fact valid.  (Closes: #719041.)  Also, tweak
dictionary-display-tooltip (used by GNU Emacs) to proceed even if
dictionary-tooltip-dictionary is nil, as already done for XEmacs.
2014-06-17 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.10-2) unstable; urgency=medium
* debian/control:
- Depend on emacsen-common (>= 2.0.8), per the new emacsen policy.
- Standards-Version: 3.9.5 (already compliant).
* debian/copyright: Belatedly update years (accidentally missed earlier).
* debian/emacsen-compat: Declare compliance with modern policy.
2013-05-21 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.10-1) unstable; urgency=low
* New upstream release, incorporating among other things all outstanding
Debian changes.  (Closes: #709093.)
* Standards-Version: 3.9.4 (already compliant).
2012-06-19 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.8.7-15) unstable; urgency=low
* dictionary.el:
- (dictionary-display-dictionary-line) Special-case "--exit--", which
doesn't name a dictionary but rather marks the end of the server's
default search list.  (Closes: #611941.)
- When customizing dictionary-server or other connection-related
variables with a connection already open, offer to close it so
that the change can take immediate effect.  (Closes: #611943.)
* dictionary-init.el: Register dictionary and dictionary-proxy as
customization groups associated with dictionary.el.  (Closes: #611942.)
* debian/compat: formally advance to Debhelper 9.
* debian/control:
- Advance debhelper build dependency accordingly.
- Drop Recommends; mule-ucs is long gone, and trying to recommend it
only in the absence of a modern emacs flavor failed to account for
the (unofficial) emacs-snapshot package.  (Closes: #660901.)
- Repoint Vcs-* fields at anonscm.debian.org (vs. git.debian.org).
- Standards-Version: 3.9.3 (already compliant).
2010-10-23 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.8.7-14) unstable; urgency=low
* dictionary.el (dictionary-mode): call make-local-hook only under XEmacs;
GNU Emacs deprecated it back in version 21, and will retire it altogether
in the upcoming version 24.  (Closes: #600800.)
* debian/compat: formally advance to Debhelper 8, as it is safe to do so.
* debian/control:
- Advance debhelper build-dependency accordingly.
- Update Recommends: again, as emacs22 and emacs-snapshot are no more.
- Standards-Version: 3.9.1.  (No further changes needed.)
- Set Vcs-* fields to point to (new) personal git.d.o repository.
* debian/.gitignore: Direct git to ignore content generated during build.
2010-07-18 - Aaron M. Ucko <ucko@debian.org>
dictionary-el (1.8.7-13) unstable; urgency=low
* debian/rules: don't ship lpath.el, not needed in Debian.  (Closes: #582579)
* debian/control:
- retire Conflicts: declaration on ancient unofficial "dictionary" package.
- Standards-Version: 3.9.0.  (No further changes needed.)

See Also

Package Description
dictionaryreader.app_0+20080616+dfsg-2build7_amd64.deb Dict client for GNUstep
didiwiki_0.5-13_amd64.deb simple wiki implementation with built-in webserver
dieharder_3.31.1-7build1_amd64.deb Random-number generator test front-end
dietlibc-dev_0.34~cvs20160606-7_amd64.deb diet libc - a libc optimized for small size
dietlibc-doc_0.34~cvs20160606-7_all.deb diet libc documentation - a libc optimized for small size
diffmon_20020222-2.6_all.deb Tool for reporting changes in system configuration
diffoscope_93ubuntu1_all.deb in-depth comparison of files, archives, and directories
diffpdf_2.1.3-1.2_amd64.deb compare two PDF files textually or visually
diffuse_0.4.8-3_all.deb graphical tool for merging and comparing text files
digikam-data_5.6.0-0ubuntu10_all.deb digiKam architecture-independant data
digikam-doc_5.6.0-0ubuntu10_all.deb handbook for digiKam
digikam-private-libs_5.6.0-0ubuntu10_amd64.deb private libraries for digiKam and kipi plugins
digikam_5.6.0-0ubuntu10_amd64.deb digital photo management application for KDE
digitemp_3.7.1-2build1_amd64.deb read temperature sensors in a 1-Wire net
dillo_3.0.5-4build1_amd64.deb Small and fast web browser
Advertisement
Advertisement