libgpgmepp6_1.10.0-1ubuntu2.1_amd64.deb


Advertisement

Description

libgpgmepp6 - C++ wrapper library for GPGME

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Proposed Main amd64
Package filename libgpgmepp6_1.10.0-1ubuntu2.1_amd64.deb
Package name libgpgmepp6
Package version 1.10.0
Package release 1ubuntu2.1
Package architecture amd64
Package type deb
Category libs
Homepage https://www.gnupg.org/related_software/gpgme/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 92.77 KB
Installed size 386.00 KB
GpgME++ (aka GpgMEpp) is a C++ wrapper (or C++ bindings) for the
GnuPG project's GPGME (GnuPG Made Easy) library.
This is the official upstream C++ binding for GPGME.

Alternatives

Package Version Architecture Repository
libgpgmepp6_1.10.0-1ubuntu2.1_i386.deb 1.10.0 i386 Ubuntu Proposed Main
libgpgmepp6_1.10.0-1ubuntu2_i386.deb 1.10.0 i386 Ubuntu Updates Main
libgpgmepp6_1.10.0-1ubuntu2_amd64.deb 1.10.0 amd64 Ubuntu Updates Main
libgpgmepp6_1.10.0-1ubuntu1_i386.deb 1.10.0 i386 Ubuntu Main
libgpgmepp6_1.10.0-1ubuntu1_amd64.deb 1.10.0 amd64 Ubuntu Main
libgpgmepp6 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libgpgme11 >= 1.9.0
libstdc++6 >= 5.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgpgmepp6_1.10.0-1ubuntu2.1_amd64.deb
Source Package gpgme1.0

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://archive.ubuntu.com/ubuntu/ bionic-proposed main
  2. Update the package index:
    # sudo apt-get update
  3. Install libgpgmepp6 deb package:
    # sudo apt-get install libgpgmepp6

Changelog

2019-08-12 - Julian Andres Klode <juliank@ubuntu.com>
gpgme1.0 (1.10.0-1ubuntu2.1) bionic; urgency=medium
* qt-Use-tofu-conflict-test-keys-without-expiry.patch: Cherry pick
upstream fix for expiry dates in test suite (LP: #1813581)
2018-08-14 - Julian Andres Klode <juliank@ubuntu.com>
gpgme1.0 (1.10.0-1ubuntu2) bionic; urgency=medium
* Make debian/libgpgme-dev.links executable, it uses dh-exec (LP: #1762384)
* Drop python3.5 test since python3.5 is not supported (fixes autopkgtest)
2018-01-15 - Julian Andres Klode <juliank@ubuntu.com>
gpgme1.0 (1.10.0-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patch/0007-Python-Versions.patch: Use py{,3}versions detection.
- debian/patches/0006-PIC-and-shared.patch: Libs are -fPIC and -shared.
- Add in libgpgme-dev a libgpgme-pthread.so pointing to libgpgme.so, this                       
will fix the build failures of kf5-kdepim-apps-libs when built against this                   
gpgme package.
2017-12-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.10.0-1) unstable; urgency=medium
* new upstream release
* update build-dependencies
* drop patches already upstream
* add new symbols
* update debian/copyright
* add explicit lintian overrides for things i have no plans to fix
2017-12-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-8) unstable; urgency=medium
* clean up wrap-and-sort
* loosen dependencies (Closes: #872368)
* only build against latest python3 (Closes: #866555)
* Standards-Version: bump to 4.1.2 (no changes needed)
* refresh patches
* cherry-pick bugfixes from upstream
2017-10-25 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-7) unstable; urgency=medium
* force-build python 3.5 now that python3 is 3.6 in unstable
2017-10-10 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-6) unstable; urgency=medium
* point to correct qgpgme README (Closes: #857529)
* use getdents64 instead of getdents (Closes: #876538)
* Standards-Version: bump to 4.1.1 (no changes needed)
2017-09-19 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-5) unstable; urgency=medium
* Import more bugfixes from upstream.
* Adopt Colin Watson's optimization for reducing the number of spurious
close() calls on Linux platforms.
2017-08-18 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-4) unstable; urgency=medium
* complete upstream python file reorg (Closes: #872519)
2017-08-17 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
gpgme1.0 (1.9.0-3) unstable; urgency=medium
* imported cleanup+bugfixes from upstream
* removed unnecessary b-d on autoreconf
* drop unneeded DEBIAN_VERSION from debian/rules
* ship constants.tofu (Closes: #871465)
* Standards-Version: bump to 4.0.1 (extra -> optional)
* try to force python 3.6
* strip debian revision from new 1.9.0 symbols
* add the simplest possible python burn-in autopkgtest
* release to unstable

See Also

Package Description
libibumad-dev_17.1-1ubuntu0.2_amd64.deb Development files for libibumad
libibumad3_17.1-1ubuntu0.2_amd64.deb InfiniBand Userspace Management Datagram (uMAD) library
libibverbs-dev_17.1-1ubuntu0.2_amd64.deb Development files for the libibverbs library
libibverbs1_17.1-1ubuntu0.2_amd64.deb Library for direct userspace use of RDMA (InfiniBand/iWARP)
libnm-dev_1.10.14-0ubuntu2_amd64.deb GObject-based client library for NetworkManager (development files)
libnm-glib-dev_1.10.14-0ubuntu2_amd64.deb network management framework (GLib interface)
libnm-glib-vpn-dev_1.10.14-0ubuntu2_amd64.deb network management framework (GLib interface)
libnm-glib-vpn1_1.10.14-0ubuntu2_amd64.deb network management framework (GLib VPN shared library)
libnm-glib4_1.10.14-0ubuntu2_amd64.deb network management framework (GLib shared library)
libnm-util-dev_1.10.14-0ubuntu2_amd64.deb network management framework (development files)
libnm-util2_1.10.14-0ubuntu2_amd64.deb network management framework (shared library)
libnm0_1.10.14-0ubuntu2_amd64.deb GObject-based client library for NetworkManager
libnss3-dev_3.35-2ubuntu2.4_amd64.deb Development files for the Network Security Service libraries
libnss3_3.35-2ubuntu2.4_amd64.deb Network Security Service libraries
libpulse-dev_11.1-1ubuntu7.4_amd64.deb PulseAudio client development headers and libraries
Advertisement
Advertisement