udisks2_2.7.6-3_amd64.deb


Advertisement

Description

udisks2 - D-Bus service to access and manipulate storage devices

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name udisks2
Package version 2.7.6
Package release 3
Package architecture amd64
Package type deb
Installed size 1.04 KB
Download size 225.89 KB
Official Mirror archive.ubuntu.com
The udisks daemon serves as an interface to system block devices,
implemented via D-Bus. It handles operations such as querying, mounting,
unmounting, formatting, or detaching storage devices such as hard disks
or USB thumb drives.
This package also provides the udisksctl utility, which can be used to
trigger these operations from the command line (if permitted by
PolicyKit).
Creating or modifying file systems such as XFS, RAID, or LUKS encryption
requires that the corresponding mkfs.* and admin tools are installed, such as
dosfstools for VFAT, xfsprogs for XFS, or cryptsetup for LUKS.

Alternatives

Package Version Architecture Repository
udisks2_2.7.6-3ubuntu0.2_i386.deb 2.7.6 i386 Ubuntu Updates Main
udisks2_2.7.6-3ubuntu0.2_amd64.deb 2.7.6 amd64 Ubuntu Updates Main
udisks2_2.7.6-3_i386.deb 2.7.6 i386 Ubuntu Main
udisks2 - - -

Requires

Name Value
dbus -
libacl1 >= 2.2.51-8
libatasmart4 >= 0.13
libblockdev-fs2 -
libblockdev-loop2 -
libblockdev-part2 -
libblockdev-swap2 -
libblockdev-utils2 >= 2.14
libblockdev2 >= 2.14
libc6 >= 2.7
libglib2.0-0 >= 2.50
libgudev-1.0-0 >= 165
libmount1 >= 2.26.2
libpam-systemd -
libpolkit-agent-1-0 >= 0.99
libpolkit-gobject-1-0 >= 0.101
libsystemd0 >= 209
libudisks2-0 >= 2.7.6
parted -
udev -

Download

Type URL
Binary Package udisks2_2.7.6-3_amd64.deb
Source Package udisks2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install udisks2 deb package:
    # sudo apt-get install udisks2

Files

Path
/etc/dbus-1/system.d/org.freedesktop.UDisks2.conf
/etc/udisks2/udisks2.conf
/lib/systemd/system/clean-mount-point@.service
/lib/systemd/system/udisks2.service
/lib/udev/rules.d/80-udisks2.rules
/sbin/umount.udisks2
/usr/bin/udisksctl
/usr/lib/udisks2/udisks2-inhibit
/usr/lib/udisks2/udisksd
/usr/share/apport/package-hooks/udisks2.py
/usr/share/bash-completion/completions/udisksctl
/usr/share/dbus-1/system-services/org.freedesktop.UDisks2.service
/usr/share/doc/udisks2/AUTHORS
/usr/share/doc/udisks2/NEWS.gz
/usr/share/doc/udisks2/README.md
/usr/share/doc/udisks2/changelog.Debian.gz
/usr/share/doc/udisks2/copyright
/usr/share/lintian/overrides/udisks2
/usr/share/man/man1/udisksctl.1.gz
/usr/share/man/man5/udisks2.conf.5.gz
/usr/share/man/man8/udisks.8.gz
/usr/share/man/man8/udisksd.8.gz
/usr/share/man/man8/umount.udisks2.8.gz
/usr/share/polkit-1/actions/org.freedesktop.UDisks2.policy

Changelog

2018-04-19 - Iain Lane <laney@debian.org>
udisks2 (2.7.6-3) unstable; urgency=medium
[ Jeremy Bicha ]
* Update Vcs fields for migration to https://salsa.debian.org/
[ Iain Lane ]
* debian/rules, debian/substvars: Recommend libblockdev-crypto2 in Ubuntu
too - the package is going to main now. (LP: #1757321)
* d/p/0001-integration-test-Wait-longer-after-the-scsi-debug-CD.patch,
d/p/0002-integration-test-don-t-error-out-on-an-unknown-distr.patch,
d/p/0004-tests-Pass-absolute-path-to-targetcli_config.json.patch:
Cherry-pick patches from upstream or in one case an upstream PR to fix
testsuite failures. All via Ubuntu.
* d/p/0003-main.c-Properly-remove-sigint-source.patch: Remove GSource
properly - the old way was causing crashes.
* debian/tests/control: Add test-deps on libblockdev-crypto2 and
targetcli-fb, both of which are required by the testsuite.
2018-03-08 - Jeremy Bicha <jbicha@debian.org>
udisks2 (2.7.6-2) unstable; urgency=medium
* Team upload
* Don't recommend exfat-utils on Ubuntu since it's in universe.
See bug 1649537.
* Don't recommend libblockdev-crypto2 on Ubuntu since volume-key
is in universe. See bug 1754422.
2018-02-09 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.6-1) unstable; urgency=medium
* New upstream version 2.7.6
* Bump Build-Depends on libglib2.0-dev to (>= 2.50)
* Add Build-Depends on libmount-dev (>= 2.30)
* Set Rules-Requires-Root to no
* Update symbols file for libudisks2-0
2017-12-14 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.5-1) unstable; urgency=medium
* New upstream version 2.7.5
* Bump Standards-Version to 4.1.2
2017-11-01 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.4-1) unstable; urgency=medium
* New upstream version 2.7.4
* Bump Build-Depends on libblockdev-dev to (>= 2.14)
* Bump Standards-Version to 4.1.1
* Update symbols file for libudisks2-0
2017-09-19 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.3-4) unstable; urgency=medium
* Fix dependency of udisks2-btrfs on libblockdev-btrfs2 (Closes: #876143)
2017-09-12 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.3-3) unstable; urgency=medium
* Enable support for LVM2.
Split the lvm2 module into a separate package named udisks2-lvm2.
* Enable support for BTRFS.
Split the btrfs module into a separate package named udisks2-btrfs.
2017-09-12 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.3-2) unstable; urgency=medium
* Revert accidental deletion of libudisks2.a
2017-09-12 - Michael Biebl <biebl@debian.org>
udisks2 (2.7.3-1) unstable; urgency=medium
* New upstream version 2.7.3
* Update symbols file for libudisks2-0
* Demote udftools to Suggests
* Drop obsolete alternative Suggests btrfs-tools
btrfs-progs is available since stretch.
* Drop obsolete cryptsetup-bin Suggests.
This is now handled by libblockdev-crypto2.
* Drop unnecessary libblockdev-lvm2 Suggests.
We don't enable lvm2 support (yet) so there is no reason to have
libblockdev-lvm2 installed.
* Demote libblockdev-mdraid2 to Suggests
libblockdev-mdraid2 will pull in mdadm which is a rather heavy dependency
so we don't want install this dependency by default. If you need RAID
support in udisks make sure to install this libblockdev plugin manually.
(Closes: #873706)
* Demote libblockdev-crypto2 to Recommends.
We want to have working LUKS/cryptsetup support by default but provide
the option for users to not install this dependency if they don't need
this functionality.
* Use new dh_missing helper instead of dh_install --fail-missing
2017-08-30 - Andreas Henriksson <andreas@fatal.se>
udisks2 (2.7.2-2) unstable; urgency=medium
* Depend on blockdev plugins required by udisks2 core (Closes: #873627)
* Add libblockdev plugins used by udisks modules to suggests

See Also

Package Description
ufw_0.35-5_all.deb program for managing a Netfilter firewall
uidmap_4.5-1ubuntu1_amd64.deb programs to help use subuids
unattended-upgrades_1.1ubuntu1_all.deb automatic installation of security upgrades
unifont_10.0.07-1_all.deb font with a glyph for each visible Unicode Plane 0 character
unixodbc-dev_2.3.4-1.1ubuntu3_amd64.deb ODBC libraries for UNIX (development files)
uno-libs3_6.0.3-0ubuntu1_amd64.deb LibreOffice UNO runtime environment -- public shared libraries
unzip_6.0-21ubuntu1_amd64.deb De-archiver for .zip files
update-inetd_4.44_all.deb inetd configuration file updater
update-manager-core_18.04.11_all.deb manage release upgrades
update-manager_18.04.11_all.deb GNOME application that manages apt updates
update-motd_3.6-0ubuntu1_all.deb compliments pam_motd in libpam-modules
update-notifier-common_3.192_all.deb Files shared between update-notifier and other packages
update-notifier_3.192_amd64.deb Daemon which notifies about package updates
upower-doc_0.99.7-2_all.deb abstraction for power management - documentation
upower_0.99.7-2_amd64.deb abstraction for power management
Advertisement
Advertisement