speech-dispatcher_0.8.8-1ubuntu1_amd64.deb


Advertisement

Description

speech-dispatcher - Common interface to speech synthesizers

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name speech-dispatcher
Package version 0.8.8
Package release 1ubuntu1
Package architecture amd64
Package type deb
Installed size 1020 B
Download size 312.28 KB
Official Mirror archive.ubuntu.com
Speech Dispatcher provides a device independent layer for speech synthesis.
It supports various software and hardware speech synthesizers as
backends and provides a generic layer for synthesizing speech and
playing back PCM data via those different backends to applications.
Various high level concepts like enqueueing vs. interrupting speech and
application specific user configurations are implemented in a device
independent way, therefore freeing the application programmer from
having to yet again reinvent the wheel.
This package contains Speech Dispatcher itself.

Alternatives

Package Version Architecture Repository
speech-dispatcher_0.8.8-1ubuntu1_i386.deb 0.8.8 i386 Ubuntu Main
speech-dispatcher - - -

Requires

Name Value
adduser -
libc6 >= 2.16
libdotconf0 >= 1.0.13
libglib2.0-0 >= 2.35.9
libltdl7 >= 2.4.6
libsndfile1 >= 1.0.20
libspeechd2 >= 0.7.1
lsb-base >= 3.0-10
speech-dispatcher-audio-plugins = 0.8.8-1ubuntu1

Download

Type URL
Binary Package speech-dispatcher_0.8.8-1ubuntu1_amd64.deb
Source Package speech-dispatcher

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install speech-dispatcher deb package:
    # sudo apt-get install speech-dispatcher

Files

Path
/etc/default/speech-dispatcher
/etc/init.d/speech-dispatcher
/etc/logrotate.d/speech-dispatcher
/etc/speech-dispatcher/speechd.conf
/etc/speech-dispatcher/clients/emacs.conf
/etc/speech-dispatcher/modules/cicero.conf
/etc/speech-dispatcher/modules/dtk-generic.conf
/etc/speech-dispatcher/modules/epos-generic.conf
/etc/speech-dispatcher/modules/espeak-generic.conf
/etc/speech-dispatcher/modules/espeak-mbrola-generic.conf
/etc/speech-dispatcher/modules/espeak-ng.conf
/etc/speech-dispatcher/modules/espeak.conf
/etc/speech-dispatcher/modules/festival.conf
/etc/speech-dispatcher/modules/flite.conf
/etc/speech-dispatcher/modules/ibmtts.conf
/etc/speech-dispatcher/modules/ivona.conf
/etc/speech-dispatcher/modules/llia_phon-generic.conf
/etc/speech-dispatcher/modules/pico-generic.conf
/etc/speech-dispatcher/modules/swift-generic.conf
/usr/bin/spd-say
/usr/bin/speech-dispatcher
/usr/lib/speech-dispatcher-modules/sd_dummy
/usr/lib/speech-dispatcher-modules/sd_generic
/usr/share/doc/speech-dispatcher/AUTHORS
/usr/share/doc/speech-dispatcher/NEWS.gz
/usr/share/doc/speech-dispatcher/README
/usr/share/doc/speech-dispatcher/README.Debian
/usr/share/doc/speech-dispatcher/architecture-future.png
/usr/share/doc/speech-dispatcher/architecture.png
/usr/share/doc/speech-dispatcher/changelog.Debian.gz
/usr/share/doc/speech-dispatcher/copyright
/usr/share/doc/speech-dispatcher/priorities.png
/usr/share/info/spd-say.info.gz
/usr/share/info/speech-dispatcher.info.gz
/usr/share/info/ssip.info.gz
/usr/share/lintian/overrides/speech-dispatcher
/usr/share/man/man1/spd-say.1.gz
/usr/share/man/man1/speech-dispatcher.1.gz
/usr/share/sounds/speech-dispatcher/dummy-message.wav
/usr/share/speech-dispatcher/conf/speechd.conf
/usr/share/speech-dispatcher/conf/clients/emacs.conf
/usr/share/speech-dispatcher/conf/desktop/speechd.desktop
/usr/share/speech-dispatcher/conf/modules/cicero.conf
/usr/share/speech-dispatcher/conf/modules/espeak-ng.conf
/usr/share/speech-dispatcher/conf/modules/espeak.conf
/usr/share/speech-dispatcher/conf/modules/festival.conf

Changelog

2018-04-23 - Matthias Klose <doko@ubuntu.com>
speech-dispatcher (0.8.8-1ubuntu1) bionic; urgency=medium
* Build-depend on dh-python.
2017-12-15 - Paul Gevers <elbrus@debian.org>
speech-dispatcher (0.8.8-1) unstable; urgency=medium
[ Samuel Thibault ]
* speech-dispatcher.logrotate: Use invoke-rc.d instead of /etc/init.d path.
* control: Migrate priority to optional.
* control: Make speech-dispatcher recommend sound-icons.
[ Paul Gevers ]
* New upstream release
* control: Bump Standards-Version to 4.1.2
* Bump debhelper compat level to 10
2017-07-14 - Paul Gevers <elbrus@debian.org>
speech-dispatcher (0.8.7-1) unstable; urgency=medium
[ Samuel Thibault ]
* Make sure to drop obsolete /etc/speech-dispatcher/clients/gnome-speech.conf
conffile. (Closes: Bug#803536)
* patches/spd-conf: Fix spd-conf (Closes: Bug#860898)
* Use canonical anonscm vcs URL.
* debian/speech-dispatcher.1: fix debugging output path (Closes: Bug#860889)
[ Helmut Grohne ]
* Demote python3 from Build-Depends to Build-Depends-Indep (Closes: #842674)
[ Luke Yelavich ]
* debian/speech-dispatcher-pico.install: Ship the configuration files
* New upstream release
patches/spd-conf: Dropped, applied upstream
[ Paul Gevers ]
* Team upload
* patches/flite-strip-silence: Dropped, applied upstream
* Build with dh_python3 to fix paths
* Enable hardening
* Fix syntax errors in d/copyright
* Add fix-spelling-mistakes.patch
* Add add-german-translation.patch (Closes: #863306) Thanks to Chris Leick
2017-03-05 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.6-4) unstable; urgency=medium
* Fix stripped audio output of flite module (Closes: #856895).
2017-02-04 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.6-3) unstable; urgency=medium
[ Samuel Thibault ]
* Relax dependency between speech-dispatcher and speech-dispatcher-contrib a
bit: Require only same upstream version.  Avoids installability issues
with binNMU (Closes: #854091).
[ Luke Yelavich ]
* Set the default output module to espeak-ng (Closes: #854106).
2017-01-10 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.6-1) unstable; urgency=medium
[ Luke Yelavich ]
* New upstream release
2016-12-05 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.5-6) unstable; urgency=medium
* contrib: Make speech-dispatcher module packages depend on same version of
speech-dispatcher, and replace old speech-dispatcher package. Fix
speech-dispatcher-pico content.
2016-12-04 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.5-5) unstable; urgency=medium
[ Luke Yelavich ]
* Split out cicero, espeak, espeak-ng, and flite modules into separate
packages
* Add speech-dispatcher-espeak-ng to the speech-dispatcher package
recommends, and add all other synth module packages to suggests
[ Samuel Thibault ]
* Rename speech-dispatcher-contrib package into speech-dispatcher-pico.
2016-11-17 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.5-4) unstable; urgency=medium
* Fix installing the espeak-ng module.
2016-11-10 - Samuel Thibault <sthibault@debian.org>
speech-dispatcher (0.8.5-3) unstable; urgency=medium
* Add espeak-ng support.

See Also

Package Description
speex-doc_1.2~rc1.2-1ubuntu2_all.deb Documentation for speex
sphinx-common_1.6.7-1ubuntu1_all.deb documentation generator for Python projects - common data
sphinx-doc_1.6.7-1ubuntu1_all.deb documentation generator for Python projects - documentation
sphinx-rtd-theme-common_0.2.4-1_all.deb sphinx theme from readthedocs.org (common files)
spice-vdagent_0.17.0-1ubuntu2_amd64.deb Spice agent for Linux
sqlite3-doc_3.22.0-1_all.deb SQLite 3 documentation
sqlite3_3.22.0-1_amd64.deb Command line interface for SQLite 3
squashfs-tools_4.3-6_amd64.deb Tool to create and append to squashfs filesystems
squid-common_3.5.27-1ubuntu1_all.deb Full featured Web Proxy cache (HTTP proxy) - common files
squid-langpack_20170901-1_all.deb Localized error pages for Squid
squid3_3.5.27-1ubuntu1_all.deb Transitional package
squid_3.5.27-1ubuntu1_amd64.deb Full featured Web Proxy cache (HTTP proxy)
ss-dev_2.0-1.44.1-1_amd64.deb command-line interface parsing library - headers and static libraries
ssh-import-id_5.7-0ubuntu1_all.deb securely retrieve an SSH public key and install it locally
ssh_7.6p1-4_all.deb secure shell client and server (metapackage)
Advertisement
Advertisement