snmpd_5.7.3+dfsg-1.8ubuntu3_amd64.deb


Advertisement

Description

snmpd - SNMP (Simple Network Management Protocol) agents

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name snmpd
Package version 5.7.3+dfsg
Package release 1.8ubuntu3
Package architecture amd64
Package type deb
Installed size 141 B
Download size 55.64 KB
Official Mirror archive.ubuntu.com
The Simple Network Management Protocol (SNMP) provides a framework
for the exchange of management information between agents (servers)
and clients.
The Net-SNMP agent is a daemon which listens for incoming SNMP
requests from clients and provides responses.

Alternatives

Package Version Architecture Repository
snmpd_5.7.3+dfsg-1.8ubuntu3.1_i386.deb 5.7.3+dfsg i386 Ubuntu Updates Main
snmpd_5.7.3+dfsg-1.8ubuntu3.1_amd64.deb 5.7.3+dfsg amd64 Ubuntu Updates Main
snmpd_5.7.3+dfsg-1.8ubuntu3_i386.deb 5.7.3+dfsg i386 Ubuntu Main
snmpd - - -

Requires

Name Value
adduser -
debconf -
debconf >= 0.5
debconf-2.0 -
libc6 >= 2.4
libsnmp-base -
libsnmp30 = 5.7.3+dfsg-1.8ubuntu3
lsb-base >= 3.2-13

Download

Type URL
Binary Package snmpd_5.7.3+dfsg-1.8ubuntu3_amd64.deb
Source Package net-snmp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install snmpd deb package:
    # sudo apt-get install snmpd

Files

Path
/etc/default/snmpd
/etc/init.d/snmpd
/etc/snmp/snmpd.conf
/lib/systemd/system/snmpd.service
/usr/sbin/snmpd
/usr/share/apport/package-hooks/source_net-snmp.py
/usr/share/doc/snmpd
/usr/share/lintian/overrides/snmpd
/usr/share/man/man5/snmpd.conf.5.gz
/usr/share/man/man8/snmpd.8.gz
/usr/share/snmp/snmp_perl.pl
/usr/share/snmp/snmpconf-data/snmpd-data/acl
/usr/share/snmp/snmpconf-data/snmpd-data/basic_setup
/usr/share/snmp/snmpconf-data/snmpd-data/extending
/usr/share/snmp/snmpconf-data/snmpd-data/monitor
/usr/share/snmp/snmpconf-data/snmpd-data/operation
/usr/share/snmp/snmpconf-data/snmpd-data/snmpconf-config
/usr/share/snmp/snmpconf-data/snmpd-data/system
/usr/share/snmp/snmpconf-data/snmpd-data/trapsinks

Changelog

2018-02-20 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
net-snmp (5.7.3+dfsg-1.8ubuntu3) bionic; urgency=medium
* d/p/0001-swinst_apt.c-Fix-indexing-of-hrSWInstalledTable-to-s.patch:
set first hrSWInstalledIndex to 1 to follow RFC 2790 (LP: #1314760)
2018-02-06 - Dimitri John Ledkov <xnox@ubuntu.com>
net-snmp (5.7.3+dfsg-1.8ubuntu2) bionic; urgency=high
* No change rebuild against openssl1.1.
2018-01-11 - Andreas Hasenack <andreas@canonical.com>
net-snmp (5.7.3+dfsg-1.8ubuntu1) bionic; urgency=medium
* Merge with Debian unstable (LP: #1742518). Remaining changes:
- Add apport hook.
+ d/control: add dh-apport to Build-Depends
+ d/rules: install the apport hook via debhelper
+ d/source.apport: apport hook
- d/p/my_load_defaults: use my_load_defaults instead of the
libmysqlclient-internal load_defaults (LP #1565003). Thanks to Lars
Tangvald.
* Dropped:
- Avoid installing links in rc[06].d.
[It's not clear what it was trying to solve (no details or bug
number), but update-rc.d no longer takes start/stop arguments and
this delta was actually resulting in warnings during the installation.
Also, Ubuntu is using systemd now and this package has systemd service
files.]
2017-12-23 - Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
net-snmp (5.7.3+dfsg-1.8) unstable; urgency=medium
* Non-maintainer upload.
* Add support for OpenSSL 1.1.0 and revert that were added
(Closes: #828449):
- add libssl-dev back as dependency of libsnmp-dev
- drop the guard which enforced libssl 1.0.2
- add -lcrypto back to pkg-config
2017-08-23 - Andreas Hasenack <andreas@canonical.com>
net-snmp (5.7.3+dfsg-1.7ubuntu1) artful; urgency=medium
* Merge with Debian unstable (LP: #1712569). Remaining changes:
- Add apport hook.
+ d/control: add dh-apport to Build-Depends
+ d/rules: install the apport hook via debhelper
+ d/source.apport: apport hook
- Avoid installing links in rc[06].d.
- d/p/my_load_defaults: use my_load_defaults instead of the
libmysqlclient-internal load_defaults (LP #1565003). Thanks to Lars
Tangvald.
* Drop:
- SECURITY UPDATE: denial of service and possible code execution via
incompletely parsed varBind variables
+ debian/patches/CVE-2015-5621.patch: don't return incorrectly parsed
varbinds in snmplib/snmp_api.c.
+ CVE-2015-5621
[Added by Debian as 0025-Bug-788964-net-snmp-snmp_pdu_parse-DoS.patch
in 5.7.3+dfsg-1.1]
- debian/snmp.preinst:
It turns out that the original motivation why killall was added is gone.
So we can just remove the killall introduced by Ubuntu LP #573391
(Closes: #781257, LP #1245604)
[Fixed in Debian 5.7.3+dfsg-1.1]
- Fix "FTBFS with Perl 5.24: error: conflicting types for 'U64'":
add patch from upstream git which removes the U64 typedef from the
Net-SNMP header files.
Thanks to Niky Tyni for extracting the patch.
(Closes: #825014)
[Fixed in Debian 5.7.3+dfsg-1.5]
- Additionally add another patch from upstream git which fixes
perl/*/Makefile.PL to fix build failures with Perl 5.24.
Cf. https://sourceforge.net/p/net-snmp/bugs/2712/
[Fixed in Debian 5.7.3+dfsg-1.5]
2017-01-24 - Niels Thykier <niels@thykier.net>
net-snmp (5.7.3+dfsg-1.7) unstable; urgency=medium
[ Niels Thykier ]
* Non-maintainer upload with the following changes from
other people.
[ Sebastian Andrzej Siewior ]
* drop dep on libssl1.0-dev in the dev package.  (Closes: #851946)
* add a guard to catch users of the wrong library
* remove "-lcrypto" from the pkg-config when linking statically.
This is technical suboptimal and should ideally be reverted
for buster (when all packages migrate to the same ssl version).
[ Adrian Bunk ]
* Re-able "pie" hardening as its absence is causing issues for
reverse dependencies.  (Closes: #852023)

See Also

Package Description
socat_1.7.3.2-2ubuntu2_amd64.deb multipurpose relay for bidirectional data transfer
software-properties-common_0.96.24.32.1_all.deb manage the repositories that you install software from (common)
software-properties-gtk_0.96.24.32.1_all.deb manage the repositories that you install software from (gtk)
sosreport_3.5-1ubuntu3_amd64.deb Set of tools to gather troubleshooting data from a system
sound-icons_0.1-6_all.deb Sounds for speech enabled applications
sound-theme-freedesktop_0.8-2ubuntu1_all.deb freedesktop.org sound theme
spamassassin_3.4.1-8build1_all.deb Perl-based spam filter using text analysis
spamc_3.4.1-8build1_amd64.deb Client for SpamAssassin spam filtering daemon
speech-dispatcher-audio-plugins_0.8.8-1ubuntu1_amd64.deb Speech Dispatcher: Audio output plugins
speech-dispatcher-espeak-ng_0.8.8-1ubuntu1_amd64.deb Speech Dispatcher: Espeak-ng output module
speech-dispatcher_0.8.8-1ubuntu1_amd64.deb Common interface to speech synthesizers
speex-doc_1.2~rc1.2-1ubuntu2_all.deb Documentation for speex
sphinx-common_1.6.7-1ubuntu1_all.deb documentation generator for Python projects - common data
sphinx-doc_1.6.7-1ubuntu1_all.deb documentation generator for Python projects - documentation
sphinx-rtd-theme-common_0.2.4-1_all.deb sphinx theme from readthedocs.org (common files)
Advertisement
Advertisement