siege_4.0.4-1build1_amd64.deb


Advertisement

Description

siege - HTTP regression testing and benchmarking utility

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name siege
Package version 4.0.4
Package release 1build1
Package architecture amd64
Package type deb
Installed size 271 B
Download size 96.04 KB
Official Mirror archive.ubuntu.com
Siege is an regression test and benchmark utility. It can stress test a single
URL with a user defined number of simulated users, or it can read many URLs
into memory and stress them simultaneously. The program reports the total
number of hits recorded, bytes transferred, response time, concurrency, and
return status. Siege supports HTTP/1.0 and 1.1 protocols, the GET and POST
directives, cookies, transaction logging, and basic authentication. Its
features are configurable on a per user basis.
Note: this package contains siege with HTTPS support turned on, thus it
obsoletes siege-ssl package now.

Alternatives

Package Version Architecture Repository
siege_4.0.4-1build1_i386.deb 4.0.4 i386 Ubuntu Main
siege - - -

Requires

Name Value
libc6 >= 2.15
libssl1.1 >= 1.1.0
zlib1g >= 1:1.1.4

Conflicts

Name Value
siege-ssl -

Replaces

Name Value
siege-ssl -

Download

Type URL
Binary Package siege_4.0.4-1build1_amd64.deb
Source Package siege

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install siege deb package:
    # sudo apt-get install siege

Files

Path
/etc/siege/siegerc
/etc/siege/urls.txt
/usr/bin/bombardment
/usr/bin/siege
/usr/bin/siege.config
/usr/bin/siege2csv
/usr/share/doc/siege/AUTHORS
/usr/share/doc/siege/README.md.gz
/usr/share/doc/siege/changelog.Debian.gz
/usr/share/doc/siege/copyright
/usr/share/man/man1/bombardment.1.gz
/usr/share/man/man1/siege.1.gz
/usr/share/man/man1/siege.config.1.gz
/usr/share/man/man1/siege2csv.1.gz

Changelog

2018-02-05 - Dimitri John Ledkov <xnox@ubuntu.com>
siege (4.0.4-1build1) bionic; urgency=high
* No change rebuild against openssl1.1.
2017-10-22 - Josue Abarca <jmaslibre@debian.org>
siege (4.0.4-1) unstable; urgency=medium
* New upstream version 4.0.4. Closes: #865502
* debian/control
- Standards-Version increased to 4.1.1, no changes required.
- Build dependency on zlib1g-dev added to enable Zip encoding.
2016-09-27 - Mattia Rizzolo <mattia@debian.org>
siege (4.0.2-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Canonicalize Vcs-* fields.
* bump debhelper compat level to 9:
+ dh exports build flags from dpkg-buildflags.
* Stop using hardening-wrapper, make use of dpkg-buildflags with
DEB_BUILD_MAINT_OPTIONS=hardening=+all
instead.  Closes: #836654
2016-06-11 - Josue Abarca <jmaslibre@debian.org>
siege (4.0.2-1) unstable; urgency=medium
* New upstream version 4.0.2.
* debian/docs
- NEWS, KNOWNBUGS, MACHINES, are no longer provided by upstream.
- README was renamed to README.md
* debian/control
- Fix insecure uris in the vcs fields.
- Standards-Version increased to 3.9.8, no changes required.
* debian/copyright removed some entries because lib/* was removed by
upstream.
* hyphen-used-as-minus-sign.diff removed, fixed upstream.
* layingsiege.7.in.diff removed, this file was removed upstream.
* set_verbose_to_false.diff updated.
* update_doc_about_log_file.diff updated.
* update_doc_about_urls_file.diff updated.
* siege.1.in.diff patch added in order to fix a typo, a missing dash,
and a break line issue in the manpage.
* debian/rules updated the debhelper sequence and options order.
2014-10-05 - Josue Abarca <jmaslibre@debian.org>
siege (3.0.8-1) unstable; urgency=medium
* Imported Upstream version 3.0.8
* debian/source/lintian-overrides:
- Add override for new lintian error concerning hardening-wrapper
being obsolete, isn't so based on #711193 despite lintian reporting
such. Siege continues build-depending on hardening-wrapper for now,
while the build scripts are updated to support dpkg build flags.
* debian/control Standards-Version increased to 3.9.6, no changes
required.
* debian/watch updated.
* hyphen-used-as-minus-sign.diff added in order to correct some hyphens
thar were used as minus in siege.1.in.
2013-11-22 - Josue Abarca <jmaslibre@debian.org>
siege (3.0.5-1) unstable; urgency=low
* New Upstream version 3.0.5.
* bombardment.in-typo.diff patch updated.
* debian/control
- Build-Depends: Builds-Depends: Removed automake. (closes: #724435)
- Standards-Version increased to 3.9.5, no changes required.
2013-06-02 - Josue Abarca <jmaslibre@debian.org>
siege (3.0.1-1) unstable; urgency=low
* New upstream version.
- The undefined behavior in DNS resolution is now fixed, thanks to
Michael Hudson-Doyle for providing to upstream the patch to fix this
(closes: #706662).
* hyphen-used-as-minus-sign.diff patch dropped, it was merged upstream.
* update_doc_about_log_file.diff path updated.
* update_doc_about_urls_file.diff path updated.
* Upload to unstable.
2013-03-24 - Josue Abarca <jmaslibre@debian.org>
siege (2.78-1) experimental; urgency=low
* New upstream version
* debian/rules override_dh_auto_install parameters removed, because
upstream added the DESTDIR to the makefile.
* debian/control Standards-Version increased to 3.9.4, no changes
required.

See Also

Package Description
simple-scan_3.28.0-0ubuntu1_amd64.deb Simple Scanning Utility
slapd_2.4.45+dfsg-1ubuntu1_amd64.deb OpenLDAP server (slapd)
smartmontools_6.5+svn4324-1_amd64.deb control and monitor storage systems using S.M.A.R.T
smbclient_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb command-line SMB/CIFS clients for Unix
smitools_0.4.8+dfsg2-15_amd64.deb various tools operating on MIB module files
snapd_2.32.5+18.04_amd64.deb Daemon and tooling that enable snap packages
snmp_5.7.3+dfsg-1.8ubuntu3_amd64.deb SNMP (Simple Network Management Protocol) applications
snmpd_5.7.3+dfsg-1.8ubuntu3_amd64.deb SNMP (Simple Network Management Protocol) agents
socat_1.7.3.2-2ubuntu2_amd64.deb multipurpose relay for bidirectional data transfer
software-properties-common_0.96.24.32.1_all.deb manage the repositories that you install software from (common)
software-properties-gtk_0.96.24.32.1_all.deb manage the repositories that you install software from (gtk)
sosreport_3.5-1ubuntu3_amd64.deb Set of tools to gather troubleshooting data from a system
sound-icons_0.1-6_all.deb Sounds for speech enabled applications
sound-theme-freedesktop_0.8-2ubuntu1_all.deb freedesktop.org sound theme
spamassassin_3.4.1-8build1_all.deb Perl-based spam filter using text analysis
Advertisement
Advertisement