ruby2.5-dev_2.5.1-1ubuntu1_amd64.deb


Advertisement

Description

ruby2.5-dev - Header files for compiling extension modules for the Ruby 2.5

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name ruby2.5-dev
Package version 2.5.1
Package release 1ubuntu1
Package architecture amd64
Package type deb
Installed size 320 B
Download size 62.21 KB
Official Mirror archive.ubuntu.com
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in perl).  It is simple,
straight-forward, and extensible.
This package contains the header files and the mkmf library, necessary
to make extension library for Ruby 2.5. It is also required to build
many gems.

Alternatives

Package Version Architecture Repository
ruby2.5-dev_2.5.1-1ubuntu1.1_i386.deb 2.5.1 i386 Ubuntu Updates Main
ruby2.5-dev_2.5.1-1ubuntu1.1_amd64.deb 2.5.1 amd64 Ubuntu Updates Main
ruby2.5-dev_2.5.1-1ubuntu1_i386.deb 2.5.1 i386 Ubuntu Main
ruby2.5-dev - - -

Requires

Name Value
libgmp-dev -
libruby2.5 = 2.5.1-1ubuntu1

Download

Type URL
Binary Package ruby2.5-dev_2.5.1-1ubuntu1_amd64.deb
Source Package ruby2.5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby2.5-dev deb package:
    # sudo apt-get install ruby2.5-dev

Files

Path
/usr/include/ruby-2.5.0/ruby.h
/usr/include/ruby-2.5.0/ruby/backward.h
/usr/include/ruby-2.5.0/ruby/debug.h
/usr/include/ruby-2.5.0/ruby/defines.h
/usr/include/ruby-2.5.0/ruby/digest.h
/usr/include/ruby-2.5.0/ruby/encoding.h
/usr/include/ruby-2.5.0/ruby/intern.h
/usr/include/ruby-2.5.0/ruby/io.h
/usr/include/ruby-2.5.0/ruby/missing.h
/usr/include/ruby-2.5.0/ruby/onigmo.h
/usr/include/ruby-2.5.0/ruby/oniguruma.h
/usr/include/ruby-2.5.0/ruby/re.h
/usr/include/ruby-2.5.0/ruby/regex.h
/usr/include/ruby-2.5.0/ruby/ruby.h
/usr/include/ruby-2.5.0/ruby/st.h
/usr/include/ruby-2.5.0/ruby/subst.h
/usr/include/ruby-2.5.0/ruby/thread.h
/usr/include/ruby-2.5.0/ruby/thread_native.h
/usr/include/ruby-2.5.0/ruby/util.h
/usr/include/ruby-2.5.0/ruby/version.h
/usr/include/ruby-2.5.0/ruby/vm.h
/usr/include/ruby-2.5.0/ruby/backward/classext.h
/usr/include/ruby-2.5.0/ruby/backward/rubyio.h
/usr/include/ruby-2.5.0/ruby/backward/rubysig.h
/usr/include/ruby-2.5.0/ruby/backward/st.h
/usr/include/ruby-2.5.0/ruby/backward/util.h
/usr/include/x86_64-linux-gnu/ruby-2.5.0/ruby/config.h
/usr/lib/x86_64-linux-gnu/libruby-2.5.so
/usr/lib/x86_64-linux-gnu/pkgconfig/ruby-2.5.pc
/usr/share/doc/ruby2.5-dev/changelog.Debian.gz
/usr/share/doc/ruby2.5-dev/copyright

Changelog

See ruby2.5_2.5.1-1ubuntu1_amd64.deb changelog.

See Also

Package Description
ruby2.5-doc_2.5.1-1ubuntu1_all.deb Documentation for Ruby 2.5
ruby2.5_2.5.1-1ubuntu1_amd64.deb Interpreter of object-oriented scripting language Ruby
ruby_2.5.1_amd64.deb Interpreter of object-oriented scripting language Ruby (default version)
rubygems-integration_1.11_all.deb integration of Debian Ruby packages with Rubygems
run-one_1.17-0ubuntu1_all.deb run just one instance of a command and its args at a time
sa-compile_3.4.1-8build1_all.deb Tools for compiling SpamAssassin rules into C
samba-common-bin_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba common files used by both the server and the client
samba-common_4.7.6+dfsg~ubuntu-0ubuntu2_all.deb common files used by both the Samba server and client
samba-dev_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb tools for extending Samba
samba-dsdb-modules_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba Directory Services Database
samba-libs_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba core libraries
samba-vfs-modules_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba Virtual FileSystem plugins
samba_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb SMB/CIFS file, print, and login server for Unix
sane-utils_1.0.27-1~experimental3ubuntu2_amd64.deb API library for scanners -- utilities
sasl2-bin_2.1.27~101-g0780600+dfsg-3ubuntu2_amd64.deb Cyrus SASL - administration programs for SASL users database
Advertisement
Advertisement