ruby-all-dev_2.5.1_amd64.deb


Advertisement

Description

ruby-all-dev - Ruby development environment (all versions supported in Debian)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name ruby-all-dev
Package version 2.5.1
Package architecture amd64
Package type deb
Installed size 23 B
Download size 5.24 KB
Official Mirror archive.ubuntu.com
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in perl).  It is simple,
straight-forward, and extensible.
This package depends on the respective development packages for every Ruby
version currently supported by Debian. This will usually be a single version
(the default one), but during transitions multiple versions might be
supported.
To programmatically list all the supported versions, install the `gem2deb`
package and run `dh_ruby --print-supported`. To determine which is the default
version, just dereference the /usr/bin/ruby symbolic link.
If you are not building Ruby packages for Debian, you probably do not need
this package.

Alternatives

Package Version Architecture Repository
ruby-all-dev_2.5.1_i386.deb 2.5.1 i386 Ubuntu Main
ruby-all-dev - - -

Requires

Name Value
ruby2.5-dev -
ruby2.5:any -

Download

Type URL
Binary Package ruby-all-dev_2.5.1_amd64.deb
Source Package ruby-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-all-dev deb package:
    # sudo apt-get install ruby-all-dev

Files

Path
/usr/lib/ruby/vendor_ruby/ruby_debian_dev.rb
/usr/share/doc/ruby-all-dev/NEWS.Debian.gz
/usr/share/doc/ruby-all-dev/changelog.gz
/usr/share/doc/ruby-all-dev/copyright

Changelog

2018-03-22 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5.1) unstable; urgency=medium
* Drop support for ruby2.3
* Use salsa.debian.org in Vcs-* fields
2018-03-04 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5.0) unstable; urgency=medium
* Really upload to unstable this time.
2018-03-04 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5) experimental; urgency=medium
* Switch to ruby2.5 in unstable
* debian/rules: call debian/version-check before configure to ensure
consistent versions numbers, i.e. If Ruby X.Y is the default, then the
metapackage *must* be versioned as E:X.Y* (E being the epoch).
* RubyDebianDev: Provide an upper bound on supported Ruby versions that can
be used to prevent installation without a supported Ruby interpreter
(Closes: #860747). Note that gem2deb also needs to be updated to be able
to use this data.
* RubyDebianDev::SUPPORTED_RUBY_VERSIONS: make sure default Ruby always
comes first.
2018-02-03 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5~1000grau) experimental; urgency=medium
* Make Ruby 2.5 the default
2018-02-01 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5~1) unstable; urgency=medium
* Upload to unstable
* Bump Standards-Version to 4.1.3; no changes needed
* Drop unnecessary Testsuite: header
* Drop triggers used to help upgrades in the ruby1.8/ruby1.9.1 era; those
versions are now only in oldoldstable.
* Specify section `ruby` for ruby-dev and ruby-all-dev
2018-01-23 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.5~0) experimental; urgency=medium
* Enable building against ruby2.5
2016-12-10 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:2.3.3) unstable; urgency=medium
* Rename libtcltk-ruby to ruby-tcltk to be consistent with other ruby
packages. Keep Provides: libtcltk-ruby for now.
* debian/copyright: list copyright for all maintainers in the latest years.
2016-04-14 - Christian Hofstaedtler <zeha@debian.org>
ruby-defaults (1:2.3.0+4) unstable; urgency=medium
* Install ruby.pc symlink only in ruby-dev. (Closes: #820962)
2016-04-13 - Christian Hofstaedtler <zeha@debian.org>
ruby-defaults (1:2.3.0+3) unstable; urgency=medium
* Turn `ruby` package into an `Architecture: any` package, too,
to ease Multi-Arch interpreter issues. Also add missing Multi-Arch
annotation to ruby-all-dev. Thanks to Helmut Grohne <helmutg@debian.org>.
2016-04-13 - Christian Hofstaedtler <zeha@debian.org>
ruby-defaults (1:2.3.0+2) unstable; urgency=medium
* Add workaround for Multi-Arch interpreter problem.
Change ruby-all-dev to be an arch native package, so it can be
used in Build-Depends without losing Architecture information,
and have it depend on rubyN.M:any so the default ruby can still
be used to run ruby.
Thanks to Helmut Grohne <helmutg@debian.org>.

See Also

Package Description
ruby-dev_2.5.1_amd64.deb Header files for compiling extension modules for Ruby (default version)
ruby-did-you-mean_1.2.0-2_all.deb smart error messages for Ruby > 2.3
ruby-minitest_5.10.3-1_all.deb Ruby test tools supporting TDD, BDD, mocking, and benchmarking
ruby-net-telnet_0.1.1-2_all.deb telnet client library
ruby-power-assert_0.3.0-1_all.deb library showing values of variables and method calls in an expression
ruby-test-unit_3.2.5-1_all.deb unit testing framework for Ruby
ruby2.5-dev_2.5.1-1ubuntu1_amd64.deb Header files for compiling extension modules for the Ruby 2.5
ruby2.5-doc_2.5.1-1ubuntu1_all.deb Documentation for Ruby 2.5
ruby2.5_2.5.1-1ubuntu1_amd64.deb Interpreter of object-oriented scripting language Ruby
ruby_2.5.1_amd64.deb Interpreter of object-oriented scripting language Ruby (default version)
rubygems-integration_1.11_all.deb integration of Debian Ruby packages with Rubygems
run-one_1.17-0ubuntu1_all.deb run just one instance of a command and its args at a time
sa-compile_3.4.1-8build1_all.deb Tools for compiling SpamAssassin rules into C
samba-common-bin_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba common files used by both the server and the client
samba-common_4.7.6+dfsg~ubuntu-0ubuntu2_all.deb common files used by both the Samba server and client
Advertisement
Advertisement