rtkit_0.11-6_amd64.deb


Advertisement

Description

rtkit - Realtime Policy and Watchdog Daemon

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name rtkit
Package version 0.11
Package release 6
Package architecture amd64
Package type deb
Installed size 135 B
Download size 34.85 KB
Official Mirror archive.ubuntu.com
RealtimeKit is a D-Bus system service that changes the
scheduling policy of user processes/threads to SCHED_RR
(i.e. realtime scheduling mode) on request. It is intended to
be used as a secure mechanism to allow real-time scheduling to
be used by normal user processes.

Alternatives

Package Version Architecture Repository
rtkit_0.11-6_i386.deb 0.11 i386 Ubuntu Main
rtkit - - -

Requires

Name Value
adduser -
dbus -
libc6 >= 2.8
libcap2 >= 1:2.10
libdbus-1-3 >= 1.9.14
policykit-1 -

Download

Type URL
Binary Package rtkit_0.11-6_amd64.deb
Source Package rtkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rtkit deb package:
    # sudo apt-get install rtkit

Files

Path
/etc/dbus-1/system.d/org.freedesktop.RealtimeKit1.conf
/lib/systemd/system/rtkit-daemon.service
/usr/lib/rtkit/rtkit-daemon
/usr/lib/rtkit/rtkit-test
/usr/sbin/rtkitctl
/usr/share/dbus-1/interfaces/org.freedesktop.RealtimeKit1.xml
/usr/share/dbus-1/system-services/org.freedesktop.RealtimeKit1.service
/usr/share/doc/rtkit/README.gz
/usr/share/doc/rtkit/changelog.Debian.gz
/usr/share/doc/rtkit/copyright
/usr/share/man/man8/rtkitctl.8.gz
/usr/share/polkit-1/actions/org.freedesktop.RealtimeKit1.policy

Changelog

2018-02-16 - Felipe Sateler <fsateler@debian.org>
rtkit (0.11-6) unstable; urgency=medium
* Move dbus and polkit from Recommends to Depends
rtkit can't do much really without either of them so bump them to Depends.
(Closes: #881342)
* Switch maintainer to debian-multimedia@l.d.o since alioth will be going away
* Update Vcs-* to point to salsa
* Update standards-version (no changes needed)
* Drop dh-autoreconf and autotools-dev Build-Dependencies, implied by debhelper compat 10
2017-06-27 - Felipe Sateler <fsateler@debian.org>
rtkit (0.11-5) unstable; urgency=medium
[ Felipe Sateler ]
* Update Vcs-* urls
* Stop the rktid daemon when removing the package. (Closes: #813149)
* Bump debhelper compat level to 10
* Switch from cdbs to dh sequencer
* Enable hardening flags
* Don't start or enable the rtkit daemon by default.
Debhelper 10 enables the systemd addon by default, so disable the
starting on install it brings.
* Bump standards-version (no changes needed)
[ Andrew Shadura ]
* Add a format string to dbus_message_new_error_printf.
Fixes an FTBFS due to -Werror=format-security (Closes: #855605)
2015-10-24 - Felipe Sateler <fsateler@debian.org>
rtkit (0.11-4) unstable; urgency=medium
* Remove stale ubuntu.series file.
2015-10-18 - Felipe Sateler <fsateler@debian.org>
rtkit (0.11-3) unstable; urgency=medium
[ Felipe Sateler ]
* Add myself to uploaders
* Add patch to fix rtkit-test failure
* Install rtkit test program
* Use autoreconf at build
* Fix linkage with librt (Closes: #802110)
* Build rtkit out-of-tree
* Fixup build in outoftree
* Pick up no-ptrace patch from ubuntu.
[ Alessio Treglia ]
* Drop 02-fix-undropped-supp-groups.patch.
2014-11-16 - Felipe Sateler <fsateler@debian.org>
rtkit (0.11-2) unstable; urgency=medium
* Team upload
* Remove build dependency on libpolkit-backend-1-dev, it is not used
(Closes: #696900)
* Drop removed ControlGroup stanza (Closes: #747568)
2014-04-28 - Alessio Treglia <alessio@debian.org>
rtkit (0.11-1) unstable; urgency=low
* New upstream release.
* Drop 02-fix-undropped-supp-groups.patch, already adopted upstream.
* debian/watch: New tarballs seem to be provided in xz format.
* Fix multiple issues in debian/copyright:
- Fix wrong License fields and files listing.
- Update copyright holders information.
* Fix VCS tags.
* Bump Standards.
2013-09-19 - Alessio Treglia <alessio@debian.org>
rtkit (0.10-3) unstable; urgency=high
* Update debian/copyright.
* Add dbus, policykit-1 on Recommends. (Closes: #657351)
* Fix CVE-2013-4326 (Closes: #723714)
2011-07-28 - Alessio Treglia <alessio@debian.org>
rtkit (0.10-2) unstable; urgency=low
* debian/patches/02-fix-undropped-supp-groups.patch:
- Fix a security bug of not dropping supplemental groups.
* Bump Standards.
2011-03-09 - Alessio Treglia <alessio@debian.org>
rtkit (0.10-1) unstable; urgency=low
* New upstream release.
2011-02-09 - Alessio Treglia <alessio@debian.org>
rtkit (0.9-3) unstable; urgency=low
* Pass systemd unit dir to the configure script, thanks to
Daniel Schaal for the patch (Closes: #612084).

See Also

Package Description
ruby-all-dev_2.5.1_amd64.deb Ruby development environment (all versions supported in Debian)
ruby-dev_2.5.1_amd64.deb Header files for compiling extension modules for Ruby (default version)
ruby-did-you-mean_1.2.0-2_all.deb smart error messages for Ruby > 2.3
ruby-minitest_5.10.3-1_all.deb Ruby test tools supporting TDD, BDD, mocking, and benchmarking
ruby-net-telnet_0.1.1-2_all.deb telnet client library
ruby-power-assert_0.3.0-1_all.deb library showing values of variables and method calls in an expression
ruby-test-unit_3.2.5-1_all.deb unit testing framework for Ruby
ruby2.5-dev_2.5.1-1ubuntu1_amd64.deb Header files for compiling extension modules for the Ruby 2.5
ruby2.5-doc_2.5.1-1ubuntu1_all.deb Documentation for Ruby 2.5
ruby2.5_2.5.1-1ubuntu1_amd64.deb Interpreter of object-oriented scripting language Ruby
ruby_2.5.1_amd64.deb Interpreter of object-oriented scripting language Ruby (default version)
rubygems-integration_1.11_all.deb integration of Debian Ruby packages with Rubygems
run-one_1.17-0ubuntu1_all.deb run just one instance of a command and its args at a time
sa-compile_3.4.1-8build1_all.deb Tools for compiling SpamAssassin rules into C
samba-common-bin_4.7.6+dfsg~ubuntu-0ubuntu2_amd64.deb Samba common files used by both the server and the client
Advertisement
Advertisement