python3-pygments_2.2.0+dfsg-1_all.deb


Advertisement

Description

python3-pygments - syntax highlighting package written in Python 3

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python3-pygments
Package version 2.2.0+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 3.07 KB
Download size 560.64 KB
Official Mirror archive.ubuntu.com
Pygments aims to be a generic syntax highlighter for general use in all kinds
of software such as forum systems, wikis or other applications that need to
prettify source code.
Highlights are:
* a wide range of common languages and markup formats is supported
* special attention is paid to details, increasing quality by a fair amount
* support for new languages and formats are added easily
* a number of output formats, presently HTML, LaTeX and ANSI sequences
* it is usable as a command-line tool and as a library

Alternatives

Package Version Architecture Repository
python3-pygments_2.2.0+dfsg-1_all.deb 2.2.0+dfsg all Ubuntu Main
python3-pygments - - -

Requires

Name Value
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package python3-pygments_2.2.0+dfsg-1_all.deb
Source Package pygments

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-pygments deb package:
    # sudo apt-get install python3-pygments

Files

Path
/usr/lib/python3/dist-packages/Pygments-2.2.0.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/Pygments-2.2.0.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/Pygments-2.2.0.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/Pygments-2.2.0.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/Pygments-2.2.0.egg-info/top_level.txt
/usr/lib/python3/dist-packages/pygments/__init__.py
/usr/lib/python3/dist-packages/pygments/cmdline.py
/usr/lib/python3/dist-packages/pygments/console.py
/usr/lib/python3/dist-packages/pygments/filter.py
/usr/lib/python3/dist-packages/pygments/formatter.py
/usr/lib/python3/dist-packages/pygments/lexer.py
/usr/lib/python3/dist-packages/pygments/modeline.py
/usr/lib/python3/dist-packages/pygments/plugin.py
/usr/lib/python3/dist-packages/pygments/regexopt.py
/usr/lib/python3/dist-packages/pygments/scanner.py
/usr/lib/python3/dist-packages/pygments/sphinxext.py
/usr/lib/python3/dist-packages/pygments/style.py
/usr/lib/python3/dist-packages/pygments/token.py
/usr/lib/python3/dist-packages/pygments/unistring.py
/usr/lib/python3/dist-packages/pygments/util.py
/usr/lib/python3/dist-packages/pygments/filters/__init__.py
/usr/lib/python3/dist-packages/pygments/formatters/__init__.py
/usr/lib/python3/dist-packages/pygments/formatters/_mapping.py
/usr/lib/python3/dist-packages/pygments/formatters/bbcode.py
/usr/lib/python3/dist-packages/pygments/formatters/html.py
/usr/lib/python3/dist-packages/pygments/formatters/img.py
/usr/lib/python3/dist-packages/pygments/formatters/irc.py
/usr/lib/python3/dist-packages/pygments/formatters/latex.py
/usr/lib/python3/dist-packages/pygments/formatters/other.py
/usr/lib/python3/dist-packages/pygments/formatters/rtf.py
/usr/lib/python3/dist-packages/pygments/formatters/svg.py
/usr/lib/python3/dist-packages/pygments/formatters/terminal.py
/usr/lib/python3/dist-packages/pygments/formatters/terminal256.py
/usr/lib/python3/dist-packages/pygments/lexers/__init__.py
/usr/lib/python3/dist-packages/pygments/lexers/_asy_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_cl_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_cocoa_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_csound_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_lasso_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_lua_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_mapping.py
/usr/lib/python3/dist-packages/pygments/lexers/_mql_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_openedge_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_php_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_postgres_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_scilab_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_sourcemod_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_stan_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_stata_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_tsql_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/_vim_builtins.py
/usr/lib/python3/dist-packages/pygments/lexers/actionscript.py
/usr/lib/python3/dist-packages/pygments/lexers/agile.py
/usr/lib/python3/dist-packages/pygments/lexers/algebra.py
/usr/lib/python3/dist-packages/pygments/lexers/ambient.py
/usr/lib/python3/dist-packages/pygments/lexers/ampl.py
/usr/lib/python3/dist-packages/pygments/lexers/apl.py
/usr/lib/python3/dist-packages/pygments/lexers/archetype.py
/usr/lib/python3/dist-packages/pygments/lexers/asm.py
/usr/lib/python3/dist-packages/pygments/lexers/automation.py
/usr/lib/python3/dist-packages/pygments/lexers/basic.py
/usr/lib/python3/dist-packages/pygments/lexers/bibtex.py
/usr/lib/python3/dist-packages/pygments/lexers/business.py
/usr/lib/python3/dist-packages/pygments/lexers/c_cpp.py
/usr/lib/python3/dist-packages/pygments/lexers/c_like.py
/usr/lib/python3/dist-packages/pygments/lexers/capnproto.py
/usr/lib/python3/dist-packages/pygments/lexers/chapel.py
/usr/lib/python3/dist-packages/pygments/lexers/clean.py
/usr/lib/python3/dist-packages/pygments/lexers/compiled.py
/usr/lib/python3/dist-packages/pygments/lexers/configs.py
/usr/lib/python3/dist-packages/pygments/lexers/console.py
/usr/lib/python3/dist-packages/pygments/lexers/crystal.py
/usr/lib/python3/dist-packages/pygments/lexers/csound.py
/usr/lib/python3/dist-packages/pygments/lexers/css.py
/usr/lib/python3/dist-packages/pygments/lexers/d.py
/usr/lib/python3/dist-packages/pygments/lexers/dalvik.py
/usr/lib/python3/dist-packages/pygments/lexers/data.py
/usr/lib/python3/dist-packages/pygments/lexers/diff.py
/usr/lib/python3/dist-packages/pygments/lexers/dotnet.py
/usr/lib/python3/dist-packages/pygments/lexers/dsls.py
/usr/lib/python3/dist-packages/pygments/lexers/dylan.py
/usr/lib/python3/dist-packages/pygments/lexers/ecl.py
/usr/lib/python3/dist-packages/pygments/lexers/eiffel.py
/usr/lib/python3/dist-packages/pygments/lexers/elm.py
/usr/lib/python3/dist-packages/pygments/lexers/erlang.py
/usr/lib/python3/dist-packages/pygments/lexers/esoteric.py
/usr/lib/python3/dist-packages/pygments/lexers/ezhil.py
/usr/lib/python3/dist-packages/pygments/lexers/factor.py
/usr/lib/python3/dist-packages/pygments/lexers/fantom.py
/usr/lib/python3/dist-packages/pygments/lexers/felix.py
/usr/lib/python3/dist-packages/pygments/lexers/forth.py
/usr/lib/python3/dist-packages/pygments/lexers/fortran.py
/usr/lib/python3/dist-packages/pygments/lexers/foxpro.py
/usr/lib/python3/dist-packages/pygments/lexers/functional.py
/usr/lib/python3/dist-packages/pygments/lexers/go.py
/usr/lib/python3/dist-packages/pygments/lexers/grammar_notation.py
/usr/lib/python3/dist-packages/pygments/lexers/graph.py
/usr/lib/python3/dist-packages/pygments/lexers/graphics.py
/usr/lib/python3/dist-packages/pygments/lexers/haskell.py
/usr/lib/python3/dist-packages/pygments/lexers/haxe.py
/usr/lib/python3/dist-packages/pygments/lexers/hdl.py
/usr/lib/python3/dist-packages/pygments/lexers/hexdump.py
/usr/lib/python3/dist-packages/pygments/lexers/html.py
/usr/lib/python3/dist-packages/pygments/lexers/idl.py
/usr/lib/python3/dist-packages/pygments/lexers/igor.py
/usr/lib/python3/dist-packages/pygments/lexers/inferno.py
/usr/lib/python3/dist-packages/pygments/lexers/installers.py
/usr/lib/python3/dist-packages/pygments/lexers/int_fiction.py
/usr/lib/python3/dist-packages/pygments/lexers/iolang.py
/usr/lib/python3/dist-packages/pygments/lexers/j.py
/usr/lib/python3/dist-packages/pygments/lexers/javascript.py
/usr/lib/python3/dist-packages/pygments/lexers/julia.py
/usr/lib/python3/dist-packages/pygments/lexers/jvm.py
/usr/lib/python3/dist-packages/pygments/lexers/lisp.py
/usr/lib/python3/dist-packages/pygments/lexers/make.py
/usr/lib/python3/dist-packages/pygments/lexers/markup.py
/usr/lib/python3/dist-packages/pygments/lexers/math.py
/usr/lib/python3/dist-packages/pygments/lexers/matlab.py
/usr/lib/python3/dist-packages/pygments/lexers/ml.py
/usr/lib/python3/dist-packages/pygments/lexers/modeling.py
/usr/lib/python3/dist-packages/pygments/lexers/modula2.py
/usr/lib/python3/dist-packages/pygments/lexers/monte.py
/usr/lib/python3/dist-packages/pygments/lexers/ncl.py
/usr/lib/python3/dist-packages/pygments/lexers/nimrod.py
/usr/lib/python3/dist-packages/pygments/lexers/nit.py
/usr/lib/python3/dist-packages/pygments/lexers/nix.py
/usr/lib/python3/dist-packages/pygments/lexers/oberon.py
/usr/lib/python3/dist-packages/pygments/lexers/objective.py
/usr/lib/python3/dist-packages/pygments/lexers/ooc.py
/usr/lib/python3/dist-packages/pygments/lexers/other.py
/usr/lib/python3/dist-packages/pygments/lexers/parasail.py
/usr/lib/python3/dist-packages/pygments/lexers/parsers.py
/usr/lib/python3/dist-packages/pygments/lexers/pascal.py
/usr/lib/python3/dist-packages/pygments/lexers/pawn.py
/usr/lib/python3/dist-packages/pygments/lexers/perl.py
/usr/lib/python3/dist-packages/pygments/lexers/php.py
/usr/lib/python3/dist-packages/pygments/lexers/praat.py
/usr/lib/python3/dist-packages/pygments/lexers/prolog.py
/usr/lib/python3/dist-packages/pygments/lexers/python.py
/usr/lib/python3/dist-packages/pygments/lexers/qvt.py
/usr/lib/python3/dist-packages/pygments/lexers/r.py
/usr/lib/python3/dist-packages/pygments/lexers/rdf.py
/usr/lib/python3/dist-packages/pygments/lexers/rebol.py
/usr/lib/python3/dist-packages/pygments/lexers/resource.py
/usr/lib/python3/dist-packages/pygments/lexers/rnc.py
/usr/lib/python3/dist-packages/pygments/lexers/roboconf.py
/usr/lib/python3/dist-packages/pygments/lexers/robotframework.py
/usr/lib/python3/dist-packages/pygments/lexers/ruby.py
/usr/lib/python3/dist-packages/pygments/lexers/rust.py
/usr/lib/python3/dist-packages/pygments/lexers/sas.py
/usr/lib/python3/dist-packages/pygments/lexers/scripting.py
/usr/lib/python3/dist-packages/pygments/lexers/shell.py
/usr/lib/python3/dist-packages/pygments/lexers/smalltalk.py
/usr/lib/python3/dist-packages/pygments/lexers/smv.py
/usr/lib/python3/dist-packages/pygments/lexers/snobol.py
/usr/lib/python3/dist-packages/pygments/lexers/special.py
/usr/lib/python3/dist-packages/pygments/lexers/sql.py
/usr/lib/python3/dist-packages/pygments/lexers/stata.py
/usr/lib/python3/dist-packages/pygments/lexers/supercollider.py
/usr/lib/python3/dist-packages/pygments/lexers/tcl.py
/usr/lib/python3/dist-packages/pygments/lexers/templates.py
/usr/lib/python3/dist-packages/pygments/lexers/testing.py
/usr/lib/python3/dist-packages/pygments/lexers/text.py
/usr/lib/python3/dist-packages/pygments/lexers/textedit.py
/usr/lib/python3/dist-packages/pygments/lexers/textfmts.py
/usr/lib/python3/dist-packages/pygments/lexers/theorem.py
/usr/lib/python3/dist-packages/pygments/lexers/trafficscript.py
/usr/lib/python3/dist-packages/pygments/lexers/typoscript.py
/usr/lib/python3/dist-packages/pygments/lexers/urbi.py
/usr/lib/python3/dist-packages/pygments/lexers/varnish.py
/usr/lib/python3/dist-packages/pygments/lexers/verification.py
/usr/lib/python3/dist-packages/pygments/lexers/web.py
/usr/lib/python3/dist-packages/pygments/lexers/webmisc.py
/usr/lib/python3/dist-packages/pygments/lexers/whiley.py
/usr/lib/python3/dist-packages/pygments/lexers/x10.py
/usr/lib/python3/dist-packages/pygments/styles/__init__.py
/usr/lib/python3/dist-packages/pygments/styles/abap.py
/usr/lib/python3/dist-packages/pygments/styles/algol.py
/usr/lib/python3/dist-packages/pygments/styles/algol_nu.py
/usr/lib/python3/dist-packages/pygments/styles/arduino.py
/usr/lib/python3/dist-packages/pygments/styles/autumn.py
/usr/lib/python3/dist-packages/pygments/styles/borland.py
/usr/lib/python3/dist-packages/pygments/styles/bw.py
/usr/lib/python3/dist-packages/pygments/styles/colorful.py
/usr/lib/python3/dist-packages/pygments/styles/default.py
/usr/lib/python3/dist-packages/pygments/styles/emacs.py
/usr/lib/python3/dist-packages/pygments/styles/friendly.py
/usr/lib/python3/dist-packages/pygments/styles/fruity.py
/usr/lib/python3/dist-packages/pygments/styles/igor.py
/usr/lib/python3/dist-packages/pygments/styles/lovelace.py
/usr/lib/python3/dist-packages/pygments/styles/manni.py
/usr/lib/python3/dist-packages/pygments/styles/monokai.py
/usr/lib/python3/dist-packages/pygments/styles/murphy.py
/usr/lib/python3/dist-packages/pygments/styles/native.py
/usr/lib/python3/dist-packages/pygments/styles/paraiso_dark.py
/usr/lib/python3/dist-packages/pygments/styles/paraiso_light.py
/usr/lib/python3/dist-packages/pygments/styles/pastie.py
/usr/lib/python3/dist-packages/pygments/styles/perldoc.py
/usr/lib/python3/dist-packages/pygments/styles/rainbow_dash.py
/usr/lib/python3/dist-packages/pygments/styles/rrt.py
/usr/lib/python3/dist-packages/pygments/styles/sas.py
/usr/lib/python3/dist-packages/pygments/styles/stata.py
/usr/lib/python3/dist-packages/pygments/styles/tango.py
/usr/lib/python3/dist-packages/pygments/styles/trac.py
/usr/lib/python3/dist-packages/pygments/styles/vim.py
/usr/lib/python3/dist-packages/pygments/styles/vs.py
/usr/lib/python3/dist-packages/pygments/styles/xcode.py
/usr/share/doc/python3-pygments/changelog.Debian.gz
/usr/share/doc/python3-pygments/copyright

Changelog

2017-01-23 - Piotr Ożarowski <piotr@debian.org>
pygments (2.2.0+dfsg-1) unstable; urgency=medium
* New upstream release.
2016-05-02 - Dmitry Shachnev <mitya57@debian.org>
pygments (2.1.3+dfsg-1) unstable; urgency=medium
* Team upload.
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Dmitry Shachnev ]
* New upstream bugfix release.
2016-01-25 - Dmitry Shachnev <mitya57@debian.org>
pygments (2.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* New upstream release.
* Drop CVE-2015-8557.patch, applied upstream.
* Disable two tests that need example files, again.
* Stop setting PYTHONWARNINGS=d when running the autopkgtests, that
breaks the cmdline test which checks that process stderr is empty.
[ Piotr Ożarowski ]
* Remove /etc/bash_completion.d/pygmentize conffile in maintainer scripts
(closes: #810661)
2016-01-10 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0.1+dfsg-2) unstable; urgency=high
[ Salvatore Bonaccorso ]
* Add CVE-2015-8557.patch patch.
CVE-2015-8557: Shell injection in FontManager._get_nix_font_path.
(Closes: #802828)
[ Piotr Ożarowski ]
* debian/watch: use pypi.debian.net redirector
* install pygmentize's bash completion to
/usr/share/bash-completion/completions
2015-03-22 - Sébastien Villemot <sebastien@debian.org>
pygments (2.0.1+dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/copyright: add the missing licenses of:
- pygments/lexers/robotframework.py
- tests/dtds/HTMLspec.ent
- tests/dtds/HTMLlat1.ent
- tests/dtds/HTMLsym.ent
(Closes: #766042)
2014-11-09 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* Drop disable_example_files_test.patch, no longer needed.
* Enable verbose tests output.
[ Piotr Ożarowski ]
* New upstream release
- pygmentize no longer fails when writing UTF-8 to output files
(closes: 771724)
* Drop doc/_build from the tarball (mostly due to missing JS sources; these
files are regenerated anyway)
* Remove .pyc files from upstream tarball
* make_utf8_default patch removed, no longer needed
2014-10-19 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0~rc1.a2bc2bd+dfsg-1) unstable; urgency=medium
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Dmitry Shachnev ]
* Make autopkgtests depend on patch (to fix test failure on CI)
and python[3]-all (to run tests for all supported Python versions).
Closes: #740166.
[ Piotr Ożarowski ]
* New upstream release
- Bump X-Python-Version to 2.6
* Documentation moved to new binary package: python-pygments-doc
* Add dh-python and python-sphinx to Build-Depends
* Switch debhelper compat level to 9
* Standards-Version bumped to 3.9.6 (no changes needed)
2013-02-03 - Piotr Ożarowski <piotr@debian.org>
pygments (1.6+dfsg-1) experimental; urgency=low
* New upstream release
* fix_makefile_re.patch removed, no longer needed
* debian/watch file updated to handle rc versions correctly
2013-01-06 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-2) unstable; urgency=low
[ Dmitry Shachnev ]
* Add DEP-8 tests (closes: #693028).
* Remove unneeded build-dependency on quilt.
* Bump Standards-Version to 3.9.4.
+ Add empty build-arch target to debian/rules.
* Drop Breaks: {python:Breaks}, it is obsolete.
* debian/patches/fix_makefile_re.patch: cherry-picked upstream commit
that fixes Makefile highlighting.
2012-03-11 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-1) unstable; urgency=low
* New upstream release
* make_utf8_default patch: do not change the encoding guessing part in
pygments/lexer.py; updated to new upstream version
* debian/pygmentize no longer needed, upstream now ships the script in the
tarball (and it returns correct exit codes, closes: 628881)

See Also

Package Description
python3-pyinotify_0.9.6-1_all.deb simple Linux inotify Python bindings
python3-pylibacl_0.5.3-1build2_amd64.deb module for manipulating POSIX.1e ACLs (Python3 version)
python3-pymacaroons_0.13.0-1_all.deb Macaroon library for Python 3
python3-pymongo-ext_3.6.1+dfsg1-1_amd64.deb C-coded extension to the python3-pymongo package
python3-pymongo_3.6.1+dfsg1-1_amd64.deb Python3 interface to the MongoDB document-oriented database
python3-pyparsing_2.2.0+dfsg1-2_all.deb alternative to creating and executing simple grammars - Python 3.x
python3-pyperclip_1.6.0-1_all.deb Cross-platform clipboard module for Python3
python3-pyudev_0.21.0-1_all.deb Python3 bindings for libudev
python3-pyvmomi_6.5.0.2017.5-0ubuntu1_all.deb VMware vSphere Python SDK - Python 3.x
python3-pyxattr_0.6.0-2build2_amd64.deb module for manipulating filesystem extended attributes (Python3)
python3-pyxs_0.4.1+dfsg1-0ubuntu1_all.deb Pure Python 3 bindings to XenStore
python3-renderpm_3.4.0-3build1_amd64.deb python low level render interface
python3-reportlab-accel_3.4.0-3build1_amd64.deb C coded extension accelerator for the ReportLab Toolkit
python3-reportlab_3.4.0-3build1_all.deb ReportLab library to create PDF documents using Python3
python3-requests-unixsocket_0.1.5-3_all.deb Use requests to talk HTTP via a UNIX domain socket - Python 3.x
Advertisement
Advertisement