python3-lazr.uri_1.0.3-2build1_all.deb


Advertisement

Description

python3-lazr.uri - library for parsing, manipulating, and generating URIs

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python3-lazr.uri
Package version 1.0.3
Package release 2build1
Package architecture all
Package type deb
Installed size 92 B
Download size 12.59 KB
Official Mirror archive.ubuntu.com
A self-contained, easily reusable, Python library for parsing,
manipulating and generating URIs. With it you can extract parts
of a URL, compare URIs to see if one contains another, search for
URIs in text, and many other things.
This package contains the library for Python 3.x.

Alternatives

Package Version Architecture Repository
python3-lazr.uri_1.0.3-2build1_all.deb 1.0.3 all Ubuntu Main
python3-lazr.uri - - -

Requires

Name Value
python3-pkg-resources -
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package python3-lazr.uri_1.0.3-2build1_all.deb
Source Package lazr.uri

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-lazr.uri deb package:
    # sudo apt-get install python3-lazr.uri

Files

Path
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/namespace_packages.txt
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/requires.txt
/usr/lib/python3/dist-packages/lazr.uri-1.0.3.egg-info/top_level.txt
/usr/lib/python3/dist-packages/lazr/uri/__init__.py
/usr/lib/python3/dist-packages/lazr/uri/_uri.py
/usr/lib/python3/dist-packages/lazr/uri/configure.zcml
/usr/lib/python3/dist-packages/lazr/uri/version.txt
/usr/lib/python3/dist-packages/lazr/uri/tests/__init__.py
/usr/lib/python3/dist-packages/lazr/uri/tests/test_docs.py
/usr/lib/python3/dist-packages/lazr/uri/tests/test_uri.py
/usr/share/doc/python3-lazr.uri/changelog.Debian.gz
/usr/share/doc/python3-lazr.uri/copyright

Changelog

2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com>
lazr.uri (1.0.3-2build1) wily; urgency=medium
* No-change rebuild for python3.5 transition
2014-06-05 - Stefano Rivera <stefanor@debian.org>
lazr.uri (1.0.3-2) unstable; urgency=low
[ Stefano Rivera ]
* Get rid of .pth files, dh_python2's namespace support is sufficient
(LP: #583426)
* Include configure.zcml (LP: #822469)
* Update watch file.
* Bump machine readable debian/copyright's format to 1.0.
* Bump Standards-Version to 3.9.5.
* Bump debhelper Build-Dep to 8.1 for build-{arch,indep}.
* Bump Copyright years.
* Port to pybuild.
* Verify upstream PGP signatures with uscan.
* Add DEP-12 upstream metadata.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2012-01-23 - Stefano Rivera <stefanor@debian.org>
lazr.uri (1.0.3-1) unstable; urgency=low
* New maintainer.
* New upstream release (Closes: #656336)
- Includes python3 support.
* Refreshed patches.
* debian/control:
- Drop Breaks: ${python:Breaks}, no longer used by dh_python2.
- Wrap and sort long lists.
* Clean egg-info.
* Removed changelog duplicate, NEWS.txt.
* debian/copyright: Converted to DEP5 machine-readable format.
* Install version.txt via package_data.
2011-04-18 - Luca Falavigna <dktrkranz@debian.org>
lazr.uri (1.0.2-5) unstable; urgency=low
* Python transition:
- Add support for python2.7
- Drop support for python2.5
* debian/control:
- Bump Standards-Version to 3.9.2, no changes required.
2011-02-14 - Luca Falavigna <dktrkranz@debian.org>
lazr.uri (1.0.2-4) unstable; urgency=low
* Upload to unstable.
2010-12-04 - Luca Falavigna <dktrkranz@debian.org>
lazr.uri (1.0.2-3) experimental; urgency=low
* Switch to dh_python2.
* debian/patches/no_package_data.patch:
- Do not install documentation files in Python module directory.
* debian/control:
- Bump Standards-Version to 3.9.1, no changes required.
* debian/docs:
- Install documentation files under /usr/share/doc.
2010-04-29 - Luca Falavigna <dktrkranz@debian.org>
lazr.uri (1.0.2-2) unstable; urgency=low
* Switch to format 3.0 (quilt).
* debian/control:
- Move myself as Maintainer, DPMT as Uploaders.
- Remove Conflicts/Replaces with python-lazr-uri, they were useful
for Ubuntu Lucid only.
- Bump Standards-Version to 3.8.4, no changes required.
* debian/rules:
- Install upstream changelog.
2009-10-17 - Luca Falavigna <dktrkranz@debian.org>
lazr.uri (1.0.2-1) unstable; urgency=low
* Initial Debian release (Closes: #532703).
* Package taken from Ubuntu, major changes introduced are:
- Switch to debhelper 7.
- Switch to python-support.
- Binary package renamed to python-lazr.uri to match module name.
2009-06-10 - James Westby <james.westby@ubuntu.com>
lazr.uri (1.0-0ubuntu1) karmic; urgency=low
* Initial release.
* Comment out "setup_requires" so that setuptools doesn't try to download
the packages there at build time.

See Also

Package Description
python3-lazy-object-proxy_1.3.1-1_amd64.deb Python 3 fast and thorough lazy object proxy
python3-ldap_3.0.0-1_amd64.deb LDAP interface module for Python3
python3-lib2to3_3.6.5-3_all.deb Interactive high-level object-oriented language (2to3, version 3.6)
python3-libapparmor_2.12-4ubuntu5_amd64.deb AppArmor library Python3 bindings
python3-libvoikko_4.1.1-1.1_all.deb Python bindings for libvoikko
python3-libxml2_2.9.4+dfsg1-6.1ubuntu1_amd64.deb Python3 bindings for the GNOME XML library
python3-linecache2_1.0.0-3_all.deb backports of the linecache module - Python 3.x
python3-logilab-common_1.4.1-1_all.deb useful miscellaneous modules used by Logilab projects (Python3)
python3-louis_3.5.0-1_all.deb Python bindings for liblouis
python3-lxml_4.2.1-1_amd64.deb pythonic binding for the libxml2 and libxslt libraries
python3-maas-client_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS python API client (Python 3)
python3-maas-provisioningserver_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS server provisioning libraries (Python 3)
python3-macaroonbakery_1.1.3-1_all.deb Higher-level macaroon operations for Python 3
python3-magic_0.4.15-1_all.deb python3 interface to the libmagic file type identification library
python3-mako_1.0.7+ds1-1_all.deb fast and lightweight templating for the Python 3 platform
Advertisement
Advertisement