python-pygments-doc_2.2.0+dfsg-1_all.deb


Advertisement

Description

python-pygments-doc - documentation for the Pygments

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-pygments-doc
Package version 2.2.0+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 1.38 KB
Download size 212.09 KB
Official Mirror archive.ubuntu.com
Pygments is syntax highlighting package.
This package contains the documentation for Pygments in HTML and
reStructuredText format.

Alternatives

Package Version Architecture Repository
python-pygments-doc_2.2.0+dfsg-1_all.deb 2.2.0+dfsg all Ubuntu Main
python-pygments-doc - - -

Requires

Name Value
libjs-sphinxdoc >= 1.0

Conflicts

Name Value
python-pygments <= 2.0~

Download

Type URL
Binary Package python-pygments-doc_2.2.0+dfsg-1_all.deb
Source Package pygments

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pygments-doc deb package:
    # sudo apt-get install python-pygments-doc

Files

Path
/usr/share/doc/python-pygments/html
/usr/share/doc/python-pygments/rst
/usr/share/doc/python-pygments-doc/AUTHORS.gz
/usr/share/doc/python-pygments-doc/TODO
/usr/share/doc/python-pygments-doc/changelog.Debian.gz
/usr/share/doc/python-pygments-doc/copyright
/usr/share/doc/python-pygments-doc/examples/markdown-processor.py
/usr/share/doc/python-pygments-doc/examples/moin-parser.py
/usr/share/doc/python-pygments-doc/examples/rst-directive.py
/usr/share/doc/python-pygments-doc/html/download.html
/usr/share/doc/python-pygments-doc/html/faq.html
/usr/share/doc/python-pygments-doc/html/genindex.html
/usr/share/doc/python-pygments-doc/html/index.html
/usr/share/doc/python-pygments-doc/html/languages.html
/usr/share/doc/python-pygments-doc/html/objects.inv
/usr/share/doc/python-pygments-doc/html/py-modindex.html
/usr/share/doc/python-pygments-doc/html/search.html
/usr/share/doc/python-pygments-doc/html/searchindex.js
/usr/share/doc/python-pygments-doc/html/_sources/download.txt
/usr/share/doc/python-pygments-doc/html/_sources/faq.txt
/usr/share/doc/python-pygments-doc/html/_sources/index.txt
/usr/share/doc/python-pygments-doc/html/_sources/languages.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/api.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/authors.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/cmdline.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/filterdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/filters.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/formatterdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/formatters.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/index.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/integrate.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/java.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/lexerdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/lexers.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/moinmoin.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/plugins.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/quickstart.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/rstdirective.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/styles.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/tokens.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/unicode.txt
/usr/share/doc/python-pygments-doc/html/_static/ajax-loader.gif
/usr/share/doc/python-pygments-doc/html/_static/basic.css
/usr/share/doc/python-pygments-doc/html/_static/classic.css
/usr/share/doc/python-pygments-doc/html/_static/comment-bright.png
/usr/share/doc/python-pygments-doc/html/_static/comment-close.png
/usr/share/doc/python-pygments-doc/html/_static/comment.png
/usr/share/doc/python-pygments-doc/html/_static/default.css
/usr/share/doc/python-pygments-doc/html/_static/doctools.js
/usr/share/doc/python-pygments-doc/html/_static/down-pressed.png
/usr/share/doc/python-pygments-doc/html/_static/down.png
/usr/share/doc/python-pygments-doc/html/_static/favicon.ico.gz
/usr/share/doc/python-pygments-doc/html/_static/file.png
/usr/share/doc/python-pygments-doc/html/_static/jquery.js
/usr/share/doc/python-pygments-doc/html/_static/logo_new.png
/usr/share/doc/python-pygments-doc/html/_static/logo_only.png
/usr/share/doc/python-pygments-doc/html/_static/minus.png
/usr/share/doc/python-pygments-doc/html/_static/plus.png
/usr/share/doc/python-pygments-doc/html/_static/pygments.css
/usr/share/doc/python-pygments-doc/html/_static/searchtools.js
/usr/share/doc/python-pygments-doc/html/_static/sidebar.js
/usr/share/doc/python-pygments-doc/html/_static/underscore.js
/usr/share/doc/python-pygments-doc/html/_static/up-pressed.png
/usr/share/doc/python-pygments-doc/html/_static/up.png
/usr/share/doc/python-pygments-doc/html/docs/api.html
/usr/share/doc/python-pygments-doc/html/docs/authors.html
/usr/share/doc/python-pygments-doc/html/docs/cmdline.html
/usr/share/doc/python-pygments-doc/html/docs/filterdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/filters.html
/usr/share/doc/python-pygments-doc/html/docs/formatterdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/formatters.html
/usr/share/doc/python-pygments-doc/html/docs/index.html
/usr/share/doc/python-pygments-doc/html/docs/integrate.html
/usr/share/doc/python-pygments-doc/html/docs/java.html
/usr/share/doc/python-pygments-doc/html/docs/lexerdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/lexers.html
/usr/share/doc/python-pygments-doc/html/docs/moinmoin.html
/usr/share/doc/python-pygments-doc/html/docs/plugins.html
/usr/share/doc/python-pygments-doc/html/docs/quickstart.html
/usr/share/doc/python-pygments-doc/html/docs/rstdirective.html
/usr/share/doc/python-pygments-doc/html/docs/styles.html
/usr/share/doc/python-pygments-doc/html/docs/tokens.html
/usr/share/doc/python-pygments-doc/html/docs/unicode.html

Changelog

2017-01-23 - Piotr Ożarowski <piotr@debian.org>
pygments (2.2.0+dfsg-1) unstable; urgency=medium
* New upstream release.
2016-05-02 - Dmitry Shachnev <mitya57@debian.org>
pygments (2.1.3+dfsg-1) unstable; urgency=medium
* Team upload.
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Dmitry Shachnev ]
* New upstream bugfix release.
2016-01-25 - Dmitry Shachnev <mitya57@debian.org>
pygments (2.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* New upstream release.
* Drop CVE-2015-8557.patch, applied upstream.
* Disable two tests that need example files, again.
* Stop setting PYTHONWARNINGS=d when running the autopkgtests, that
breaks the cmdline test which checks that process stderr is empty.
[ Piotr Ożarowski ]
* Remove /etc/bash_completion.d/pygmentize conffile in maintainer scripts
(closes: #810661)
2016-01-10 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0.1+dfsg-2) unstable; urgency=high
[ Salvatore Bonaccorso ]
* Add CVE-2015-8557.patch patch.
CVE-2015-8557: Shell injection in FontManager._get_nix_font_path.
(Closes: #802828)
[ Piotr Ożarowski ]
* debian/watch: use pypi.debian.net redirector
* install pygmentize's bash completion to
/usr/share/bash-completion/completions
2015-03-22 - Sébastien Villemot <sebastien@debian.org>
pygments (2.0.1+dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/copyright: add the missing licenses of:
- pygments/lexers/robotframework.py
- tests/dtds/HTMLspec.ent
- tests/dtds/HTMLlat1.ent
- tests/dtds/HTMLsym.ent
(Closes: #766042)
2014-11-09 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* Drop disable_example_files_test.patch, no longer needed.
* Enable verbose tests output.
[ Piotr Ożarowski ]
* New upstream release
- pygmentize no longer fails when writing UTF-8 to output files
(closes: 771724)
* Drop doc/_build from the tarball (mostly due to missing JS sources; these
files are regenerated anyway)
* Remove .pyc files from upstream tarball
* make_utf8_default patch removed, no longer needed
2014-10-19 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0~rc1.a2bc2bd+dfsg-1) unstable; urgency=medium
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Dmitry Shachnev ]
* Make autopkgtests depend on patch (to fix test failure on CI)
and python[3]-all (to run tests for all supported Python versions).
Closes: #740166.
[ Piotr Ożarowski ]
* New upstream release
- Bump X-Python-Version to 2.6
* Documentation moved to new binary package: python-pygments-doc
* Add dh-python and python-sphinx to Build-Depends
* Switch debhelper compat level to 9
* Standards-Version bumped to 3.9.6 (no changes needed)
2013-02-03 - Piotr Ożarowski <piotr@debian.org>
pygments (1.6+dfsg-1) experimental; urgency=low
* New upstream release
* fix_makefile_re.patch removed, no longer needed
* debian/watch file updated to handle rc versions correctly
2013-01-06 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-2) unstable; urgency=low
[ Dmitry Shachnev ]
* Add DEP-8 tests (closes: #693028).
* Remove unneeded build-dependency on quilt.
* Bump Standards-Version to 3.9.4.
+ Add empty build-arch target to debian/rules.
* Drop Breaks: {python:Breaks}, it is obsolete.
* debian/patches/fix_makefile_re.patch: cherry-picked upstream commit
that fixes Makefile highlighting.
2012-03-11 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-1) unstable; urgency=low
* New upstream release
* make_utf8_default patch: do not change the encoding guessing part in
pygments/lexer.py; updated to new upstream version
* debian/pygmentize no longer needed, upstream now ships the script in the
tarball (and it returns correct exit codes, closes: 628881)

See Also

Package Description
python-pygments_2.2.0+dfsg-1_all.deb syntax highlighting package written in Python
python-pyicu_1.9.8-0ubuntu1_amd64.deb Python extension wrapping the ICU C++ API
python-pyinotify-doc_0.9.6-1_all.deb simple Linux inotify Python bindings -- documentation
python-pyinotify_0.9.6-1_all.deb simple Linux inotify Python bindings
python-pylibacl-doc_0.5.3-1build2_all.deb module for manipulating POSIX.1e ACLs (documentation)
python-pylibacl_0.5.3-1build2_amd64.deb module for manipulating POSIX.1e ACLs
python-pylxd-doc_2.2.6-0ubuntu1_all.deb Python library for interacting with LXD REST API - doc
python-pylxd_2.2.6-0ubuntu1_all.deb Python library for interacting with LXD REST API
python-pymemcache_1.3.2-3_all.deb comprehensive, fast, pure Python memcached client - Python 2.x
python-pymongo-doc_3.6.1+dfsg1-1_all.deb Python interface to the MongoDB document-oriented database (documentation)
python-pymongo-ext_3.6.1+dfsg1-1_amd64.deb C-coded extension to the python-pymongo package
python-pymongo_3.6.1+dfsg1-1_amd64.deb Python interface to the MongoDB document-oriented database
python-pymysql-doc_0.8.0-1_all.deb Pure-Python MySQL driver - doc
python-pymysql_0.8.0-1_all.deb Pure-Python MySQL driver - Python 2.x
python-pyparsing-doc_2.2.0+dfsg1-2_all.deb alternative to creating and executing simple grammars - doc
Advertisement
Advertisement