python-pyeclib_1.3.1-1ubuntu3_amd64.deb


Advertisement

Description

python-pyeclib - interface for implementing erasure codes - Python 2.x

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-pyeclib
Package version 1.3.1
Package release 1ubuntu3
Package architecture amd64
Package type deb
Installed size 108 B
Download size 24.64 KB
Official Mirror archive.ubuntu.com
This library provides a simple Python interface for implementing erasure
codes. To obtain the best possible performance, the underlying erasure code
algorithms are written in C.
This library makes use of Jerasure for Reed-Solomon and provides its own flat
XOR-based erasure code encoder and decoder. Currently, it implements a
specific class of HD Combination Codes (see "Flat XOR-based erasure codes in
storage systems: Constructions, efficient recovery, and tradeoffs" in IEEE
MSST 2010). These codes are well-suited to archival use-cases, have a simple
construction and require a minimum number of participating disks during
single-disk reconstruction (think XOR-based LRC code).
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-pyeclib_1.3.1-1ubuntu3_i386.deb 1.3.1 i386 Ubuntu Main
python-pyeclib - - -

Requires

Name Value
libc6 >= 2.4
liberasurecode1 >= 1.2.0
python >= 2.7~
python << 2.8
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pyeclib_1.3.1-1ubuntu3_amd64.deb
Source Package python-pyeclib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyeclib deb package:
    # sudo apt-get install python-pyeclib

Files

Path
/usr/lib/python2.7/dist-packages/pyeclib_c.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pyeclib/__init__.py
/usr/lib/python2.7/dist-packages/pyeclib/core.py
/usr/lib/python2.7/dist-packages/pyeclib/ec_iface.py
/usr/lib/python2.7/dist-packages/pyeclib/enum.py
/usr/lib/python2.7/dist-packages/pyeclib/utils.py
/usr/lib/python2.7/dist-packages/pyeclib-1.3.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pyeclib-1.3.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pyeclib-1.3.1.egg-info/top_level.txt
/usr/share/doc/python-pyeclib/changelog.Debian.gz
/usr/share/doc/python-pyeclib/copyright

Changelog

2017-08-04 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
python-pyeclib (1.3.1-1ubuntu3) artful; urgency=medium
* No change rebuild to drop Python 3.5 support.
2017-05-12 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
python-pyeclib (1.3.1-1ubuntu2) artful; urgency=medium
* No change rebuild to add Python 3.6 support.
2016-11-22 - Chuck Short <zulcss@ubuntu.com>
python-pyeclib (1.3.1-1ubuntu1) zesty; urgency=medium
* debian/tests/control: Disable tests for ISA-L since
tests do not run on non-amd64 arches. 
2016-10-08 - Ondřej Nový <onovy@debian.org>
python-pyeclib (1.3.1-1) unstable; urgency=medium
* New upstream release
* Removed Pre-Depends on dpkg
2016-09-23 - Ondřej Nový <onovy@debian.org>
python-pyeclib (1.2.1-2) unstable; urgency=medium
* d/{control,copyright}: Use my @debian.org email address
* Fixed .gitreview file
* d/s/options: extend-diff-ignore of .gitreview
* d/control: Using OpenStack's Gerrit as VCS URLs.
2016-06-02 - Ondřej Nový <novy@ondrej.org>
python-pyeclib (1.2.1-1) unstable; urgency=medium
* New upstream release
* Upstream moved to official Openstack project
* Bump liberasurecode-dev dependency to 1.2.0 version
* Added Flat XOR HD backend to Debian test
* Print debug info in Debian test
2016-04-08 - Ondřej Nový <novy@ondrej.org>
python-pyeclib (1.2.0-2) unstable; urgency=medium
* Tests liberasure backends in Debian tests.
* Removed Suggests libjerasure2.
* Standards-Version is 3.9.8 now (no change).
2016-02-26 - Ondřej Nový <novy@ondrej.org>
python-pyeclib (1.2.0-1) unstable; urgency=medium
* New upstream release.
* Added Suggests libjerasure2.
* Added Debian tests.
* Added myself as uploader.
* Added myself to copyright file.
* Fixed Vcs URLs.
* Removed patch: disable-check-for-liberasure-code.patch
* Removed patch: more-rpath-tweak-removal.patch
* Removed install-liberasurecode=no option, it's not needed anymore.
* Fixed d/copyright.
* Standards-Version is 3.9.7 now (no change).
2015-12-11 - Thomas Goirand <zigo@debian.org>
python-pyeclib (1.1.1-2) unstable; urgency=medium
* Rebuild with liberasurecode 1.1.0.
2015-11-10 - Thomas Goirand <zigo@debian.org>
python-pyeclib (1.1.1-1) unstable; urgency=medium
* New upstream release.
* Add --install-liberasurecode=no when installing with "python setup.py
install".
* Drop version of python-all-dev build-depends.
* Dropped big-endian.patch applied upstream.
* Rebased patches:
- disable-check-for-liberasure-code.patch
- more-rpath-tweak-removal.patch
* Overrides dh_auto_install, not dh_install.

See Also

Package Description
python-pygments-doc_2.2.0+dfsg-1_all.deb documentation for the Pygments
python-pygments_2.2.0+dfsg-1_all.deb syntax highlighting package written in Python
python-pyicu_1.9.8-0ubuntu1_amd64.deb Python extension wrapping the ICU C++ API
python-pyinotify-doc_0.9.6-1_all.deb simple Linux inotify Python bindings -- documentation
python-pyinotify_0.9.6-1_all.deb simple Linux inotify Python bindings
python-pylibacl-doc_0.5.3-1build2_all.deb module for manipulating POSIX.1e ACLs (documentation)
python-pylibacl_0.5.3-1build2_amd64.deb module for manipulating POSIX.1e ACLs
python-pylxd-doc_2.2.6-0ubuntu1_all.deb Python library for interacting with LXD REST API - doc
python-pylxd_2.2.6-0ubuntu1_all.deb Python library for interacting with LXD REST API
python-pymemcache_1.3.2-3_all.deb comprehensive, fast, pure Python memcached client - Python 2.x
python-pymongo-doc_3.6.1+dfsg1-1_all.deb Python interface to the MongoDB document-oriented database (documentation)
python-pymongo-ext_3.6.1+dfsg1-1_amd64.deb C-coded extension to the python-pymongo package
python-pymongo_3.6.1+dfsg1-1_amd64.deb Python interface to the MongoDB document-oriented database
python-pymysql-doc_0.8.0-1_all.deb Pure-Python MySQL driver - doc
python-pymysql_0.8.0-1_all.deb Pure-Python MySQL driver - Python 2.x
Advertisement
Advertisement