python-psycopg2_2.7.4-1_amd64.deb


Advertisement

Description

python-psycopg2 - Python module for PostgreSQL

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-psycopg2
Package version 2.7.4
Package release 1
Package architecture amd64
Package type deb
Installed size 830 B
Download size 150.99 KB
Official Mirror archive.ubuntu.com
psycopg is a PostgreSQL database adapter for the Python programming language
(just like pygresql and popy.) This is version 2, a complete rewrite of the
original code to provide new-style classes for connection and cursor objects
and other sweet candies. Like the original, psycopg 2 was written with the
aim of being very small and fast, and stable as a rock.
psycopg is different from the other database adapter because it was designed
for heavily multi-threaded applications that create and destroy lots of
cursors and make a conspicuous number of concurrent INSERTs or UPDATEs.
psycopg 2 also provides full asynchronous operations for the really brave
programmer.
The main advantages of psycopg2 are that it supports the full Python DBAPI-2.0
and being thread safe at level 2. It also includes some extensions to the
standard DBAPI-2.0 to allow for better thread performance.

Alternatives

Package Version Architecture Repository
python-psycopg2_2.7.4-1_i386.deb 2.7.4 i386 Ubuntu Main
python-psycopg2 - - -

Requires

Name Value
libc6 >= 2.15
libpq5 >= 9.3~
python >= 2.7~
python << 2.8
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-psycopg2_2.7.4-1_amd64.deb
Source Package psycopg2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-psycopg2 deb package:
    # sudo apt-get install python-psycopg2

Files

Path
/usr/lib/python2.7/dist-packages/psycopg2-2.7.4.egg-info
/usr/lib/python2.7/dist-packages/psycopg2/__init__.py
/usr/lib/python2.7/dist-packages/psycopg2/_ipaddress.py
/usr/lib/python2.7/dist-packages/psycopg2/_json.py
/usr/lib/python2.7/dist-packages/psycopg2/_psycopg.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/psycopg2/_range.py
/usr/lib/python2.7/dist-packages/psycopg2/errorcodes.py
/usr/lib/python2.7/dist-packages/psycopg2/extensions.py
/usr/lib/python2.7/dist-packages/psycopg2/extras.py
/usr/lib/python2.7/dist-packages/psycopg2/pool.py
/usr/lib/python2.7/dist-packages/psycopg2/psycopg1.py
/usr/lib/python2.7/dist-packages/psycopg2/sql.py
/usr/lib/python2.7/dist-packages/psycopg2/tz.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/__init__.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/dbapi20.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/dbapi20_tpc.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_async.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_async_keyword.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_bugX000.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_bug_gc.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_cancel.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_connection.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_copy.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_cursor.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_dates.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_errcodes.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_extras_dictcursor.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_fast_executemany.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_green.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_ipaddress.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_lobject.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_module.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_notify.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_psycopg2_dbapi20.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_quote.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_replication.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_sql.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_transaction.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_types_basic.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_types_extras.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_with.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/testconfig.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/testutils.py
/usr/share/doc/python-psycopg2/AUTHORS
/usr/share/doc/python-psycopg2/README.rst
/usr/share/doc/python-psycopg2/changelog.Debian.gz
/usr/share/doc/python-psycopg2/copyright

Changelog

2018-02-09 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.7.4-1) unstable; urgency=medium
* New upstream release (Closes: #880651)
- Drop d/p/0002-Make-dbapi_extension.py-compatible-with-Sphinx-1.6.patch,
incorporated upstream
* Drop extra priority from -dbg packages
* Update debian/watch to use secure URI
* Clean up trailing whitespace in d/control and d/changelog
* Bump standards-version to 4.1.3 without further change
2018-01-09 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.7.3-2) unstable; urgency=medium
* d/p/0002-Make-dbapi_extension.py-compatible-with-Sphinx-1.6.patch
(Closes: #876931)
- Thanks to Corey Bryant for forwarding the patch from Ubuntu
2017-08-09 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.7.3-1) unstable; urgency=medium
* New upstream release
* Bump standards-version to 4.0.1 without further change
* Update minimum versions in X-Python{3}-Version
* Update debian/copyright
2017-06-10 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.7.1-1) unstable; urgency=medium
* New upstream release
* Refresh patches after git-dpm to gbp pq conversion
2016-07-15 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.6.2-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ SVN-Git Migration ]
* Migrate packaging to git with git-dpm
[ Scott Kitterman ]
* New upstream release
* Remove uupdate from debian/watch as it doesn't make sense for a package
maintained in git
* Bump standards version to 3.9.8 without further change
* Use default python3 build to generate documentation
* Bump debhelper minimum version and compat to 9
2015-06-22 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.6.1-1) unstable; urgency=medium
* New upstream release
- Improve documentation regarding use of extensions.
ISOLATION_LEVEL_AUTOCOMMIT (Closes: #768194)
2015-04-24 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.6-2) unstable; urgency=medium
* Upload to unstable
* Build docs using python3 vice python
* Add doc-base registration
2015-02-09 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.6-1) experimental; urgency=medium
* New upstream release
- Adapt debian/rules build-indep and binary targets  as well as
python-psycopg2-doc.install for adjustments in upstream documentation
build system
* Add dh-python to build-depends
* Update debian/watch to use the new pypi.debian.net redirector so that new
releases are detected and to account for no longer needing to mangle the
version since a +dfsg tarball is no longer required
2014-09-27 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.5.4+dfsg-1) unstable; urgency=medium
* New upstream release
- Repack source tarball to remove minified javascript files
* Swap DPMT to maintainer and add myself to uploaders
* Drop obsolete and unused python:Provides
* Add appropriate X-Python{3}-Version fields to debian/control
* Bump standards version to 3.9.6 without further change
* Install NEWS using dh_installchangelogs to install as upstream changelog
* Update debian/copyright
* Update debian/README.source list of files that need to be removed to
create a DFSG free tarball
* Drop obsolete python-psycopg2-doc breaks/replaces python-psycopg2-docs
2014-05-26 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.5.3+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream release
* Correct python-psycopg2-doc install location (Closes: #686741)
* Update debian/copyright
* Repack source tarball to remove minified javascript files
- Update debian/watch to unmangle upstream version

See Also

Package Description
python-pyasn1-doc_0.4.2-3_all.deb ASN.1 library for Python (documentation)
python-pyasn1-modules_0.2.1-0.2_all.deb Collection of protocols modules written in ASN.1 language
python-pyasn1_0.4.2-3_all.deb ASN.1 library for Python (Python 2 module)
python-pycadf_2.7.0-0ubuntu1_all.deb implementation of DMTF Cloud Audit (CADF) data model - Python 2.7
python-pycparser_2.18-2_all.deb C parser in Python
python-pycryptodome-doc_3.4.7-1ubuntu1_all.deb cryptographic Python library (documentation)
python-pycryptodome_3.4.7-1ubuntu1_amd64.deb cryptographic Python library (Python 2)
python-pycurl-doc_7.43.0.1-0.2_all.deb Python bindings to libcurl (documentation)
python-pycurl_7.43.0.1-0.2_amd64.deb Python bindings to libcurl
python-pyeclib_1.3.1-1ubuntu3_amd64.deb interface for implementing erasure codes - Python 2.x
python-pygments-doc_2.2.0+dfsg-1_all.deb documentation for the Pygments
python-pygments_2.2.0+dfsg-1_all.deb syntax highlighting package written in Python
python-pyicu_1.9.8-0ubuntu1_amd64.deb Python extension wrapping the ICU C++ API
python-pyinotify-doc_0.9.6-1_all.deb simple Linux inotify Python bindings -- documentation
python-pyinotify_0.9.6-1_all.deb simple Linux inotify Python bindings
Advertisement
Advertisement