python-parsedatetime_2.4-2_all.deb


Advertisement

Description

python-parsedatetime - Python module to parse human-readable date/time expressions

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-parsedatetime
Package version 2.4
Package release 2
Package architecture all
Package type deb
Installed size 178 B
Download size 31.53 KB
Official Mirror archive.ubuntu.com
parsedatetime is able to parse, for example, the following:
* August 25th, 2008
* 25 Aug 2008
* Aug 25 5pm
* 5pm August 25
* next saturday
* tomorrow
* next thursday at 4pm
* at 4pm
* eod
* tomorrow eod
* eod tuesday
* eoy
* eom
* in 5 minutes
* 5 minutes from now
* 5 hours before now
* 2 hours before noon
* 2 days from tomorrow
This package provides the modules for Python 2.

Alternatives

Package Version Architecture Repository
python-parsedatetime_2.4-2_all.deb 2.4 all Ubuntu Main
python-parsedatetime - - -

Requires

Name Value
python-future -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-parsedatetime_2.4-2_all.deb
Source Package parsedatetime

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-parsedatetime deb package:
    # sudo apt-get install python-parsedatetime

Files

Path
/usr/lib/python2.7/dist-packages/parsedatetime/__init__.py
/usr/lib/python2.7/dist-packages/parsedatetime/context.py
/usr/lib/python2.7/dist-packages/parsedatetime/parsedatetime.py
/usr/lib/python2.7/dist-packages/parsedatetime/warns.py
/usr/lib/python2.7/dist-packages/parsedatetime-2.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/parsedatetime-2.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/parsedatetime-2.4.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/parsedatetime-2.4.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/parsedatetime-2.4.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/__init__.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/base.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/de_DE.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/en_AU.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/en_US.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/es.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/fr_FR.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/icu.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/nl_NL.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/pt_BR.py
/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales/ru_RU.py
/usr/share/doc/python-parsedatetime/AUTHORS.txt
/usr/share/doc/python-parsedatetime/README.rst
/usr/share/doc/python-parsedatetime/changelog.Debian.gz
/usr/share/doc/python-parsedatetime/copyright

Changelog

2017-07-17 - Ghislain Antony Vaillant <ghisvail@gmail.com>
parsedatetime (2.4-2) unstable; urgency=medium
* Team upload
[ Ghislain Antony Vaillant ]
* Update the gbp configuration
* Remove superfluous ${shlibs:Depends}
* Release to unstable
2017-07-12 - Ghislain Antony Vaillant <ghisvail@gmail.com>
parsedatetime (2.4-1) experimental; urgency=medium
* Team upload
[ Ghislain Antony Vaillant ]
* Upgrade watch file to version 4
* New upstream version 2.4
* Drop the patch queue, no longer required
* Add support for the nocheck build profile
* Normalize the Vcs-Browser URI
* Upgrade copyright to format 1.0
* Bump debhelper version to 10, no changes required
* Bump standards version to 4.0.0, no changes required
* Fixup the DEP-8 tests
2017-03-11 - Ghislain Antony Vaillant <ghisvail@gmail.com>
parsedatetime (2.3-1) experimental; urgency=medium
* Team upload
[ Harlan Lieberman-Berg ]
* New upstream version 2.3 (Closes: #717991)
[ Ghislain Antony Vaillant ]
* Switch from git-dpm to gbp
* Drop the patch queue, applied upstream
* cme fix dpkg-control
- Drop versioned b-dep on python-all
- Bump Standards-Version to 3.9.8, no changes required
- Drop versioned i-dep on base-files
- Overall reordering of fields, wrap and sort
* Replace b-dep on nose by pytest and pytest-runner
* Ensure only test targets require pytest-runner
- New patch Conditional-requirement-on-pytest-runner.patch
* Add the necessary test args for pybuild
* Support the non-standard pytest config used upstream
- New patch Add-upstream-pytest-configuration.patch
* Build binary packages for Python 3.
Thanks to Paul Tagliamonte for reporting (Closes: #782926)
* Add autopkgtests running the upstream test suite
2017-03-11 - Brian May <bam@debian.org>
parsedatetime (2.1-3) unstable; urgency=medium
* Add patch to fix FTBFS error after February. Closes: #856625.
2016-09-28 - Tristan Seligmann <mithrandi@debian.org>
parsedatetime (2.1-2) unstable; urgency=medium
* Team upload.
* python_distutils buildsystem was being autodetected previously, but
now makefile is autodetected; select pybuild explicitly instead as
this will run the tests for us automatically (closes: #838881).
* Add dh-python to Build-Depends.
2016-09-25 - Bernd Zeimetz <bzed@debian.org>
parsedatetime (2.1-1) unstable; urgency=medium
[ SVN-Git Migration ]
* [c93b4f5] Initialize git-dpm
* [acb4987] git-dpm config
* [0cc61ed] Update Vcs fields for git migration
[ Ondřej Nový ]
* [185f2b8] Fixed VCS URL (https)
[ Bernd Zeimetz ]
* [1e12a2f] Merge tag 'upstream/2.1'
Upstream version 2.1
* [8da7518] THANKS.txt was removed.
* [42a8b28] depend on python-nose for nosetest.
2014-10-05 - Bernd Zeimetz <bzed@debian.org>
parsedatetime (1.4-1) unstable; urgency=medium
* New upstream version 
* Add python-setuptools as build-dependency
* Use README.rst instead of README.md
2014-06-02 - Jackson Doak <noskcaj@ubuntu.com>
parsedatetime (1.2-1) unstable; urgency=medium
* Team upload.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Jackson Doak ]
* Sync from ubuntu. Closes: #485054 #717991
* Bump standards-version to 3.9.5 (no changes)
* Use dh and debhelper 9 for building
[ Vincent Cheng ]
* Remove obsolete patches.
2014-05-31 - Jackson Doak <noskcaj@ubuntu.com>
parsedatetime (1.2-0ubuntu1) utopic; urgency=medium
* New upstream release. LP: #1302963
* Drop use of dpatch
2014-01-14 - Matthias Klose <doko@ubuntu.com>
parsedatetime (1.1.2-0ubuntu1) trusty; urgency=medium
* New upstream version.
* Build using source format 3.

See Also

Package Description
python-passlib_1.7.1-1_all.deb comprehensive password hashing framework
python-paste-doc_2.0.3+dfsg-4ubuntu1_all.deb tools for using a Web Server Gateway Interface stack - documentation
python-paste_2.0.3+dfsg-4ubuntu1_all.deb tools for using a Web Server Gateway Interface stack - Python 2.x
python-pastedeploy-tpl_1.5.2-4_all.deb load, configure, and compose WSGI applications and servers - templates
python-pastedeploy_1.5.2-4_all.deb load, configure, and compose WSGI applications and servers - Python 2.x
python-pastescript-doc_2.0.2-2_all.deb create file layouts for packages and serve webapps - documentation
python-pastescript_2.0.2-2_all.deb create file layouts for Python packages and serve webapps
python-pathlib-doc_1.0.1-2_all.deb set of Python 2 classes to handle filesystem paths (Documentation)
python-pathlib_1.0.1-2_all.deb set of Python 2 classes to handle filesystem paths
python-pbr-doc_3.1.1-3ubuntu3_all.deb inject useful and sensible default behaviors into setuptools - doc
python-pbr_3.1.1-3ubuntu3_all.deb inject useful and sensible default behaviors into setuptools - Python 2.x
python-pecan-doc_1.2.1-2_all.deb WSGI object-dispatching web framework
python-pecan_1.2.1-2_all.deb WSGI object-dispatching web framework - Python 2.x
python-pexpect-doc_4.2.1-1_all.deb Python module for automating interactive applications (documentation)
python-pika-doc_0.11.0-1_all.deb AMQP client library documentation
Advertisement
Advertisement