python-oslo.middleware_3.34.0-0ubuntu1_all.deb


Advertisement

Description

python-oslo.middleware - various WSGI middleware components for OpenStack - Python 2.x

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-oslo.middleware
Package version 3.34.0
Package release 0ubuntu1
Package architecture all
Package type deb
Installed size 222 B
Download size 29.85 KB
Official Mirror archive.ubuntu.com
The oslo.middleware library contains various functions and methods used by
the OpenStack projects that are using the WSGI pipeline.
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-oslo.middleware_3.34.0-0ubuntu1_all.deb 3.34.0 all Ubuntu Main
python-oslo.middleware - - -

Requires

Name Value
python-debtcollector >= 1.2.0
python-jinja2 >= 2.8
python-oslo.config >= 1:5.1.0
python-oslo.context >= 2.19.2
python-oslo.i18n >= 3.15.3
python-oslo.utils >= 3.33.0
python-pbr >= 2.0.0
python-six >= 1.10.0
python-statsd >= 3.2.1
python-stevedore >= 1.20.0
python-webob >= 1.7.1
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-oslo.middleware_3.34.0-0ubuntu1_all.deb
Source Package python-oslo.middleware

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-oslo.middleware deb package:
    # sudo apt-get install python-oslo.middleware

Files

Path
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/oslo.middleware-3.34.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/oslo_middleware/__init__.py
/usr/lib/python2.7/dist-packages/oslo_middleware/_i18n.py
/usr/lib/python2.7/dist-packages/oslo_middleware/base.py
/usr/lib/python2.7/dist-packages/oslo_middleware/catch_errors.py
/usr/lib/python2.7/dist-packages/oslo_middleware/correlation_id.py
/usr/lib/python2.7/dist-packages/oslo_middleware/cors.py
/usr/lib/python2.7/dist-packages/oslo_middleware/debug.py
/usr/lib/python2.7/dist-packages/oslo_middleware/http_proxy_to_wsgi.py
/usr/lib/python2.7/dist-packages/oslo_middleware/opts.py
/usr/lib/python2.7/dist-packages/oslo_middleware/request_id.py
/usr/lib/python2.7/dist-packages/oslo_middleware/sizelimit.py
/usr/lib/python2.7/dist-packages/oslo_middleware/ssl.py
/usr/lib/python2.7/dist-packages/oslo_middleware/stats.py
/usr/lib/python2.7/dist-packages/oslo_middleware/version.py
/usr/lib/python2.7/dist-packages/oslo_middleware/healthcheck/__init__.py
/usr/lib/python2.7/dist-packages/oslo_middleware/healthcheck/__main__.py
/usr/lib/python2.7/dist-packages/oslo_middleware/healthcheck/disable_by_file.py
/usr/lib/python2.7/dist-packages/oslo_middleware/healthcheck/opts.py
/usr/lib/python2.7/dist-packages/oslo_middleware/healthcheck/pluginbase.py
/usr/lib/python2.7/dist-packages/oslo_middleware/locale/de/LC_MESSAGES/oslo_middleware.po
/usr/lib/python2.7/dist-packages/oslo_middleware/locale/en_GB/LC_MESSAGES/oslo_middleware.po
/usr/lib/python2.7/dist-packages/oslo_middleware/locale/fr/LC_MESSAGES/oslo_middleware.po
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/__init__.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_base.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_catch_errors.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_correlation_id.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_cors.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_entry_points.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_healthcheck.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_http_proxy_to_wsgi.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_opts.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_request_id.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_sizelimit.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_ssl.py
/usr/lib/python2.7/dist-packages/oslo_middleware/tests/test_stats.py
/usr/share/doc/python-oslo.middleware/changelog.Debian.gz
/usr/share/doc/python-oslo.middleware/copyright

Changelog

2018-01-26 - James Page <james.page@ubuntu.com>
python-oslo.middleware (3.34.0-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
* d/control: Align (Build-)Depends with upstream.
2017-12-08 - James Page <james.page@ubuntu.com>
python-oslo.middleware (3.33.0-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
* d/control: Align (Build-)Depends with upstream.
* d/control: Bumped Standards-Version to 4.1.2.
* d/p/drop-openstackdoctheme.patch: Drop, no longer required.
2017-11-13 - James Page <james.page@ubuntu.com>
python-oslo.middleware (3.32.1-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
* d/control: Align (Build-)Depends with upstream.
* d/p/fix-parsing-of-forwarded-header.patch: Drop, fixed upstream.
2017-09-22 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.middleware (3.30.0-0ubuntu1.1) artful; urgency=medium
* d/p/fix-parsing-of-forwarded-header.patch: Fix invalid parsing of
forwarded header (LP: #1711573).
2017-08-11 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.middleware (3.30.0-0ubuntu1) artful; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/p/drop-openstackdoctheme.patch: Temporarily drop openstackdocstheme
sphinx extension until sphinx>=1.6.2 is available.
2017-06-02 - James Page <james.page@ubuntu.com>
python-oslo.middleware (3.27.0-0ubuntu1) artful; urgency=medium
* New upstream release.
* d/control: Drop Breaks/Replaces with oslo-middleware.
* d/control: Align (build-)depends with upstream.
2017-04-21 - James Page <james.page@ubuntu.com>
python-oslo.middleware (3.26.0-0ubuntu1) artful; urgency=medium
[ Chuck Short ]
* New upstream release.
* d/control: Align (build-)depends with upstream.
[ James Page ]
* d/watch: Use tarballs.openstack.org.
* New upstream release.
* d/control: Align (build-)depends with upstream.
2017-02-01 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.middleware (3.23.1-0ubuntu1) zesty; urgency=medium
* New upstream release.
2017-01-19 - Chuck Short <zulcss@ubuntu.com>
python-oslo.middleware (3.23.0-0ubuntu1) zesty; urgency=medium
* New upstream release.
* d/control: Align (build-)depends with upstream.
2016-12-07 - Chuck Short <zulcss@ubuntu.com>
python-oslo.middleware (3.22.0-0ubuntu1) zesty; urgency=medium
* New upstream version.

See Also

Package Description
python-oslo.policy-doc_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - doc
python-oslo.policy_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - Python 2.x
python-oslo.privsep-doc_1.27.0-0ubuntu3_all.deb OpenStack library for privilege separation - doc
python-oslo.privsep_1.27.0-0ubuntu3_all.deb OpenStack library for privilege separation - Python 2.7
python-oslo.reports-doc_1.26.0-0ubuntu1_all.deb reports serialized in various data types - doc
python-oslo.reports_1.26.0-0ubuntu1_all.deb reports serialized in various data types - Python 2.7
python-oslo.rootwrap_5.13.0-0ubuntu1_all.deb allows fine filtering of shell commands to run as root - Python 2.x
python-oslo.serialization-doc_2.24.0-0ubuntu2_all.deb utilities for serialization , especially JSON - doc
python-oslo.serialization_2.24.0-0ubuntu2_all.deb utilities for serialization , especially JSON - Python 2.x
python-oslo.service-doc_1.29.0-0ubuntu1_all.deb library for running OpenStack services - doc
python-oslo.service_1.29.0-0ubuntu1_all.deb library for running OpenStack services - Python 2.x
python-oslo.utils-doc_3.35.0-0ubuntu1_all.deb Oslo Utility library - doc
python-oslo.utils_3.35.0-0ubuntu1_all.deb set of utility functions for OpenStack - Python 2.x
python-oslo.versionedobjects-doc_1.31.2-0ubuntu3_all.deb deals with DB schema versions and code expectations - doc
python-oslo.versionedobjects_1.31.2-0ubuntu3_all.deb deals with DB schema versions and code expectations - Python 2.x
Advertisement
Advertisement