python-oslo.config_5.2.0-0ubuntu1_all.deb


Advertisement

Description

python-oslo.config - Common code for Openstack Projects (configuration API) - Python 2.x

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-oslo.config
Package version 5.2.0
Package release 0ubuntu1
Package architecture all
Package type deb
Installed size 626 B
Download size 77.79 KB
Official Mirror archive.ubuntu.com
The OpenStack Oslo project provides Python libraries containing
infrastructure code shared by OpenStack projects.
The OpenStack Oslo Configuration API supports parsing command line
arguments and .ini style configuration files.
This package provides the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-oslo.config_5.2.0-0ubuntu1_all.deb 5.2.0 all Ubuntu Main
python-oslo.config - - -

Requires

Name Value
python-debtcollector -
python-docutils -
python-netaddr >= 0.7.18
python-oslo.i18n >= 3.15.3
python-pbr >= 2.0.0
python-rfc3986 -
python-six >= 1.10.0
python-stevedore >= 1.20.0
python-yaml -
python2.7:any -
python:any << 2.8
python:any >= 2.7.5-5~

Replaces

Name Value
python-oslo.config >= 1:4.6.0

Download

Type URL
Binary Package python-oslo.config_5.2.0-0ubuntu1_all.deb
Source Package python-oslo.config

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-oslo.config deb package:
    # sudo apt-get install python-oslo.config

Files

Path
/usr/bin/python2-oslo-config-generator
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/oslo.config-5.2.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/oslo_config/__init__.py
/usr/lib/python2.7/dist-packages/oslo_config/_i18n.py
/usr/lib/python2.7/dist-packages/oslo_config/_list_opts.py
/usr/lib/python2.7/dist-packages/oslo_config/cfg.py
/usr/lib/python2.7/dist-packages/oslo_config/cfgfilter.py
/usr/lib/python2.7/dist-packages/oslo_config/fixture.py
/usr/lib/python2.7/dist-packages/oslo_config/generator.py
/usr/lib/python2.7/dist-packages/oslo_config/iniparser.py
/usr/lib/python2.7/dist-packages/oslo_config/sphinxconfiggen.py
/usr/lib/python2.7/dist-packages/oslo_config/sphinxext.py
/usr/lib/python2.7/dist-packages/oslo_config/types.py
/usr/lib/python2.7/dist-packages/oslo_config/version.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/__init__.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_cfg.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_cfgfilter.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_fixture.conf
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_fixture.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_generator.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_iniparser.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_sphinxconfiggen.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_sphinxext.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/test_types.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/__init__.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/bar_foo_opt.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/baz_qux_opt.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/blaa_opt.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/fbaar_baa_opt.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/fbar_foo_opt.py
/usr/lib/python2.7/dist-packages/oslo_config/tests/testmods/fblaa_opt.py
/usr/share/doc/python-oslo.config/changelog.Debian.gz
/usr/share/doc/python-oslo.config/copyright

Changelog

2018-01-26 - James Page <james.page@ubuntu.com>
python-oslo.config (1:5.2.0-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
2017-12-08 - James Page <james.page@ubuntu.com>
python-oslo.config (1:5.1.0-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
* d/control: Align (Build-)Depends with upstream.
2017-11-13 - James Page <james.page@ubuntu.com>
python-oslo.config (1:5.0.0-0ubuntu1) bionic; urgency=medium
* New upstream release for OpenStack Queens.
2017-11-02 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.config (1:4.11.0-4ubuntu1) bionic; urgency=medium
* Merge from Debian unstable, remaining changes:
- d/gbp.conf: Retain git-buildpackage config, including use of pristine-tar.
- d/control: Retain Breaks/Replaces.
- debian/watch: Use tarballs.openstack.org.
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-oslo.config (1:4.11.0-4) unstable; urgency=medium
* Uploading to unstable.
2017-10-26 - Thomas Goirand <zigo@debian.org>
python-oslo.config (1:4.11.0-3) experimental; urgency=medium
* Add missing b-d on python-openstackdocstheme (Closes: #877618).
* Fixed watch file.
* Standards-Version is now 4.1.1.
2017-10-01 - Thomas Goirand <zigo@debian.org>
python-oslo.config (1:4.11.0-2) experimental; urgency=medium
* Add missing build-depends: python{3,}-oslotest (Closes: #877253).
2017-08-04 - Thomas Goirand <zigo@debian.org>
python-oslo.config (1:4.11.0-1) experimental; urgency=medium
[ Ondřej Nový ]
* Bumped debhelper compat version to 10
[ Thomas Goirand ]
* New upstream release.
* Reviewed (build-)depends for this release.
* test-config-dir-doesnt-exist.patch applied upstream.
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Running wrap-and-sort -bast.
* Updating maintainer field.
* Updating standards version to 4.0.0.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Correcting permissions in debian packaging files.
* Updating standards version to 4.0.1.
* Updating standards version to 4.1.0.
2017-07-28 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.config (1:4.11.0-0ubuntu1) artful; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/p/drop-openstackdoctheme.patch: Temporarily drop openstackdocstheme
sphinx extension until sphinx>=1.6.2 is available.
2017-07-06 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.config (1:4.3.0-0ubuntu1) artful; urgency=medium
* New upstream release.

See Also

Package Description
python-oslo.context-doc_2.20.0-0ubuntu1_all.deb WSGI context helpers for OpenStack - doc
python-oslo.context_2.20.0-0ubuntu1_all.deb WSGI context helpers for OpenStack - Python 2.x
python-oslo.db-doc_4.33.0-0ubuntu1_all.deb database connectivity to the different backends and helper utils - doc
python-oslo.db_4.33.0-0ubuntu1_all.deb database connectivity to the different backends and helper utils - Python 2.x
python-oslo.i18n-doc_3.19.0-0ubuntu1_all.deb Oslo Internationalization Utilities - doc
python-oslo.i18n_3.19.0-0ubuntu1_all.deb Oslo Internationalization Utilities - Python 2.x
python-oslo.log-doc_3.36.0-0ubuntu1_all.deb OpenStack logging configuration library - doc
python-oslo.log_3.36.0-0ubuntu1_all.deb OpenStack logging configuration library - Python 2.x
python-oslo.messaging_5.35.0-0ubuntu1_all.deb oslo messaging library - Python 2.x
python-oslo.middleware-doc_3.34.0-0ubuntu1_all.deb various WSGI middleware components for OpenStack - doc
python-oslo.middleware_3.34.0-0ubuntu1_all.deb various WSGI middleware components for OpenStack - Python 2.x
python-oslo.policy-doc_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - doc
python-oslo.policy_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - Python 2.x
python-oslo.privsep-doc_1.27.0-0ubuntu3_all.deb OpenStack library for privilege separation - doc
python-oslo.privsep_1.27.0-0ubuntu3_all.deb OpenStack library for privilege separation - Python 2.7
Advertisement
Advertisement