python-oslo.concurrency_3.25.0-0ubuntu1_all.deb


Advertisement

Description

python-oslo.concurrency - concurrency and locks for OpenStack projects - Python 2.x

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-oslo.concurrency
Package version 3.25.0
Package release 0ubuntu1
Package architecture all
Package type deb
Installed size 161 B
Download size 27.65 KB
Official Mirror archive.ubuntu.com
The oslo.concurrency library provides solutions for managing concurrency and
locks within OpenStack projects.
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-oslo.concurrency_3.25.0-0ubuntu1_all.deb 3.25.0 all Ubuntu Main
python-oslo.concurrency - - -

Requires

Name Value
python-concurrent.futures >= 3.0.0
python-enum34 >= 1.0.4
python-fasteners >= 0.7.0
python-fixtures -
python-oslo.config >= 1:5.1.0
python-oslo.i18n >= 3.15.3
python-oslo.utils >= 3.33.0
python-pbr >= 2.0.0
python-posix-ipc -
python-six >= 1.10.0
python2.7:any -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-oslo.concurrency_3.25.0-0ubuntu1_all.deb
Source Package python-oslo.concurrency

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-oslo.concurrency deb package:
    # sudo apt-get install python-oslo.concurrency

Files

Path
/usr/bin/python2-lockutils-wrapper
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/oslo.concurrency-3.25.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/oslo_concurrency/__init__.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/_i18n.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/opts.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/prlimit.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/processutils.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/version.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/watchdog.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/fixture/__init__.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/fixture/lockutils.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/locale/de/LC_MESSAGES/oslo_concurrency.po
/usr/lib/python2.7/dist-packages/oslo_concurrency/locale/en_GB/LC_MESSAGES/oslo_concurrency.po
/usr/lib/python2.7/dist-packages/oslo_concurrency/locale/es/LC_MESSAGES/oslo_concurrency.po
/usr/lib/python2.7/dist-packages/oslo_concurrency/locale/fr/LC_MESSAGES/oslo_concurrency.po
/usr/lib/python2.7/dist-packages/oslo_concurrency/tests/__init__.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/tests/unit/__init__.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/tests/unit/test_lockutils.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/tests/unit/test_lockutils_eventlet.py
/usr/lib/python2.7/dist-packages/oslo_concurrency/tests/unit/test_processutils.py
/usr/share/doc/python-oslo.concurrency/changelog.Debian.gz
/usr/share/doc/python-oslo.concurrency/copyright

Changelog

2018-01-24 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.25.0-0ubuntu1) bionic; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/control: Update Standards-Version to 4.1.2.
* d/control: Bump debhelper compat to 10.
2017-11-13 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.23.0-0ubuntu1) bionic; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/control: Drop Breaks/Replaces. No longer needed.
2017-11-02 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.21.0-2ubuntu1) bionic; urgency=medium
* Merge from Debian unstable, remaining changes:
- d/rules: Run all tests.
- d/control: Retain Breaks/Replaces.
- d/gbp.conf: Retain git-buildpackage config, including use of pristine-tar.
- d/p/lock-path-tempfile.patch: Cherry picked from upstream to set default
of lock_file to a tempfile if OSLO_LOCK_PATH isn't set (LP: #1550188).
- d/p/fix-tests-i386.patch: Fix tests that fail on i386 builds.
- d/watch: Use tarballs.openstack.org.
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-oslo.concurrency (3.21.0-2) unstable; urgency=medium
* Disable some unit tests failing on i386 (Closes: #880227).
* Using pkgos-dh_auto_test.
* Watch file using https.
* Standards-Version is now 4.1.1.
* Using pkgos-dh_auto_install.
* Uploading to unstable.
2017-08-04 - Thomas Goirand <zigo@debian.org>
python-oslo.concurrency (3.21.0-1) experimental; urgency=medium
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
* Removed all patches: either not relevant or applied upstream.
* debian/gbp.conf to use debian/pike as packaging branch.
* Removed now useless transition packages.
* Fixed debian/copyright holders.
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Running wrap-and-sort -bast.
* Updating maintainer field.
* Updating standards version to 4.0.0.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Correcting permissions in debian packaging files.
* Updating standards version to 4.0.1.
* Deprecating priority extra as per policy 4.0.1.
* Updating standards version to 4.1.0.
2017-08-15 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.21.0-0ubuntu2) artful; urgency=medium
* d/control: Fix typo for python3-oslo.i18n.
2017-08-11 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.21.0-0ubuntu1) artful; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/p/drop-openstackdoctheme.patch: Temporarily drop openstackdocstheme
sphinx extension until sphinx>=1.6.2 is available.
2017-04-21 - James Page <james.page@ubuntu.com>
python-oslo.concurrency (3.20.0-0ubuntu1) artful; urgency=medium
[ Chuck Short ]
* New upstream release.
* d/control: Align (build-)depends with upstream.
[ James Page ]
* d/watch: Use tarballs.openstack.org.
2017-01-19 - Corey Bryant <corey.bryant@canonical.com>
python-oslo.concurrency (3.18.0-0ubuntu1) zesty; urgency=medium
* New upstream release.
2017-01-13 - Chuck Short <zulcss@ubuntu.com>
python-oslo.concurrency (3.17.0-0ubuntu1) zesty; urgency=medium
* New upstream version.
* debian/control: Add autopkgtest.

See Also

Package Description
python-oslo.config-doc_5.2.0-0ubuntu1_all.deb Common code for Openstack Projects (configuration API) - doc
python-oslo.config_5.2.0-0ubuntu1_all.deb Common code for Openstack Projects (configuration API) - Python 2.x
python-oslo.context-doc_2.20.0-0ubuntu1_all.deb WSGI context helpers for OpenStack - doc
python-oslo.context_2.20.0-0ubuntu1_all.deb WSGI context helpers for OpenStack - Python 2.x
python-oslo.db-doc_4.33.0-0ubuntu1_all.deb database connectivity to the different backends and helper utils - doc
python-oslo.db_4.33.0-0ubuntu1_all.deb database connectivity to the different backends and helper utils - Python 2.x
python-oslo.i18n-doc_3.19.0-0ubuntu1_all.deb Oslo Internationalization Utilities - doc
python-oslo.i18n_3.19.0-0ubuntu1_all.deb Oslo Internationalization Utilities - Python 2.x
python-oslo.log-doc_3.36.0-0ubuntu1_all.deb OpenStack logging configuration library - doc
python-oslo.log_3.36.0-0ubuntu1_all.deb OpenStack logging configuration library - Python 2.x
python-oslo.messaging_5.35.0-0ubuntu1_all.deb oslo messaging library - Python 2.x
python-oslo.middleware-doc_3.34.0-0ubuntu1_all.deb various WSGI middleware components for OpenStack - doc
python-oslo.middleware_3.34.0-0ubuntu1_all.deb various WSGI middleware components for OpenStack - Python 2.x
python-oslo.policy-doc_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - doc
python-oslo.policy_1.33.1-0ubuntu1_all.deb RBAC policy enforcement library for OpenStack - Python 2.x
Advertisement
Advertisement