python-openid_2.2.5-6_all.deb


Advertisement

Description

python-openid - OpenID support for servers and consumers

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-openid
Package version 2.2.5
Package release 6
Package architecture all
Package type deb
Installed size 484 B
Download size 95.51 KB
Official Mirror archive.ubuntu.com
Set of Python packages to support use of the OpenID decentralized
identity system in your application, both server- and client-side,
including:
- OpenID 1.0, 1.1 and 2.0 support,
- SReg support,
- several storage implementations for stateful OpenID authentication.

Alternatives

Package Version Architecture Repository
python-openid_2.2.5-6_all.deb 2.2.5 all Ubuntu Main
python-openid - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-openid_2.2.5-6_all.deb
Source Package python-openid

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-openid deb package:
    # sudo apt-get install python-openid

Files

Path
/usr/lib/python2.7/dist-packages/python_openid-2.2.5.egg-info
/usr/lib/python2.7/dist-packages/openid/__init__.py
/usr/lib/python2.7/dist-packages/openid/association.py
/usr/lib/python2.7/dist-packages/openid/cryptutil.py
/usr/lib/python2.7/dist-packages/openid/dh.py
/usr/lib/python2.7/dist-packages/openid/extension.py
/usr/lib/python2.7/dist-packages/openid/fetchers.py
/usr/lib/python2.7/dist-packages/openid/kvform.py
/usr/lib/python2.7/dist-packages/openid/message.py
/usr/lib/python2.7/dist-packages/openid/oidutil.py
/usr/lib/python2.7/dist-packages/openid/sreg.py
/usr/lib/python2.7/dist-packages/openid/urinorm.py
/usr/lib/python2.7/dist-packages/openid/consumer/__init__.py
/usr/lib/python2.7/dist-packages/openid/consumer/consumer.py
/usr/lib/python2.7/dist-packages/openid/consumer/discover.py
/usr/lib/python2.7/dist-packages/openid/consumer/html_parse.py
/usr/lib/python2.7/dist-packages/openid/extensions/__init__.py
/usr/lib/python2.7/dist-packages/openid/extensions/ax.py
/usr/lib/python2.7/dist-packages/openid/extensions/sreg.py
/usr/lib/python2.7/dist-packages/openid/extensions/draft/__init__.py
/usr/lib/python2.7/dist-packages/openid/extensions/draft/pape2.py
/usr/lib/python2.7/dist-packages/openid/extensions/draft/pape5.py
/usr/lib/python2.7/dist-packages/openid/server/__init__.py
/usr/lib/python2.7/dist-packages/openid/server/server.py
/usr/lib/python2.7/dist-packages/openid/server/trustroot.py
/usr/lib/python2.7/dist-packages/openid/store/__init__.py
/usr/lib/python2.7/dist-packages/openid/store/filestore.py
/usr/lib/python2.7/dist-packages/openid/store/interface.py
/usr/lib/python2.7/dist-packages/openid/store/memstore.py
/usr/lib/python2.7/dist-packages/openid/store/nonce.py
/usr/lib/python2.7/dist-packages/openid/store/sqlstore.py
/usr/lib/python2.7/dist-packages/openid/yadis/__init__.py
/usr/lib/python2.7/dist-packages/openid/yadis/accept.py
/usr/lib/python2.7/dist-packages/openid/yadis/constants.py
/usr/lib/python2.7/dist-packages/openid/yadis/discover.py
/usr/lib/python2.7/dist-packages/openid/yadis/etxrd.py
/usr/lib/python2.7/dist-packages/openid/yadis/filters.py
/usr/lib/python2.7/dist-packages/openid/yadis/manager.py
/usr/lib/python2.7/dist-packages/openid/yadis/parsehtml.py
/usr/lib/python2.7/dist-packages/openid/yadis/services.py
/usr/lib/python2.7/dist-packages/openid/yadis/xri.py
/usr/lib/python2.7/dist-packages/openid/yadis/xrires.py
/usr/share/doc/python-openid/NEWS.gz
/usr/share/doc/python-openid/NOTICE
/usr/share/doc/python-openid/README
/usr/share/doc/python-openid/changelog.Debian.gz
/usr/share/doc/python-openid/copyright

Changelog

2014-09-02 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-6) unstable; urgency=low
* Fixing changelog of previous botched release
(wrong .changes file got uploaded).
2014-08-31 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-5) unstable; urgency=medium
* Errorneous release.
2014-08-31 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-4) unstable; urgency=low
[ Mikhail Gusarov ]
* Fix version reported in openid.__version__ (Closes: #754774).
* Fix openid.sqlstore crash with long nonce (Closes: #704698).
* Switch to dh_python2 from python-support (suggested by Lintian).
* Bump Standards-Version, no changes required.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2011-04-11 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-3) unstable; urgency=low
* Add missing build-dependency to python-epydoc (Closes: #622228).
2011-04-08 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-2) unstable; urgency=low
* Split out -doc package (Closes: #620977):
- debian/control: New package entry.
- debian/examples, debian/python-openid.doc-base,
debian/python-openid.docs: Renamed.
- debian/rules: Adjust installation directories.
* debian/python-openid.preinst: Remove workaround for upgrading from
Lenny, as Squeeze is released.
* debian/source/format: Upgrade to 3.0 (quilt).
2011-03-25 - Mikhail Gusarov <dottedmag@debian.org>
python-openid (2.2.5-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Update my e-mail address.
- Update homepage as upstream moved to GitHub.
- Bump Standards-Version to 3.9.1, no changes required.
- Add python-epydoc to Build-Depends to generate documentation during
build.
* debian/watch:
- Update download URL as upstream moved to GitHub.
* debian/rules:
- Generate epydoc documentation during build.
2009-09-10 - Mikhail Gusarov <dottedmag@dottedmag.net>
python-openid (2.2.4-2) unstable; urgency=low
* debian/pycompat: remove useless file.
* debian/control:
- remove X[BS]-Python-Versions,
- bump Standards-Version to 3.8.3, no changes required.
* Rename debian/docs to debian/python-openid.docs.
* debian/rules:
- rewrite to use dh 7.
* debian/python-openid.doc-base: added.
2009-05-01 - Mikhail Gusarov <dottedmag@dottedmag.net>
python-openid (2.2.4-1) unstable; urgency=low
* New upstream release:
- removed build-extensions.patch, applied upstream,
- removed quilt dependency, unused.
- removed README.source, no more quilt.
* Switched to debian-support:
- added preinst script to de-register from pycentral.
* Standards-Version bumped to 3.8.1, no changes needed.
* python-all-dev build-dependency relaxed to python, as no binary
modules are built.
2009-02-17 - Mikhail Gusarov <dottedmag@dottedmag.net>
python-openid (2.2.1-3) unstable; urgency=low
* debian/copyright:
- replaced (C) with ©, as suggested by Lintian,
- debian packaging is under Apache-2.0 as well.
* debian/rules:
- replaced deprecated dh_clean -k with dh_prep,
- clean target now unpatches the source code.
* debian/control:
- expanded package description, as suggested by Lintian.
* debian/patches/build-extensions.patch:
- added description, as suggested by Lintian.
2009-02-04 - Mikhail Gusarov <dottedmag@dottedmag.net>
python-openid (2.2.1-2) unstable; urgency=medium
[ Mikhail Gusarov ]
* Fixed debian/copyright: library changed license to Apache-2.0
(Closes: #514064)
* debian/README.source added.
[ Sandro Tosi ]
* debian/control
- switch Vcs-Browser field to viewsvn

See Also

Package Description
python-openssl-doc_17.5.0-1ubuntu1_all.deb Python wrapper around the OpenSSL library (documentation package)
python-openssl_17.5.0-1ubuntu1_all.deb Python 2 wrapper around the OpenSSL library
python-openstackclient-doc_3.14.0-0ubuntu1_all.deb OpenStack Command-line Client - doc
python-openstackclient_3.14.0-0ubuntu1_all.deb OpenStack Command-line Client - Python 2.7
python-openstacksdk-doc_0.11.3+repack-0ubuntu1_all.deb SDK for building applications to work with OpenStack - doc
python-openstacksdk_0.11.3+repack-0ubuntu1_all.deb SDK for building applications to work with OpenStack - Python 2.x
python-openvswitch_2.9.0-0ubuntu1_all.deb Python bindings for Open vSwitch
python-os-brick-doc_2.3.0-0ubuntu1_all.deb Library for managing local volume attaches - doc
python-os-brick_2.3.0-0ubuntu1_all.deb Library for managing local volume attaches - Python 2.x
python-os-client-config-doc_1.29.0-0ubuntu1_all.deb OpenStack client configuration library - doc
python-os-client-config_1.29.0-0ubuntu1_all.deb OpenStack client configuration library - Python 2.x
python-os-service-types_1.1.0-0ubuntu2_all.deb Python library for consuming OpenStack sevice-types-authority data
python-os-traits_0.5.0-0ubuntu1_all.deb A library containing standardized trait strings for OpenStack
python-os-vif-doc_1.9.0-0ubuntu1_all.deb Integration library between network and compute - doc
python-os-vif_1.9.0-0ubuntu1_all.deb Integration library between network and compute - Python 2.7
Advertisement
Advertisement