python-oauthlib_2.0.6-1_all.deb


Advertisement

Description

python-oauthlib - generic, spec-compliant implementation of OAuth for Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-oauthlib
Package version 2.0.6
Package release 1
Package architecture all
Package type deb
Installed size 446 B
Download size 68.66 KB
Official Mirror archive.ubuntu.com
OAuthLib is a generic utility which implements the logic of OAuth without
assuming a specific HTTP request object. It can be used to graft OAuth support
onto HTTP libraries.
OAuth1 is almost complete while OAuth2 is already in the works.

Alternatives

Package Version Architecture Repository
python-oauthlib_2.0.6-1_all.deb 2.0.6 all Ubuntu Main
python-oauthlib - - -

Requires

Name Value
python-blinker -
python-cryptography -
python-jwt >= 1.0.0
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-oauthlib_2.0.6-1_all.deb
Source Package python-oauthlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-oauthlib deb package:
    # sudo apt-get install python-oauthlib

Files

Path
/usr/lib/python2.7/dist-packages/oauthlib/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/common.py
/usr/lib/python2.7/dist-packages/oauthlib/signals.py
/usr/lib/python2.7/dist-packages/oauthlib/uri_validate.py
/usr/lib/python2.7/dist-packages/oauthlib-2.0.6.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/oauthlib-2.0.6.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/oauthlib-2.0.6.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/oauthlib-2.0.6.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/errors.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/parameters.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/request_validator.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/signature.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/utils.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/access_token.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/authorization.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/base.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/pre_configured.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/request_token.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/resource.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth1/rfc5849/endpoints/signature_only.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/errors.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/parameters.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/request_validator.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/tokens.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/utils.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/backend_application.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/base.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/legacy_application.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/mobile_application.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/service_application.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/clients/web_application.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/authorization.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/base.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/pre_configured.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/resource.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/revocation.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/endpoints/token.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/__init__.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/authorization_code.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/base.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/client_credentials.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/implicit.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/openid_connect.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/refresh_token.py
/usr/lib/python2.7/dist-packages/oauthlib/oauth2/rfc6749/grant_types/resource_owner_password_credentials.py
/usr/share/doc/python-oauthlib/README.rst
/usr/share/doc/python-oauthlib/changelog.Debian.gz
/usr/share/doc/python-oauthlib/copyright

Changelog

2018-02-04 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (2.0.6-1) unstable; urgency=medium
* New upstream release.
* Bump debhelper compat level to 11.
* debian/control
- Bump Standards-Version to 4.1.3 (no changes needed).
* debian/copyright
- Use secure URI in format field.
- Update copyright years.
* debian/watch
- Use secure URI.
2017-09-26 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (2.0.4-1) unstable; urgency=medium
* New upstream release.
* Upload to unstable.
* Enable autopkgtest tests.
* debian/control
- Bump Standards-Version to 4.1.0 (no changes needed).
* debian/copyright
- Update copyright years.
2017-03-28 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (2.0.2-1) experimental; urgency=medium
* New upstream release.
* debian/control
- Bump X-Python-Version >= 2.7 and X-Python3-Version >= 3.4.
- Drop version for python-all.
2016-12-03 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (2.0.1-1) unstable; urgency=medium
* New upstream release.
2016-11-21 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (2.0.0-1) unstable; urgency=medium
* New upstream release.
2016-06-10 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (1.1.2-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Daniele Tricoli ]
* New upstream release.
* debian/control
- Bump Standards-Version to 3.9.8 (no changes needed).
* debian/copyright
- Update copyright years and upstream stanza.
2015-08-17 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (1.0.3-1) unstable; urgency=medium
* New upstream release (Closes: #795273).
* debian/rules
- Use PYBUILD_SYSTEM=custom inside override_dh_auto_test to not run
doctests since some docstrings can't be tested anymore.
- Use PYBUILD_NAME instead of PYBUILD_DESTDIR_python2 and
PYBUILD_DESTDIR_python3.
2015-07-20 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (1.0.0-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Switch Build-Depends and Depends from python{,3}-crypto to
python{,3}-cryptography.
- Bump python{,3}-jwt version to >= 1.0.0 in Build-Depends and Depends.
* debian/watch
- Use pypi.debian.net redirector.
2014-11-22 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (0.7.2-1) experimental; urgency=medium
* New upstream release.
* debian/control
- Add python{,3}-blinker to Build-Depends and Depends fields.
2014-10-07 - Daniele Tricoli <eriol@mornie.org>
python-oauthlib (0.6.3-1) unstable; urgency=medium
* New upstream release (Closes: #757630).
* debian/control
- Add python{,3}-jwt to Build-Depends and Depends fields.
- Bump Standards-Version to 3.9.6 (no changes needed)

See Also

Package Description
python-octaviaclient-doc_1.4.0-2_all.deb Octavia client for OpenStack Load Balancing - doc
python-octaviaclient_1.4.0-2_all.deb octavia client for OpenStack Load Balancing - Python 2.7
python-olefile_0.45.1-1_all.deb Python module to read/write MS OLE2 files
python-openid-doc_2.2.5-6_all.deb OpenID support for servers and consumers -- documentation
python-openid_2.2.5-6_all.deb OpenID support for servers and consumers
python-openssl-doc_17.5.0-1ubuntu1_all.deb Python wrapper around the OpenSSL library (documentation package)
python-openssl_17.5.0-1ubuntu1_all.deb Python 2 wrapper around the OpenSSL library
python-openstackclient-doc_3.14.0-0ubuntu1_all.deb OpenStack Command-line Client - doc
python-openstackclient_3.14.0-0ubuntu1_all.deb OpenStack Command-line Client - Python 2.7
python-openstacksdk-doc_0.11.3+repack-0ubuntu1_all.deb SDK for building applications to work with OpenStack - doc
python-openstacksdk_0.11.3+repack-0ubuntu1_all.deb SDK for building applications to work with OpenStack - Python 2.x
python-openvswitch_2.9.0-0ubuntu1_all.deb Python bindings for Open vSwitch
python-os-brick-doc_2.3.0-0ubuntu1_all.deb Library for managing local volume attaches - doc
python-os-brick_2.3.0-0ubuntu1_all.deb Library for managing local volume attaches - Python 2.x
python-os-client-config-doc_1.29.0-0ubuntu1_all.deb OpenStack client configuration library - doc
Advertisement
Advertisement