python-mako_1.0.7+ds1-1_all.deb


Advertisement

Description

python-mako - fast and lightweight templating for the Python platform

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-mako
Package version 1.0.7+ds1
Package release 1
Package architecture all
Package type deb
Installed size 311 B
Download size 58.70 KB
Official Mirror archive.ubuntu.com
Mako is a template library written in Python. It provides a familiar, non-XML
syntax which compiles into Python modules for maximum performance. Mako's
syntax and API borrows from the best ideas of many others, including Django
templates, Cheetah, Myghty, and Genshi. Conceptually, Mako is an embedded
Python (i.e. Python Server Page) language, which refines the familiar ideas of
componentized layout and inheritance to produce one of the most
straightforward and flexible models available, while also maintaining close
ties to Python calling and scoping semantics.

Alternatives

Package Version Architecture Repository
python-mako_1.0.7+ds1-1_all.deb 1.0.7+ds1 all Ubuntu Main
python-mako - - -

Requires

Name Value
python-markupsafe -
python2.7:any -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-mako_1.0.7+ds1-1_all.deb
Source Package mako

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mako deb package:
    # sudo apt-get install python-mako

Files

Path
/usr/bin/mako-render
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Mako-1.0.7.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/mako/__init__.py
/usr/lib/python2.7/dist-packages/mako/_ast_util.py
/usr/lib/python2.7/dist-packages/mako/ast.py
/usr/lib/python2.7/dist-packages/mako/cache.py
/usr/lib/python2.7/dist-packages/mako/cmd.py
/usr/lib/python2.7/dist-packages/mako/codegen.py
/usr/lib/python2.7/dist-packages/mako/compat.py
/usr/lib/python2.7/dist-packages/mako/exceptions.py
/usr/lib/python2.7/dist-packages/mako/filters.py
/usr/lib/python2.7/dist-packages/mako/lexer.py
/usr/lib/python2.7/dist-packages/mako/lookup.py
/usr/lib/python2.7/dist-packages/mako/parsetree.py
/usr/lib/python2.7/dist-packages/mako/pygen.py
/usr/lib/python2.7/dist-packages/mako/pyparser.py
/usr/lib/python2.7/dist-packages/mako/runtime.py
/usr/lib/python2.7/dist-packages/mako/template.py
/usr/lib/python2.7/dist-packages/mako/util.py
/usr/lib/python2.7/dist-packages/mako/ext/__init__.py
/usr/lib/python2.7/dist-packages/mako/ext/autohandler.py
/usr/lib/python2.7/dist-packages/mako/ext/babelplugin.py
/usr/lib/python2.7/dist-packages/mako/ext/beaker_cache.py
/usr/lib/python2.7/dist-packages/mako/ext/extract.py
/usr/lib/python2.7/dist-packages/mako/ext/linguaplugin.py
/usr/lib/python2.7/dist-packages/mako/ext/preprocessors.py
/usr/lib/python2.7/dist-packages/mako/ext/pygmentplugin.py
/usr/lib/python2.7/dist-packages/mako/ext/turbogears.py
/usr/share/doc/python-mako/changelog.Debian.gz
/usr/share/doc/python-mako/copyright
/usr/share/man/man1/mako-render.1.gz
/usr/share/python/dist/python-mako

Changelog

2017-07-14 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.7+ds1-1) unstable; urgency=medium
* New upstream release
* Standards-Version bumped to 4.0.0 (no changes needed)
2017-02-07 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.6+ds1-2) unstable; urgency=medium
* Update tests for Pygments 2.2 (closes: 852908, thanks to Gilles Filippini
for the patch) 
2016-12-21 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.6+ds1-1) unstable; urgency=medium
* New upstream release
2016-11-02 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.4+ds1-2) unstable; urgency=medium
* Fix FTBFS due to Sphinx API change (closes: 830178, thanks to Nishanth
Aravamudan for the patch)
2016-04-14 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.4+ds1-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Piotr Ożarowski ]
* New upstream release
* Replace python-nose with python-pytest (following upstream, this also
closes: #813668)
* Standards-Version bumped to 3.9.8 (no changes needed)
2015-10-31 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.3+ds1-1) unstable; urgency=medium
* New upstream release.
2015-08-26 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.2+ds1-1) unstable; urgency=medium
* New upstream release.
- remove python35-compat.patch - no longer needed
* Add debian/upstream/signing-key.asc
2015-08-26 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.1+ds1-1) unstable; urgency=medium
[ Barry Warsaw ]
* New upstream release.
* debian/patches/python35-compat.patch: Upstream provided patch to
fix compatibility issues with Python 3.5.
[ Piotr Ożarowski ]
* Convert debian/copyright to DEP-5 and use it to remove minified JS files
* Add dh-python to Build-Depends
* Standards-Version bumped to 3.9.6 (no changes needed)
2014-11-11 - Ivo De Decker <ivodd@debian.org>
mako (1.0.0+dfsg-0.1) unstable; urgency=medium
* Non-maintainer upload.
* Remove minified javascript files from upstream source. They are not used
in the build process. Closes: #722265
2014-06-10 - Piotr Ożarowski <piotr@debian.org>
mako (1.0.0-1) unstable; urgency=medium
* New upstream release
* Add python-changelog and python-sphinx-paramlinks to Build-Depends
(needed while rebuilding documentation)
* Enable Python 3.X tests during build (add necessary packages to
Build-Depends)
* Update links to upstream changelog (now points to changelog.rst)
* Add lintian override for source-is-missing doc/searchindex.js
(this file is generated by sphinx-build, all sources are in the tarball)

See Also

Package Description
python-manilaclient-doc_1.21.0-0ubuntu1_all.deb OpenStack shared file system as a service - client doc
python-manilaclient_1.21.0-0ubuntu1_all.deb OpenStack shared file system as a service - Python 2.7 client
python-markupsafe_1.0-1build1_amd64.deb HTML/XHTML/XML string library for Python
python-memcache_1.57-2_all.deb pure Python memcached client
python-microversion-parse-doc_0.1.4-2_all.deb OpenStack microversion header parsing library - doc
python-microversion-parse_0.1.4-2_all.deb OpenStack microversion header parsing library - Python 2.7
python-migrate-doc_0.11.0-2_all.deb Database schema migration for SQLAlchemy - doc
python-migrate_0.11.0-2_all.deb Database schema migration for SQLAlchemy - Python 2.7
python-mimeparse_0.1.4-3.1_all.deb Parse mime-types and quality parameters - python 2.x
python-minimal_2.7.15~rc1-1_amd64.deb minimal subset of the Python language (default version)
python-mistralclient_3.3.0-0ubuntu1_all.deb OpenStack Workflow as a Service client - Python 2.7
python-mock-doc_2.0.0-3_all.deb Mocking and Testing Library (Documentation)
python-mock_2.0.0-3_all.deb Mocking and Testing Library
python-moinmoin_1.9.9-1ubuntu1_all.deb Python clone of WikiWiki - library
python-monascaclient_1.10.0-0ubuntu1_all.deb client bindings for the Monasca API - Python 2.7
Advertisement
Advertisement