python-launchpadlib_1.10.6-1_all.deb


Advertisement

Description

python-launchpadlib - Launchpad web services client library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-launchpadlib
Package version 1.10.6
Package release 1
Package architecture all
Package type deb
Installed size 226 B
Download size 44.84 KB
Official Mirror archive.ubuntu.com
A free Python library for scripting Launchpad through its web services
interface.
It currently provides access to the following parts of Launchpad:
* People and Teams
* Team memberships
* Bugs and bugtasks
The Launchpad API is currently in beta, and may well change in ways
incompatible with this library.
You can find current API documentation at
https://help.launchpad.net/API/launchpadlib

Alternatives

Package Version Architecture Repository
python-launchpadlib_1.10.6-1_all.deb 1.10.6 all Ubuntu Main
python-launchpadlib - - -

Requires

Name Value
python-httplib2 >= 0.4.0
python-keyring >= 0.5
python-lazr.restfulclient >= 0.11.2
python-lazr.uri >= 1.0.2-4~
python-simplejson -
python-wadllib -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-launchpadlib_1.10.6-1_all.deb
Source Package python-launchpadlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-launchpadlib deb package:
    # sudo apt-get install python-launchpadlib

Files

Path
/usr/lib/python2.7/dist-packages/launchpadlib/__init__.py
/usr/lib/python2.7/dist-packages/launchpadlib/apps.py
/usr/lib/python2.7/dist-packages/launchpadlib/credentials.py
/usr/lib/python2.7/dist-packages/launchpadlib/errors.py
/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py
/usr/lib/python2.7/dist-packages/launchpadlib/uris.py
/usr/lib/python2.7/dist-packages/launchpadlib-1.10.6.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/launchpadlib-1.10.6.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/launchpadlib-1.10.6.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/launchpadlib-1.10.6.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/launchpadlib-1.10.6.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/launchpadlib/testing/__init__.py
/usr/lib/python2.7/dist-packages/launchpadlib/testing/helpers.py
/usr/lib/python2.7/dist-packages/launchpadlib/testing/launchpad.py
/usr/lib/python2.7/dist-packages/launchpadlib/testing/resources.py
/usr/lib/python2.7/dist-packages/launchpadlib/testing/tests/__init__.py
/usr/lib/python2.7/dist-packages/launchpadlib/testing/tests/test_launchpad.py
/usr/lib/python2.7/dist-packages/launchpadlib/tests/__init__.py
/usr/lib/python2.7/dist-packages/launchpadlib/tests/test_credential_store.py
/usr/lib/python2.7/dist-packages/launchpadlib/tests/test_http.py
/usr/lib/python2.7/dist-packages/launchpadlib/tests/test_launchpad.py
/usr/share/doc/python-launchpadlib/NEWS.Debian.gz
/usr/share/doc/python-launchpadlib/README.txt
/usr/share/doc/python-launchpadlib/changelog.Debian.gz
/usr/share/doc/python-launchpadlib/copyright
/usr/share/doc/python-launchpadlib/docs/command-line.txt
/usr/share/doc/python-launchpadlib/docs/hosted-files.txt
/usr/share/doc/python-launchpadlib/docs/introduction.txt.gz
/usr/share/doc/python-launchpadlib/docs/operations.txt
/usr/share/doc/python-launchpadlib/docs/people.txt.gz
/usr/share/doc/python-launchpadlib/docs/toplevel.txt
/usr/share/doc/python-launchpadlib/docs/files/mugshot.png

Changelog

2018-03-08 - Colin Watson <cjwatson@debian.org>
python-launchpadlib (1.10.6-1) unstable; urgency=medium
[ Colin Watson ]
* Team upload.
* New upstream release:
- Fix saving of credentials in python3 with gnome-keyring (closes:
#882166, LP: #1685962).
* Move VCS to salsa.debian.org.
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
2017-09-05 - Colin Watson <cjwatson@debian.org>
python-launchpadlib (1.10.5-1) unstable; urgency=medium
* Team upload.
* New upstream release:
- Fix fallback if authorizing a token with a browser raises
webbrowser.Error (LP: #1685549).
2016-08-13 - Dimitri John Ledkov <xnox@ubuntu.com>
python-launchpadlib (1.10.4-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Dimitri John Ledkov ]
* New upstream release
* Drop deprecated warnings patch, applied upstream
* Cherrypick upstream patch to fix LP: #1471927
2015-10-18 - Stefano Rivera <stefanor@debian.org>
python-launchpadlib (1.10.3-3) unstable; urgency=medium
* Fix test suite on Python 3.5 by ignoring PendingDeprecationWarnings from
lazr.restfulclient. (Closes: #802136).
2015-07-03 - Stefano Rivera <stefanor@debian.org>
python-launchpadlib (1.10.3-2) unstable; urgency=medium
* Upload to unstable.
* Bump copyright years.
* Drop XS-Testsuite header, now unnecessary.
* Bump Standards-Version to 3.9.6, no changes needed.
2014-12-19 - Dimitri John Ledkov <dimitri.j.ledkov@linux.intel.com>
python-launchpadlib (1.10.3-1) experimental; urgency=medium
* New upstream release.
* Drop using Files-Excluded, new upstream release tarball is cruft-less.
* Python 3 support.
* Switch to debhelper 9.
* Switch to pybuild.
* Drop patches accepted upstream
* Add python3 support to the auto-package test.
2014-01-21 - Stefano Rivera <stefanor@debian.org>
python-launchpadlib (1.10.2+ds-2) unstable; urgency=low
[ Stefano Rivera ]
* Upload to unstable.
* Bump Standards-Version to 3.9.5, no changes needed.
* Export HOME in the autopkgtest, cache is stored there.
* Verify upstream GPG signatures in watch file.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2013-01-12 - Stefano Rivera <stefanor@debian.org>
python-launchpadlib (1.10.2+ds-1) experimental; urgency=low
* New upstream release.
- Supports disabling SSL validation, by exporting
LP_DISABLE_SSL_CERTIFICATE_VALIDATION=1.
* Refresh patches.
* Repack to drop eggs directory (Filed LP#1098878)
* Upload to experimental, as wheezy is frozen.
* Bump Standards-Version to 3.9.4.
- Bump debhelper dependency to 8.1 for build-{arch,indep} support.
* Add autopkgtest to run test suite.
2012-05-03 - Stefano Rivera <stefanor@debian.org>
python-launchpadlib (1.9.12-2) unstable; urgency=low
* New maintainer.
* Clean properly (Closes: #671328).
- Remove egg-info.
* Bump Standards-Version to 3.9.3, no changes needed.
* Build-Depend on python-all rather than python.
* Make all versioned dependencies more backport-friendly, by stripping
debian-revisions or appending ~.
* Make watch file a little more robust.
* Wrap long lines in debian/control.
* Use machine readable copyright format.
* begone-ez_setup.patch: Friends don't let friends use ez_setup.
* Run unit tests during build.
- python-unittest2.patch: Use unittest backport package on Python <2.7.
- B-D on python-keyring, python-lazr.restfulclient, python-oauth,
python-simplejson, python-testresources, python-unittest2, and
python-wadllib.
2011-12-19 - Luca Falavigna <dktrkranz@debian.org>
python-launchpadlib (1.9.12-1) unstable; urgency=low
* New upstream release.
* debian/patches/auth_message.patch:
- Refresh for new upstream release.

See Also

Package Description
python-lazr.restfulclient_0.13.5-1_all.deb client for lazr.restful-based web services
python-lazr.uri_1.0.3-2build1_all.deb library for parsing, manipulating, and generating URIs
python-ldap_3.0.0-1_amd64.deb LDAP interface module for Python
python-ldb-dev_1.2.3-1_amd64.deb LDB Python bindings - development files
python-ldb_1.2.3-1_amd64.deb Python bindings for LDB
python-libvirt_4.0.0-1_amd64.deb libvirt Python bindings
python-libxml2_2.9.4+dfsg1-6.1ubuntu1_amd64.deb Python bindings for the GNOME XML library
python-libxslt1_1.1.29-5_amd64.deb Python bindings for libxslt1
python-linecache2_1.0.0-3_all.deb backports of the linecache module - Python 2.7
python-lockfile-doc_0.12.2-2_all.deb file locking library for Python — documentation
python-lockfile_0.12.2-2_all.deb file locking library for Python — Python 2 library
python-logutils-doc_0.3.3-5_all.deb handlers for the Python standard library's logging package - docs
python-logutils_0.3.3-5_all.deb handlers for the Python standard library's logging package - Python 2.x
python-lxml-doc_4.2.1-1_all.deb pythonic binding for the libxml2 and libxslt libraries (documentation)
python-lxml_4.2.1-1_amd64.deb pythonic binding for the libxml2 and libxslt libraries
Advertisement
Advertisement