python-kombu_4.1.0-1_all.deb


Advertisement

Description

python-kombu - AMQP Messaging Framework for Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-kombu
Package version 4.1.0
Package release 1
Package architecture all
Package type deb
Installed size 643 B
Download size 123.09 KB
Official Mirror archive.ubuntu.com
The aim of Kombu is to make messaging in Python as easy as possible by
providing an idiomatic high-level interface for the AMQP protocol. It is meant
to replace the carrot library by providing a compatibility layer.
Features:
* Allows application authors to support several message server solutions by
using pluggable transports.
* Supports automatic encoding, serialization and compression of message
payloads.
* The ability to ensure that an operation is performed by gracefully handling
connection and channel errors.

Alternatives

Package Version Architecture Repository
python-kombu_4.1.0-1_all.deb 4.1.0 all Ubuntu Main
python-kombu - - -

Requires

Name Value
python-amqp >= 1.4.6
python-anyjson >= 0.3.3
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-kombu_4.1.0-1_all.deb
Source Package kombu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-kombu deb package:
    # sudo apt-get install python-kombu

Files

Path
/usr/lib/python2.7/dist-packages/kombu/__init__.py
/usr/lib/python2.7/dist-packages/kombu/abstract.py
/usr/lib/python2.7/dist-packages/kombu/clocks.py
/usr/lib/python2.7/dist-packages/kombu/common.py
/usr/lib/python2.7/dist-packages/kombu/compat.py
/usr/lib/python2.7/dist-packages/kombu/compression.py
/usr/lib/python2.7/dist-packages/kombu/connection.py
/usr/lib/python2.7/dist-packages/kombu/entity.py
/usr/lib/python2.7/dist-packages/kombu/exceptions.py
/usr/lib/python2.7/dist-packages/kombu/five.py
/usr/lib/python2.7/dist-packages/kombu/log.py
/usr/lib/python2.7/dist-packages/kombu/message.py
/usr/lib/python2.7/dist-packages/kombu/messaging.py
/usr/lib/python2.7/dist-packages/kombu/mixins.py
/usr/lib/python2.7/dist-packages/kombu/pidbox.py
/usr/lib/python2.7/dist-packages/kombu/pools.py
/usr/lib/python2.7/dist-packages/kombu/resource.py
/usr/lib/python2.7/dist-packages/kombu/serialization.py
/usr/lib/python2.7/dist-packages/kombu/simple.py
/usr/lib/python2.7/dist-packages/kombu-4.1.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/kombu-4.1.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/kombu-4.1.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/kombu-4.1.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/kombu-4.1.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/kombu/async/__init__.py
/usr/lib/python2.7/dist-packages/kombu/async/debug.py
/usr/lib/python2.7/dist-packages/kombu/async/hub.py
/usr/lib/python2.7/dist-packages/kombu/async/semaphore.py
/usr/lib/python2.7/dist-packages/kombu/async/timer.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/__init__.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/connection.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/ext.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/sqs/__init__.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/sqs/connection.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/sqs/ext.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/sqs/message.py
/usr/lib/python2.7/dist-packages/kombu/async/aws/sqs/queue.py
/usr/lib/python2.7/dist-packages/kombu/async/http/__init__.py
/usr/lib/python2.7/dist-packages/kombu/async/http/base.py
/usr/lib/python2.7/dist-packages/kombu/async/http/curl.py
/usr/lib/python2.7/dist-packages/kombu/transport/SLMQ.py
/usr/lib/python2.7/dist-packages/kombu/transport/SQS.py
/usr/lib/python2.7/dist-packages/kombu/transport/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/base.py
/usr/lib/python2.7/dist-packages/kombu/transport/consul.py
/usr/lib/python2.7/dist-packages/kombu/transport/etcd.py
/usr/lib/python2.7/dist-packages/kombu/transport/filesystem.py
/usr/lib/python2.7/dist-packages/kombu/transport/librabbitmq.py
/usr/lib/python2.7/dist-packages/kombu/transport/memory.py
/usr/lib/python2.7/dist-packages/kombu/transport/mongodb.py
/usr/lib/python2.7/dist-packages/kombu/transport/pyamqp.py
/usr/lib/python2.7/dist-packages/kombu/transport/pyro.py
/usr/lib/python2.7/dist-packages/kombu/transport/qpid.py
/usr/lib/python2.7/dist-packages/kombu/transport/redis.py
/usr/lib/python2.7/dist-packages/kombu/transport/zookeeper.py
/usr/lib/python2.7/dist-packages/kombu/transport/sqlalchemy/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/sqlalchemy/models.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/__init__.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/base.py
/usr/lib/python2.7/dist-packages/kombu/transport/virtual/exchange.py
/usr/lib/python2.7/dist-packages/kombu/utils/__init__.py
/usr/lib/python2.7/dist-packages/kombu/utils/amq_manager.py
/usr/lib/python2.7/dist-packages/kombu/utils/collections.py
/usr/lib/python2.7/dist-packages/kombu/utils/compat.py
/usr/lib/python2.7/dist-packages/kombu/utils/debug.py
/usr/lib/python2.7/dist-packages/kombu/utils/div.py
/usr/lib/python2.7/dist-packages/kombu/utils/encoding.py
/usr/lib/python2.7/dist-packages/kombu/utils/eventio.py
/usr/lib/python2.7/dist-packages/kombu/utils/functional.py
/usr/lib/python2.7/dist-packages/kombu/utils/imports.py
/usr/lib/python2.7/dist-packages/kombu/utils/json.py
/usr/lib/python2.7/dist-packages/kombu/utils/limits.py
/usr/lib/python2.7/dist-packages/kombu/utils/objects.py
/usr/lib/python2.7/dist-packages/kombu/utils/scheduling.py
/usr/lib/python2.7/dist-packages/kombu/utils/text.py
/usr/lib/python2.7/dist-packages/kombu/utils/time.py
/usr/lib/python2.7/dist-packages/kombu/utils/url.py
/usr/lib/python2.7/dist-packages/kombu/utils/uuid.py
/usr/share/doc/python-kombu/FAQ
/usr/share/doc/python-kombu/NEWS.Debian.gz
/usr/share/doc/python-kombu/README.rst.gz
/usr/share/doc/python-kombu/changelog.Debian.gz
/usr/share/doc/python-kombu/copyright

Changelog

2017-11-04 - Thomas Goirand <zigo@debian.org>
kombu (4.1.0-1) unstable; urgency=medium
* Uploading to unstable.
* Ran wrap-and-sort -bast to minimize diffs.
* Added myself as uploader.
* Correctly builds sphinx doc in override_dh_sphinxdoc, and understand
build-profiles nodoc and nocheck..
* Removed useless X-Python-Version: >= 2.7 and X-Python3-Version: >= 3.3
fields.
* Standards-Version is now 4.1.1.
2017-07-30 - Michael Fladischer <fladi@debian.org>
kombu (4.1.0-1~exp1) experimental; urgency=low
* New upstream release.
* Remove repack script as upstream has merged the ICC profile removal.
* Add new upstream signing key.
* Add patch disabling intersphinx to prevent network requests during
build.
* Bump Standards-Version to 4.0.0.
* Remove Artistic and GPL-1+ licenses from d/copyright as
debian/repack.stub is no longer present.
2017-03-31 - Christopher Hoskin <mans0954@debian.org>
kombu (4.0.2+really4.0.2+dfsg-2) experimental; urgency=medium
[ Brian May ]
* Add missing build depends on python-vine and python3-vine.
Closes: #858540.
[ Christopher Hoskin ]
* Change package version to 4.0.2+really4.0.2+dfsg-2 after accidently
uploading to unstable rather than experimental
2017-03-21 - Christopher Hoskin <mans0954@debian.org>
kombu (4.0.2+dfsg-1) experimental; urgency=medium
* Refresh patches after git-dpm to gbp pq conversion
* Import new upstream release (4.0.2) 
* Remove redundant patches 
* Update build dependencies 
* Add myself to Uploaders 
* Update copyright file 
* Add patch to remove image from remote donation site (privacy issue) 
* Set http(s) proxys to localhost whilst building docs 
* Remove nose from build dependencies (pytest now used) 
* Remove nose from CI tests 
2017-03-24 - Christopher Hoskin <mans0954@debian.org>
kombu (4.0.2+really3.0.35+dfsg-2) unstable; urgency=medium
* Revert mistaken upload of 4.0.2 to unstable instead of experimental
2017-02-19 - Christopher Hoskin <mans0954@debian.org>
kombu (3.0.35+dfsg-2) unstable; urgency=medium
* Team upload.
* Fix "Non-Free ICC profiles in images" add repack scripts to remove
(Closes: #855502)
* Remove all egg-info in debian/clean 
* Add Artistic and GPL to debian/copyright for repack.stub 
* Bump standards version from 3.9.7 to 3.9.8 (no change required) 
2016-04-13 - Thomas Goirand <zigo@debian.org>
kombu (3.0.35-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Added missing build-depends-indep on python{3,}-funcsigs (Closes: #811477).
2016-04-06 - Brian May <bam@debian.org>
kombu (3.0.35-1) unstable; urgency=medium
* New upstream release.
2016-01-19 - Brian May <bam@debian.org>
kombu (3.0.33-1) unstable; urgency=medium
* New upstream release.
2016-01-02 - Michael Fladischer <fladi@debian.org>
kombu (3.0.32-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
python-launchpadlib_1.10.6-1_all.deb Launchpad web services client library
python-lazr.restfulclient_0.13.5-1_all.deb client for lazr.restful-based web services
python-lazr.uri_1.0.3-2build1_all.deb library for parsing, manipulating, and generating URIs
python-ldap_3.0.0-1_amd64.deb LDAP interface module for Python
python-ldb-dev_1.2.3-1_amd64.deb LDB Python bindings - development files
python-ldb_1.2.3-1_amd64.deb Python bindings for LDB
python-libvirt_4.0.0-1_amd64.deb libvirt Python bindings
python-libxml2_2.9.4+dfsg1-6.1ubuntu1_amd64.deb Python bindings for the GNOME XML library
python-libxslt1_1.1.29-5_amd64.deb Python bindings for libxslt1
python-linecache2_1.0.0-3_all.deb backports of the linecache module - Python 2.7
python-lockfile-doc_0.12.2-2_all.deb file locking library for Python — documentation
python-lockfile_0.12.2-2_all.deb file locking library for Python — Python 2 library
python-logutils-doc_0.3.3-5_all.deb handlers for the Python standard library's logging package - docs
python-logutils_0.3.3-5_all.deb handlers for the Python standard library's logging package - Python 2.x
python-lxml-doc_4.2.1-1_all.deb pythonic binding for the libxml2 and libxslt libraries (documentation)
Advertisement
Advertisement