python-keyrings.alt_3.0-1_all.deb


Advertisement

Description

python-keyrings.alt - alternate backend implementations for python-keyring

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-keyrings.alt
Package version 3.0
Package release 1
Package architecture all
Package type deb
Installed size 89 B
Download size 16.35 KB
Official Mirror archive.ubuntu.com
The Python keyring library provides an easy way to access the system keyring
service from Python. It can be used in any application that needs safe
password storage.
Keyrings.alt module contains the alternate keyring backend implementations
for use with python-keyring, most importantly the file backend which does
not need any external services to work.
Keyrings in this package may have security risks or other implications.
These backends were extracted from the main keyring project to make them
available for those who wish to employ them, but are discouraged for general
production use. Include this module and use its backends at your own risk.
This package contains the Python 2 version of keyrings.alt.

Alternatives

Package Version Architecture Repository
python-keyrings.alt_3.0-1_all.deb 3.0 all Ubuntu Main
python-keyrings.alt - - -

Requires

Name Value
python-crypto -
python-six -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-keyrings.alt_3.0-1_all.deb
Source Package keyrings.alt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-keyrings.alt deb package:
    # sudo apt-get install python-keyrings.alt

Files

Path
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/namespace_packages.txt
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/keyrings.alt-3.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/keyrings/alt/Gnome.py
/usr/lib/python2.7/dist-packages/keyrings/alt/Google.py
/usr/lib/python2.7/dist-packages/keyrings/alt/Windows.py
/usr/lib/python2.7/dist-packages/keyrings/alt/__init__.py
/usr/lib/python2.7/dist-packages/keyrings/alt/_win_crypto.py
/usr/lib/python2.7/dist-packages/keyrings/alt/file.py
/usr/lib/python2.7/dist-packages/keyrings/alt/file_base.py
/usr/lib/python2.7/dist-packages/keyrings/alt/keyczar.py
/usr/lib/python2.7/dist-packages/keyrings/alt/multi.py
/usr/lib/python2.7/dist-packages/keyrings/alt/pyfs.py
/usr/share/doc/python-keyrings.alt/CHANGES.rst.gz
/usr/share/doc/python-keyrings.alt/README.rst
/usr/share/doc/python-keyrings.alt/changelog.Debian.gz
/usr/share/doc/python-keyrings.alt/copyright
/usr/share/python/ns/python-keyrings.alt

Changelog

2018-02-22 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (3.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Dmitry Shachnev ]
* New upstream release.
* Do not ship keyrings/__init__.py files.
- For Python 3, the namespace can be implicit (per PEP 420).
- For Python 2, let dh_python2 generate this file in postinst.
* Add a warning from upstream README to the package descriptions.
* Update to debhelper compatibility level 11.
* Bump Standards-Version to 4.1.3, no changes needed.
2017-06-27 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (2.2-2) unstable; urgency=medium
* Bump Standards-Version to 4.0.0, no changes needed.
* Upload to unstable.
2017-03-27 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (2.2-1) experimental; urgency=medium
* New upstream release.
- Fixes compatibility with python-keyring 10.3.1.
* Add dependency on python[3]-six, following upstream.
* Drop dependency on python[3]-kde4, the KWallet 4 backend is now part
of main python-keyring package.
* Add tests/test_file.py and tests/test_Windows.py to pytest ignore list
for Python 2, to avoid dependency on backports.unittest_mock.
2016-12-14 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (1.3-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* Add build-dependency on python-fs, for the testsuite.
* Change license name in debian/copyright from MIT to Expat.
* New upstream release.
* Bump setuptools-scm dependency to ≥ 1.15.0, as required by setup.py.
* Tell pytest to exclude some files that cannot be imported.
* Bump Standards-Version to 3.9.8, no changes needed.
[ Ondřej Nový ]
* Depend on newer dh-python which sets SETUPTOOLS_SCM_PRETEND_VERSION
2016-03-02 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (1.1.1-1) unstable; urgency=medium
* New upstream release.
- Fixes tests failures (closes: #816306).
* Bump Standards-Version to 3.9.7, no changes needed.
2016-02-06 - Dmitry Shachnev <mitya57@debian.org>
keyrings.alt (1.1-1) unstable; urgency=medium
* Initial release (closes: #813291).

See Also

Package Description
python-keystone_13.0.0-0ubuntu1_all.deb OpenStack identity service - Python library
python-keystoneauth1-doc_3.4.0-0ubuntu1_all.deb authentication library for OpenStack Identity - doc
python-keystoneauth1_3.4.0-0ubuntu1_all.deb authentication library for OpenStack Identity - Python 2.7
python-keystoneclient-doc_3.15.0-0ubuntu1_all.deb client library for the OpenStack Keystone API - doc
python-keystoneclient_3.15.0-0ubuntu1_all.deb client library for the OpenStack Keystone API - Python 2.x
python-keystonemiddleware-doc_4.21.0-0ubuntu1_all.deb Middleware for OpenStack Identity (Keystone) - doc
python-keystonemiddleware_4.21.0-0ubuntu1_all.deb Middleware for OpenStack Identity (Keystone) - Python 2.x
python-kombu-doc_4.1.0-1_all.deb AMQP Messaging Framework for Python (Documentation)
python-kombu_4.1.0-1_all.deb AMQP Messaging Framework for Python
python-launchpadlib_1.10.6-1_all.deb Launchpad web services client library
python-lazr.restfulclient_0.13.5-1_all.deb client for lazr.restful-based web services
python-lazr.uri_1.0.3-2build1_all.deb library for parsing, manipulating, and generating URIs
python-ldap_3.0.0-1_amd64.deb LDAP interface module for Python
python-ldb-dev_1.2.3-1_amd64.deb LDB Python bindings - development files
python-ldb_1.2.3-1_amd64.deb Python bindings for LDB
Advertisement
Advertisement