python-jsonschema_2.6.0-2_all.deb


Advertisement

Description

python-jsonschema - An(other) implementation of JSON Schema (Draft 3 and 4) - Python 2.7

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-jsonschema
Package version 2.6.0
Package release 2
Package architecture all
Package type deb
Installed size 175 B
Download size 30.75 KB
Official Mirror archive.ubuntu.com
JSON Schema is a specification for a JSON-based format for defining
the structure of JSON data. JSON Schema provides a contract for what
JSON data is required for a given application and how it can be
modified, much like what XML Schema provides for XML. JSON Schema is
intended to provide validation, documentation, and interaction control
of JSON data.
This package contains the Python 2.7 module.

Alternatives

Package Version Architecture Repository
python-jsonschema_2.6.0-2_all.deb 2.6.0 all Ubuntu Main
python-jsonschema - - -

Requires

Name Value
python-functools32 -
python-mock -
python2.7:any -
python3-pkg-resources -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-jsonschema_2.6.0-2_all.deb
Source Package python-jsonschema

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-jsonschema deb package:
    # sudo apt-get install python-jsonschema

Files

Path
/usr/bin/python2-jsonschema
/usr/lib/python2.7/dist-packages/jsonschema/__init__.py
/usr/lib/python2.7/dist-packages/jsonschema/__main__.py
/usr/lib/python2.7/dist-packages/jsonschema/_format.py
/usr/lib/python2.7/dist-packages/jsonschema/_reflect.py
/usr/lib/python2.7/dist-packages/jsonschema/_utils.py
/usr/lib/python2.7/dist-packages/jsonschema/_validators.py
/usr/lib/python2.7/dist-packages/jsonschema/_version.py
/usr/lib/python2.7/dist-packages/jsonschema/cli.py
/usr/lib/python2.7/dist-packages/jsonschema/compat.py
/usr/lib/python2.7/dist-packages/jsonschema/exceptions.py
/usr/lib/python2.7/dist-packages/jsonschema/validators.py
/usr/lib/python2.7/dist-packages/jsonschema-2.6.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/jsonschema-2.6.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/jsonschema-2.6.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/jsonschema-2.6.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/jsonschema-2.6.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/jsonschema/schemas/draft3.json
/usr/lib/python2.7/dist-packages/jsonschema/schemas/draft4.json
/usr/lib/python2.7/dist-packages/jsonschema/tests/__init__.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/compat.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/test_cli.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/test_exceptions.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/test_format.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/test_jsonschema_test_suite.py
/usr/lib/python2.7/dist-packages/jsonschema/tests/test_validators.py
/usr/share/doc/python-jsonschema/README.rst
/usr/share/doc/python-jsonschema/changelog.Debian.gz
/usr/share/doc/python-jsonschema/copyright

Changelog

2017-11-15 - Ondřej Nový <onovy@debian.org>
python-jsonschema (2.6.0-2) unstable; urgency=medium
* Team upload.
* d/p/fixup-version.patch: Set version to 2.6.0 (Closes: #881833)
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.6.0-1) unstable; urgency=medium
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Updating maintainer field.
* Running wrap-and-sort -bast.
* Updating standards version to 4.0.0.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Correcting permissions in debian packaging files.
* Updating standards version to 4.0.1.
* Updating standards version to 4.1.0.
[ Ondřej Nový ]
* Bumped debhelper compat version to 10
[ Thomas Goirand ]
* New upstream release.
* Standards-Version is now 4.1.1.
* Using pkgos-dh_auto_install.
* Testing with all versions of Python 3.
* Refreshed version patch.
2016-10-04 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.5.1-6) unstable; urgency=medium
[ Ondřej Nový ]
* d/s/options: extend-diff-ignore of .gitreview
* d/control: Using OpenStack's Gerrit as VCS URLs.
[ Thomas Goirand ]
* Adding depends on python3-pkg-resources (Closes: #839075).
2016-05-19 - Ondřej Nový <novy@ondrej.org>
python-jsonschema (2.5.1-5) unstable; urgency=medium
* Team upload.
* Fixed VCS URLs (https).
* Mention Draft 4 support in package description (Closes: #816711)
* Removed d/CHANGELOG, upstream provides own changelog now
* Bumped Standards-Version to 3.9.8, no changes needed
* d/rules: Changed UPSTREAM_GIT protocol to https
2015-10-23 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.5.1-4) unstable; urgency=medium
* override_dh_python3 to fix Py3 shebang.
2015-10-16 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.5.1-3) unstable; urgency=medium
* Uploading to unstable.
2015-09-17 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.5.1-2) experimental; urgency=medium
* Fixed pacakge version parsing to be compatible with Ubuntu Trusty.
* Fixed http{s,}_proxy during dh_auto_clean to avoid PyPi downloads.
* Added python{3,}-vcversioner as build-depends-indep.
* Using update-alternatives to provide /usr/bin/jsonschema.
* Fixed missing ${python3:Depends}.
2015-07-29 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.5.1-1) experimental; urgency=medium
* New upstream release.
* Usual debian/control clean-up.
* Added python{3,}-vcversioner as build-depends.
* Creates version.txt on build, clean it on clean.
* Do not delete *egg-info on clean, use debian/source/options instead.
* Removed XS-Test-Suite in debian/control.
* Added python-functools32 as build-depends.
2015-04-15 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.4.0-1) unstable; urgency=medium
* New upstream release.
2013-12-08 - Thomas Goirand <zigo@debian.org>
python-jsonschema (2.3.0-1) unstable; urgency=low
[ Thomas Goirand ]
* New upstream release.
* Do not depend on openstack-pkg-tools anymore.
* Build-Depends on autopkgtest and python{3,}-pytest.
[ Jean-Baptiste Lallement ]
* Add autopkgtest that runs the upstream test suite against the installed
package (Closes: #729467)

See Also

Package Description
python-jwt_1.5.3+ds1-1_all.deb Python implementation of JSON Web Token
python-kazoo_2.2.1-1ubuntu1_all.deb higher level API to Apache Zookeeper (Python 2)
python-keyring_10.6.0-1_all.deb store and access your passwords safely
python-keyrings.alt_3.0-1_all.deb alternate backend implementations for python-keyring
python-keystone_13.0.0-0ubuntu1_all.deb OpenStack identity service - Python library
python-keystoneauth1-doc_3.4.0-0ubuntu1_all.deb authentication library for OpenStack Identity - doc
python-keystoneauth1_3.4.0-0ubuntu1_all.deb authentication library for OpenStack Identity - Python 2.7
python-keystoneclient-doc_3.15.0-0ubuntu1_all.deb client library for the OpenStack Keystone API - doc
python-keystoneclient_3.15.0-0ubuntu1_all.deb client library for the OpenStack Keystone API - Python 2.x
python-keystonemiddleware-doc_4.21.0-0ubuntu1_all.deb Middleware for OpenStack Identity (Keystone) - doc
python-keystonemiddleware_4.21.0-0ubuntu1_all.deb Middleware for OpenStack Identity (Keystone) - Python 2.x
python-kombu-doc_4.1.0-1_all.deb AMQP Messaging Framework for Python (Documentation)
python-kombu_4.1.0-1_all.deb AMQP Messaging Framework for Python
python-launchpadlib_1.10.6-1_all.deb Launchpad web services client library
python-lazr.restfulclient_0.13.5-1_all.deb client for lazr.restful-based web services
Advertisement
Advertisement