python-flask_0.12.2-3_all.deb


Advertisement

Description

python-flask - micro web framework based on Werkzeug and Jinja2 - Python 2.7

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-flask
Package version 0.12.2
Package release 3
Package architecture all
Package type deb
Installed size 286 B
Download size 60.62 KB
Official Mirror archive.ubuntu.com
Flask is a micro web framework for Python based on Werkzeug, Jinja 2 and good
intentions. A minimal Flask application looks like that:
from flask import Flask
app = Flask(__name__)
@app.route("/")
def hello():
return "Hello World!"
if __name__ == '__main__':
app.run()
This package contains the Python 2.7 module.

Alternatives

Package Version Architecture Repository
python-flask_0.12.2-3_all.deb 0.12.2 all Ubuntu Main
python-flask - - -

Requires

Name Value
python-click -
python-itsdangerous -
python-jinja2 -
python-werkzeug -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-flask_0.12.2-3_all.deb
Source Package flask

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-flask deb package:
    # sudo apt-get install python-flask

Files

Path
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Flask-0.12.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/flask/__init__.py
/usr/lib/python2.7/dist-packages/flask/__main__.py
/usr/lib/python2.7/dist-packages/flask/_compat.py
/usr/lib/python2.7/dist-packages/flask/app.py
/usr/lib/python2.7/dist-packages/flask/blueprints.py
/usr/lib/python2.7/dist-packages/flask/cli.py
/usr/lib/python2.7/dist-packages/flask/config.py
/usr/lib/python2.7/dist-packages/flask/ctx.py
/usr/lib/python2.7/dist-packages/flask/debughelpers.py
/usr/lib/python2.7/dist-packages/flask/exthook.py
/usr/lib/python2.7/dist-packages/flask/globals.py
/usr/lib/python2.7/dist-packages/flask/helpers.py
/usr/lib/python2.7/dist-packages/flask/json.py
/usr/lib/python2.7/dist-packages/flask/logging.py
/usr/lib/python2.7/dist-packages/flask/sessions.py
/usr/lib/python2.7/dist-packages/flask/signals.py
/usr/lib/python2.7/dist-packages/flask/templating.py
/usr/lib/python2.7/dist-packages/flask/testing.py
/usr/lib/python2.7/dist-packages/flask/views.py
/usr/lib/python2.7/dist-packages/flask/wrappers.py
/usr/lib/python2.7/dist-packages/flask/ext/__init__.py
/usr/lib/python2.7/dist-packages/flaskext/__init__.py
/usr/share/doc/python-flask/changelog.Debian.gz
/usr/share/doc/python-flask/copyright
/usr/share/python/dist/python-flask

Changelog

2018-01-15 - Ondřej Nový <onovy@debian.org>
flask (0.12.2-3) unstable; urgency=medium
* Change priority from extra to optional
* Standards-Version is 4.1.3 now
* Remove unwanted license file from docs
* debian/patches/0003-Don-t-rely-on-X-Requested-With-for-pretty-print-json.patch:
Fix FTBFS (Closes: #884523)
* Bump debhelper compat level to 11
* Use Python 3 version of Sphinx for building docs
2017-07-09 - Ondřej Nový <onovy@debian.org>
flask (0.12.2-2) unstable; urgency=medium
* Added Python 3.6 support for tests (Closes: #867482)
* Standards-Version is 4.0.0.4 now (no changes needed)
2017-06-20 - Ondřej Nový <onovy@debian.org>
flask (0.12.2-1) unstable; urgency=medium
* New upstream bugfix release
* d/control: Cleanup long description of python-flask-doc
2017-04-13 - Ondřej Nový <onovy@debian.org>
flask (0.12.1-1) unstable; urgency=medium
* New upstream bugfix release
* Use SOURCE_DATE_EPOCH for copyright year to make build reproducible
2016-12-25 - Ondřej Nový <onovy@debian.org>
flask (0.12-1) unstable; urgency=medium
* New upstream release
* Bumped debhelper version to 10
2016-07-19 - Piotr Ożarowski <piotr@debian.org>
flask (0.11.1-1) unstable; urgency=medium
[ Ondřej Nový ]
* New upstream release
* Fixed VCS URL (https)
* Bumped Standards-Version to 3.9.8 (no changes needed)
* Use extend-diff-ignore for egg-info instead of removing it
* d/copyright
- Converted to DEP5 format
- Added myself for Debian part
* Removed patches applied upstream:
- d/p/fix_test_appcontext_signals.patch
- d/p/fix_test_json_key_sorting.patch
* Added python{3,}-click and python{3,}-pytest to build depends
* Bumped required Python 2 version to 2.6
* Enabled autopkgtest-pkg-python testsuite
* Use override_dh_sphinxdoc for building Sphinx docs and added nodocs
support
* Use LC_ALL=C.UTF-8 when running tests, Click is failing on non UTF-8
locale
* Bumped required version of dh-python to 2.20160609~
* Added /usr/share/doc/python-flask-doc/rst symlink
* Removed override_dh_auto_clean and override_dh_python3 (not needed)
* Install /usr/bin/flask CLI only to python3-flask package
* Make python-flask and python3-flask descriptions distinct
* Removed all pre-wheezy version compare from dependency
* Removed python-simplejson from build-depends/recommends
* Added python3-blinker to build-depends/recommends
* Removed d/python-flask.pyremove (not needed)
* d/watch: Changed to pypi.debian.net
* Removed site_egg directory
[ Piotr Ożarowski ]
* Make sure sphinx-build doesn't access network
* Add Ondřej Nový to Uploaders
2013-08-08 - Piotr Ożarowski <piotr@debian.org>
flask (0.10.1-2) unstable; urgency=low
* Add python3-flask binary package
* Add python-blinker to Recommends (used in flask.signals)
* Switch to pybuild buildsystem
* Add fix_test_appcontext_signals and fix_test_json_key_sorting patches
and enable tests at build time (patches taken from upstream repo)
2013-06-16 - Piotr Ożarowski <piotr@debian.org>
flask (0.10.1-1) unstable; urgency=low
* New upstream release
* Add python-itsdangerous to Build-Depends and let dh_python2
add it to Depends
2013-05-05 - Piotr Ożarowski <piotr@debian.org>
flask (0.9-2) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Piotr Ożarowski ]
* Add python-flask-doc binary package (closes: #703802)
* debian/compat bumped to 9
* Standards-Version bumped to 3.9.4 (no changes needed)
* upload to unstable
2012-08-03 - Piotr Ożarowski <piotr@debian.org>
flask (0.9-1) experimental; urgency=low
* New upstream release
- upload to experimental due to Wheezy freeze
* remove flask/testsuite from binary package (it's doesn't work outside
build directory)
* Standards-Version bumped to 3.9.3 (no changes needed)

See Also

Package Description
python-formencode_1.3.0-0ubuntu5_all.deb validation and form generation Python package
python-funcsigs-doc_1.0.2-4_all.deb function signatures from PEP362 - doc
python-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - Python 2.7
python-functools32_3.2.3.2-3_all.deb Backport of the functools module from Python 3.2.3 to Python 2.7
python-future-doc_0.15.2-4ubuntu2_all.deb Clean single-source support for Python 3 and 2 - doc
python-future_0.15.2-4ubuntu2_all.deb single-source support for Python 3 and 2 - Python 2.x
python-futurist-doc_1.6.0-0ubuntu1_all.deb useful additions to futures, from the future - doc
python-futurist_1.6.0-0ubuntu1_all.deb useful additions to futures, from the future - Python 2.x
python-gdbm_2.7.15~rc1-1_amd64.deb GNU dbm database support for Python
python-genshi-doc_0.7-6_all.deb Python XML-based template engine (documentation and examples)
python-gi-dev_3.26.1-2_amd64.deb development headers for GObject Python bindings
python-gi_3.26.1-2_amd64.deb Python 2.x bindings for gobject-introspection libraries
python-glance-doc_16.0.0-0ubuntu1_all.deb OpenStack Image Registry and Delivery Service - Documentation
python-glance-store-doc_0.23.0-0ubuntu1_all.deb OpenStack Image Service store library - doc
python-glance-store_0.23.0-0ubuntu1_all.deb OpenStack Image Service store library - Python 2.7
Advertisement
Advertisement