python-egenix-mxproxy_3.2.9-1_amd64.deb


Advertisement

Description

python-egenix-mxproxy - generic proxy wrapper type for Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-egenix-mxproxy
Package version 3.2.9
Package release 1
Package architecture amd64
Package type deb
Installed size 77 B
Download size 15.83 KB
Official Mirror archive.ubuntu.com
mxProxy is an extension package that provides a new type that is
suitable to implement Bastion like features without the need to use
restricted execution environments.
Given that current Python versions no longer support Bastion or rexec
as secure sand-box execution models, mxProxy fills an important
gap. It also gives the programmer more control over how and to what
extent access should be controlled or not.

Alternatives

Package Version Architecture Repository
python-egenix-mxproxy_3.2.9-1_i386.deb 3.2.9 i386 Ubuntu Main
python-egenix-mxproxy - - -

Requires

Name Value
libc6 >= 2.4
python >= 2.7
python << 2.8
python-egenix-mxtools -

Conflicts

Name Value
python2.3-egenix-mxproxy -
python2.4-egenix-mxproxy -

Replaces

Name Value
python2.3-egenix-mxproxy -
python2.4-egenix-mxproxy -

Download

Type URL
Binary Package python-egenix-mxproxy_3.2.9-1_amd64.deb
Source Package egenix-mx-base

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-egenix-mxproxy deb package:
    # sudo apt-get install python-egenix-mxproxy

Files

Path
/usr/lib/python2.7/dist-packages/mx/Proxy/Proxy.py
/usr/lib/python2.7/dist-packages/mx/Proxy/__init__.py
/usr/lib/python2.7/dist-packages/mx/Proxy/mxProxy/__init__.py
/usr/lib/python2.7/dist-packages/mx/Proxy/mxProxy/mxProxy.so
/usr/lib/python2.7/dist-packages/mx/Proxy/mxProxy/test.py
/usr/lib/python2.7/dist-packages/mx/Proxy/mxProxy/testvlad.py
/usr/lib/python2.7/dist-packages/mx/Proxy/mxProxy/weakreftest.py
/usr/share/doc/python-egenix-mxproxy/README.Debian
/usr/share/doc/python-egenix-mxproxy/changelog.Debian.gz
/usr/share/doc/python-egenix-mxproxy/copyright

Changelog

2015-10-24 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.9-1) unstable; urgency=medium
* New upstream release 3.2.9
2014-10-24 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.8-1) unstable; urgency=low
* New upstream release 3.2.8
* Update Standards-Version to 3.9.6 (no changes required)
2013-12-10 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.7-1) unstable; urgency=low
* New upstream release 3.2.7
2013-10-02 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.6-1) unstable; urgency=low
* New upstream release 3.2.6 (closes: #725180)
* Update Standards-Version to 3.9.4 (no changes required)
2012-11-28 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.5-1) unstable; urgency=low
* New upstream release 3.2.5 (closes: #664686)
* Update Standards-Version to 3.9.3 (no changes required)
* Remove lintian overrides again since they apparently no longer are needed
2012-11-25 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.4-1) unstable; urgency=low
* New upstream release 3.2.4
* Update watch file to work with new upstream directory index page
* Add X-Python-Version control field
* Build with flags from /usr/share/dpkg/buildflags.mk for hardening
2011-09-14 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.1-1) unstable; urgency=low
* New upstream release (closes: #641441)
2011-07-03 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.2.0-1) unstable; urgency=low
* New upstream release (closes: #494792)
* Add working debian/watch file
* Remove unnecessary ${shlibs:Depends} for doc packages
* Add ${python:Depends} again
2011-06-26 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.1.3-5) unstable; urgency=low
* Convert from dh_pycentral to dh_python2 (closes: #616798)
* Remove unused ${python:Depends} and ${python:Provides}
* Add build-arch and build-indep targets to debian/rules
* Use debhelper compat level 8
* Add dummy watch file explaining why there's no watch file
* Bump Standards-Version to 3.9.2
* Add small comments that the dbg packages are normally not needed
* Add dependency to the python package since we have some scripts as well
2010-05-16 - Joel Rosdahl <joel@debian.org>
egenix-mx-base (3.1.3-4) unstable; urgency=low
* Split documentation into -doc packages. Closes: #570531.

See Also

Package Description
python-egenix-mxqueue-doc_3.2.9-1_all.deb fast and memory-efficient queue for Python (documentation)
python-egenix-mxqueue_3.2.9-1_amd64.deb fast and memory-efficient queue for Python
python-egenix-mxstack-doc_3.2.9-1_all.deb fast and memory-efficient stack for Python (documentation)
python-egenix-mxstack_3.2.9-1_amd64.deb fast and memory-efficient stack for Python
python-egenix-mxtexttools-doc_3.2.9-1_all.deb fast text processing tools for Python (documentation)
python-egenix-mxtexttools_3.2.9-1_amd64.deb fast text processing tools for Python
python-egenix-mxtools-doc_3.2.9-1_all.deb collection of additional builtins for Python (documentation)
python-egenix-mxtools_3.2.9-1_amd64.deb collection of additional builtins for Python
python-egenix-mxuid-doc_3.2.9-1_all.deb unique identifiers for Python (documentation)
python-egenix-mxuid_3.2.9-1_amd64.deb unique identifiers for Python
python-egenix-mxurl-doc_3.2.9-1_all.deb flexible URL datatype for Python (documentation)
python-egenix-mxurl_3.2.9-1_amd64.deb flexible URL datatype for Python
python-enum34-doc_1.1.6-2_all.deb backport of Python 3.4's enum package (documentation)
python-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package
python-eventlet-doc_0.20.0-4_all.deb concurrent networking library - doc
Advertisement
Advertisement